WSAStartup kaputt?

KraetziChriZ

Lt. Commander
Dabei seit
Dez. 2004
Beiträge
1.832
Hi,

Habe ein abstruses Problem. Habe gestern nichts anderes gemacht als ein neues Antivir auf meinem SPiele-PC mit Windows XP installiert, und seid heute kann ich nicht mehr surfen.

3 Dienste verrusachen Fehlermeldungen beim Start (in der Log einsehbar) die alle auf WSASTartup zurückzuführen sind.

Netzwerk funktioniert - surfen über den Router nicht. An anderen PC's funktioniert alles einwandfrei. Kann also nicht am Router liegne. Wenn ich auf DHCP umstelle, kommt auch eine Fehlermeldung, das WSAStartup kaputt ist, und deshalb die IP nciht bezogen werden kann??

Siehe: http://mitglied.lycos.de/chrizwlz/windoof.JPG

Ich bin mit Google nicht weitergekommen, habe nur leute mit selben Problem gefunden.

Da ich Linuxler bin, kenne ich eine Neuinstallation nicht. Ich brauchte dies noch nie tun (von Linux) und würde mein Windoof auch geren weiter benutzen.

Evtl. kann mir jemand helfen.

gruß
chris
 

VanNelle

Newbie
Dabei seit
Juni 2007
Beiträge
2
Ich hatte gehofft, hier eine Antwort auf das Problem von Chris mit der WSAStartup Funktion zu finden ...
Habe das gleiche Problem. Komme auf den Router - aber nicht mehr raus. IPCONFIG und die Ereignissanzeige (Systemsteuerung) weisen beide auf WSAStartup hin. Habe die winsock.dll und die wsock32.dll schon von einem anderen Rechner rüberkopiert. Mehr fällt mir (und meinem Computerdealer) nicht mehr ein - außer einer Neuinstallation.
Weiß jemand Rat?

VanNelle
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.808
Du kannst es mal mit einer Reparaturinstallation versuchen oder Systemwiederherstellung zu einem Zeitpunkt als es noch lief.
 

VanNelle

Newbie
Dabei seit
Juni 2007
Beiträge
2
Mensch - auf so eine einfache Idee, wie die Systemwiederherstellung bin ich gar nicht gekommen. Prima ... dachte ich ...
Dummerweise fährt nach der Systemwiederherstellung die Benutzeroberflächer nicht mehr hoch :( Ich komme noch bis zur Anmeldung - dann läd der Desktophintergrund - dann ist Schluß. Kein Icon, keine Kommandozeile. Lediglich den Taskmanager kann ich noch über die Tastenkombi starten. Das war's dann wohl mit dieser Win-Installation.
Dummerweise ist das Notebook von Acer. Ohne Win-CD. Ist ja alles auf der Platte, sagt Acer. Kein guter Witz :mad:
 
Top