ASRock B450-Bios: Kommt da noch was für Raven Ridge?

barmbekersurfer

Lt. Junior Grade
Dabei seit
Juni 2018
Beiträge
374
Moin liebe Gemeinde,

in meinem vor zwei Monaten von mir selbst zusammengeschraubten PC steckt folgendes Mainboard:

ASRock B450M Pro4

Unter Windows läuft der Rechner im Großen und Ganzen stabil. Mit Linux habe ich dagegen viele Probleme, die sich auch mit diversen Tipps und Tricks nicht lösen lassen.

Da ich einen Ryzen 2400G verbaut habe, darf ich - laut ASRock-Webseite - nur bis zur BIOS-Version 3.5 upgraden. Das ist schade, da die neueste Version 3.6 offenbar Linux-Distributionen vernünftig unterstützt, wie ich in einer Mindfactory-Rezension lesen konnte:

Habe das Board Mitte August gekauft und zu dem Zeitpunkt war schon eine für Ryzen 3000 taugliche BIOS Version drauf. In der Zwischenzeit hat ASRock noch ein BIOS nachgelegt, mit dem auch aktuelle Linux-Distributionen keine Probleme mehr machen.

Meine Frage an Euch: Könnte es sein, dass ASRock noch ein BIOS-Upgrade auflegt, dass auch Raven Ridge-kompatibel ist?

Statt Abwarten wäre auch der 3400G eine Option. Was meint Ihr?
 

Xero261286

Commander
Dabei seit
Mai 2016
Beiträge
2.207
Woher soll das hier jemand Wissen?

Geh auf ASRock.com, Klick auf "Kontaktieren Sie uns", Klick dort auf "Für technische Unterstützung klicken Sie bitte hier", Füll das Formular aus und schick das ganze ab.
 

ghecko

Admiral
Dabei seit
Juli 2008
Beiträge
8.108
Habe das Board Mitte August gekauft und zu dem Zeitpunkt war schon eine für Ryzen 3000 taugliche BIOS Version drauf. In der Zwischenzeit hat ASRock noch ein BIOS nachgelegt, mit dem auch aktuelle Linux-Distributionen keine Probleme mehr machen.
Ich glaube das liegt weniger am Bios und eher an der verbauten CPU. Ich habe dasselbe Mainboard mit einem 2700, läuft einwandfrei mit dem 3.50er Bios unter Xubuntu 18.04.1

Um welche Probleme handelt es sich? Welche Distribution nutzt du in welcher Version?
Ich glaube eher dein Kernel/Mesastack ist zu alt für die APU.
 
Zuletzt bearbeitet:

mibbio

Ensign
Dabei seit
Juli 2016
Beiträge
189

barmbekersurfer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2018
Beiträge
374
Geh auf ASRock.com, Klick auf "Kontaktieren Sie uns", Klick dort auf "Für technische Unterstützung klicken Sie bitte hier", Füll das Formular aus und schick das ganze ab.
Danke, guter Tipp. Anfrage ist raus. Mal gucken, ob und was da zurückkommt.

Um welche Probleme handelt es sich? Welche Distribution nutzt du in welcher Version?
Ich habe alle Ubuntu/Derivate (Eoan Ermine) durchprobiert. Nach Grub bleibt der Bildschirm schwarz. Seltsamerweise fährt Linux dann manchmal doch hoch, unabhängig von der Distribution.

Ich habe dasselbe Mainboard mit einem 2700, läuft einwandfrei mit dem 3.50er Bios unter Xubuntu 18.04.1
Grr. Xubuntu mag ich auch sehr gerne. Also doch die APU gegen 3400G tauschen? Ich kann halt den 2400G nicht reklamieren, weil Windows 10 Home stabil läuft. Grrrrr.
 

ghecko

Admiral
Dabei seit
Juli 2008
Beiträge
8.108
Ich bezweifle dass der Tausch viel bringt da der Unterschied zwischen den APUs gering ist, die neue Gen aber wiederum neuere (Linux) Software erfordert. Wobei ich es seltsam finde dass du mit einigermaßen modernen Distris auf der APU Probleme hast. Mein Dad arbeitet mit dem 2400G, ebenfalls unter Xubuntu (wobei ich ihm 19.04 installiert hab) und das läuft einwandfrei. Allerdings auf einem anderen Mainboard.
Sicher dass nicht irgendeine Securebootgeschichte aktiv ist?
 

barmbekersurfer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2018
Beiträge
374
@ghecko
Eigentlich müsste ich im BIOS alles durchprobiert haben. Aber vielleicht sollte ich doch noch mal einen Linux-Freak, der das UEFI durchcheckt, ansprechen. Könnte ja sein, dass ich was falsch mache.
 
Zuletzt bearbeitet:

Sebastian_12

Lieutenant
Dabei seit
Jan. 2009
Beiträge
940
Moin liebe Gemeinde,

in meinem vor zwei Monaten von mir selbst zusammengeschraubten PC steckt folgendes Mainboard:

ASRock B450M Pro4

Unter Windows läuft der Rechner im Großen und Ganzen stabil. Mit Linux habe ich dagegen viele Probleme, die sich auch mit diversen Tipps und Tricks nicht lösen lassen.

Da ich einen Ryzen 2400G verbaut habe, darf ich - laut ASRock-Webseite - nur bis zur BIOS-Version 3.5 upgraden. Das ist schade, da die neueste Version 3.6 offenbar Linux-Distributionen vernünftig unterstützt, wie ich in einer Mindfactory-Rezension lesen konnte:

Habe das Board Mitte August gekauft und zu dem Zeitpunkt war schon eine für Ryzen 3000 taugliche BIOS Version drauf. In der Zwischenzeit hat ASRock noch ein BIOS nachgelegt, mit dem auch aktuelle Linux-Distributionen keine Probleme mehr machen.

Meine Frage an Euch: Könnte es sein, dass ASRock noch ein BIOS-Upgrade auflegt, dass auch Raven Ridge-kompatibel ist?

Statt Abwarten wäre auch der 3400G eine Option. Was meint Ihr?
Was ist den genau das problem ?
 

barmbekersurfer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2018
Beiträge
374
Ich möchte ein Linux-Live-System vom USB-Stick starten und nach dem Booten installieren. Mal fährt der PC hoch, mal bleibt der Bildschirm nach Grub schwarz, unabhängig von der Linux-Distribution. Ich kann den Fehler nicht weiter eingrenzen.
 

rupfy

Ensign
Dabei seit
Dez. 2008
Beiträge
179
ich habe die meldung bei asrock immer so verstanden, dass das update für alle cpus, außer matisse, nicht empfohlen wird, weil es einfach 0 unterschied macht. und nicht weil das die anderen irgendwie einschränkt.
 

ghecko

Admiral
Dabei seit
Juli 2008
Beiträge
8.108
Nein, der hat ein ITX-Board von Gigabyte.

ich habe die meldung bei asrock immer so verstanden, dass das update für alle cpus, außer matisse, nicht empfohlen wird, weil es einfach 0 unterschied macht. und nicht weil das die anderen irgendwie einschränkt.
Es ist tatsächlich so, das Microcode für die älteren CPUs fehlt. Hab aus Dummheit 3.60 auf mein Mobo gespielt und hatte dann nur sehr eingeschränkten RAM-Support.
 
Zuletzt bearbeitet:

barmbekersurfer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2018
Beiträge
374
Hm, dann werde ich mal abwarten, ob von ASRock eine freundliche Mail zurückkommt, in der steht, das auch die 3.5 volle Linux-Unterstützung bietet und keine weiteren Upgrades für die alten Ryzens geplant sind. ;)

Ach Mensch, wie mich das ärgert und beschäftigt ... Trotzdem vielen Dank für Eure Kommentare. Nun bin ich wenigstens gedanklich etwas weiter.
 

fixedwater

Lt. Commander
Dabei seit
Feb. 2018
Beiträge
1.251
Ich vermute auch wie @ghecko schon angemerkt hat, dass es eher am verwendeten Kernel als am Bios des Boards liegt. Kernel 5.3 ist wohl empfehlenswert - und dieser ist nicht imer out of the Box vorhanden. Wobei ich hier lesen konnte, dass anscheinend Ryzen 3 3200G und 3400G besser laufen als die älteren APUs... Bin mal gespannt - ich will wohl auch das oben genannte Board in meinem neuen System verbauen... ob mit APU oder nicht, ich schwanke noch ;)
 

ghecko

Admiral
Dabei seit
Juli 2008
Beiträge
8.108
Zuletzt bearbeitet:

fixedwater

Lt. Commander
Dabei seit
Feb. 2018
Beiträge
1.251
Ich habe alle Ubuntu/Derivate (Eoan Ermine) durchprobiert. Nach Grub bleibt der Bildschirm schwarz. Seltsamerweise fährt Linux dann manchmal doch hoch, unabhängig von der Distribution.
Siehe oben: Es gab kurz nach Erscheinen des 2200G/2400G Probleme mit den integrierten Grafikeinheiten. Sollte bei den aktuellen Distris aber kein Problem mehr sein. Hast Du irgendeine olle Grafikkarte zur Hand? Probiers dann mal damit und schalt die interne Grafik der APU ab...
 

Ratz_Fatz

Lieutenant
Dabei seit
Mai 2011
Beiträge
1.022
Schau im Bios nach Iommu, die sollte auf "Auto" oder "Enabled" gestellt sein.

Ich habe mit dem AMD 3200G in machen Fällen auch einen schwarzen Bildschirm. Wenn ich dann etwas über 1 Minute warte, dann wird Gnome geladen, allerdings nur xorg, es ist kein Wayland vorhanden. Es ist genau die Wartezeit, die ich bei einer defekten NVME hatte, also vielleicht hat das dann mit PCIe Problemen zu tun.

Du kannst dem Kernel Startoptionen hinzufügen. Siehe hier.

Ich würde mal folgende ausprobieren und schauen wie sich das System verhält.

Code:
amd_iommu=soft noapic pci=nocrs acpi_osi=Linux
Code:
amd_iommu=soft nomodeset pci=nocrs
 
Zuletzt bearbeitet:
Top