Externe Festplatte defekt?

Babididu

Newbie
Dabei seit
Mai 2010
Beiträge
7
Hallo,

habe mich nun schon durch so einige Threads hier durchgearbeitet und denke, dass mein Problem mit meiner ext. Festplatte kein ungewöhnliches Problem ist. Dennoch habe ich Fragen.
Hier mein Problemfall:
Zur Zeit wird meine externe Festplatte von Western Digital 1TB zwar als USB-Massenspeichergerät erkannt, allerdings ohne Laufwerkszuordnung. Im Gerätemanager ist die Platte unter den Laufwerken aufgeführt und scheint kein Problem zu haben. Aber in der Datenträgerverwaltung von WinXP) wird der Datenträger nicht angezeigt. Versuche ich es unter Windows Vista wird in der Datenträgerverwaltung angezeigt, dass der Datenträger initialisiert werden müsste, was aber nicht funktioniert.

Nun habe ich mit TestDisk mal geschaut, was da so geht. Ein Log kann ich später nachreichen, TestDisk läuft gerade, was mich zu meinen Fragen führt:
TestDisk zeigt an, dass die WD-Platte 2TB groß sei, genauer: 2199 GB. Was nicht stimmen dürfte, da es sich ja um eine 1TB-Platte handelt.
Ist das normal oder schon ein Problem?

Zweite Frage:
Ich habe die Analyse mit TestDisk vor einer halben Stunde gestartet und er ist noch nichtmal bei 1%. Naja, die Anzahl der Cylinder ist eine 10-stellige Zahl und die Anzahl der analysierten Cylinder ist im Moment gerade mal 7-stellig. Das kann also noch was dauern bis die Analyse fertig ist.
Es werden bisher nur Read error ausgegeben.
Ist auch das normal? Oder kann ich die Analyse abbrechen, weil sie nix bringen wird?
 
P

phelix

Gast
Das erste, was ich gemacht hätte, wäre sie intern anzuschließen.
 

Babididu

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
7
Da müsste ich ja das Gehäuse aufmachen und dadurch die Garantie auf das Gerät verlieren. Das fände ich nicht so schick. Zumal die Platte erst ca. 6 Monate alt ist.
Ich stelle mir eher vor, die Daten zu retten, auf einen neue Platte zu kopieren. Die alte kann aich dann noch als Not-Backup-Platte hernehmeb.
 
P

phelix

Gast
Achso, okay, dass es sich um eine "fertig-Festplatte" handelt hast du nirgendwo erwähnt. Hastes einfach mal an einem anderen PC oder USB-Port probiert?
 

Babididu

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
7
Ja, habe ich. Ein WinXP-PC und einen anderen Win Vista PC.
Ergänzung ()

So, habe die Analyse nun abgebrochen. Nach mehr als 2 Stunden, habe ich die 1% noch immer nicht erreicht. Das hätte in dem Tempo noch etliche Tage gebraucht, bis das durch ist.

Hier also eine gekürzte Fassung einer abgebrochenen Analyse (diese lief nur wenige Sekunden):
(N: ist übrigens ein Kartenlesegerät. Daher wird dazu nix gefunden.)


Fri May 14 21:11:34 2010
Command line: TestDisk

TestDisk 6.11.3, Data Recovery Utility, May 2009
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows XP SP2
Compiler: GCC 4.3, Cygwin 1005.25 - May 6 2009 20:35:43
ext2fs lib: 1.41.4, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20080501
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=120033041920
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=0
Fix disk size using CHS
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=120033041920
filewin32_getfilesize(\\.\PhysicalDrive2) GetFileSize err Unzulässige Funktion.


filewin32_setfilepointer(\\.\PhysicalDrive2) SetFilePointer err Unzulässige Funktion.


Warning: can't get size for \\.\PhysicalDrive2
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=0
Fix disk size using CHS
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C: )=31453438464
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\D: )=251660634624
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E: )=496872681984
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F: )=36701167104
filewin32_getfilesize(\\.\G: ) GetFileSize err Unzulässige Funktion.


filewin32_setfilepointer(\\.\G: ) SetFilePointer err Unzulässige Funktion.


Warning: can't get size for \\.\G:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\H: )=251660634624
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\I: )=51868583424
filewin32_getfilesize(\\.\N: ) GetFileSize err Unzulässige Funktion.


filewin32_setfilepointer(\\.\N: ) SetFilePointer err Unzulässige Funktion.


Warning: can't get size for \\.\N:
file_pread(4,1,buffer,1953536129(121601/254/63)) lseek err Invalid argument
file_pread(5,1,buffer,234452609(14593/254/63)) lseek err Invalid argument
Hard disk list
Disk /dev/sda - 1000 GB / 931 GiB - CHS 121601 255 63, sector size=512 - SAMSUNG HD103UJ
Disk /dev/sdb - 120 GB / 111 GiB - CHS 14593 255 63, sector size=512 - WDC WD1200BB-00DAA3
Disk /dev/sdd - 2199 GB / 2047 GiB - CHS 4294967295 1 1, sector size=512 - WD 1000FYP External

Partition table type (auto): Intel
Disk /dev/sdd - 2199 GB / 2047 GiB - WD 1000FYP External
Partition table type: Intel

Analyse Disk /dev/sdd - 2199 GB / 2047 GiB - CHS 4294967295 1 1
Current partition structure:

Partition: Read error
Ask the user for vista mode
Allow partial last cylinder : No
search_vista_part: 0

search_part()
Disk /dev/sdd - 2199 GB / 2047 GiB - CHS 4294967295 1 1
file_pread(6,1,buffer,19(19/0/1)) lseek err Invalid argument
file_pread(6,1,buffer,66(66/0/1)) lseek err Invalid argument
file_pread(6,8,buffer,80(80/0/1)) lseek err Invalid argument
file_pread(6,1,buffer,137(137/0/1)) lseek err Invalid argument
.
.
.
file_pread(6,1,buffer,3145(3145/0/1)) lseek err Invalid argument
Search for partition aborted

Results

interface_write()

No partition found or selected for recovery
simulate write!

write_mbr_i386: starting...
file_pread(6,1,buffer,0(0/0/1)) read err: Invalid argument

Partition: Read error
Store new MBR code
write_all_log_i386: starting...
No extended partition

TestDisk exited normally.
 
Zuletzt bearbeitet:

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Zur Sicherheit würde ich jedoch erstmal ein anderes USB-Kabel versuchen - oder hat die auch einen eSATA-Anschluss?

Ob da jetzt die Platte einen Defekt hat, oder der USB-Controllerchip im Gehäuse, kann man nur nach Ausbau der Platte aus dem ext. Gehäuse(Garantieverlust, wenn das nicht spurlos möglich ist) und Anschluss als Interne genau sagen.
Datenrettung ist nur möglich, wenn die Platte per eSATA oder intern angeschlossen noch ansprechbar wäre.
 
Zuletzt bearbeitet:
F

Fiona

Gast
Zur Zeit wird meine externe Festplatte von Western Digital 1TB zwar als USB-Massenspeichergerät erkannt, allerdings ohne Laufwerkszuordnung.
Kann es sein, das die Festplatte gegenwärtig mit 2 TB erkannt wird?
Ist wegen dem hier;
Disk /dev/sdd - 2199 GB / 2047 GiB - CHS 4294967295 1 1, sector size=512 - WD 1000FYP External
Teile auch mal mit, wie die in der Datenträgerverwaltung angezeigt wird.

Viele Grüße

Fiona
 

Babididu

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
7
Kann es sein, das die Festplatte gegenwärtig mit 2 TB erkannt wird?
Das verwundert mich auch sehr. Doch habe ich hier im Forum einen Eintrag gesehen, in dem jemand das gleiche Phänomen mit dieser Platte gesehen hat. Leider gab es in dem Thread keine Auflösung des Rätsels.
Ich denke dazu werde ich mal den Support von WD anschreiben.

Hier Screenshots:
Win XP: Hier fehlt Datenträger 2. Das wird wohl die Platte sein, die ich vermisse
Datentraegerverw.jpg
Win Vista: Hier wird angezeigt, dass der Datenträger nicht initialisiert ist.
dtrverw_vista.jpg
Gerätemanager in XP: hier wird alles fehlerlos angezeigt.
geraetemgr.jpg

Die Platte hat leider keinen eSATA-Anschluß. Ob ich sie schadlos öffnen kann, weiß ich noch nicht.
 

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Dann stell mal im Forum "Festplatten" die Anfrage, ob jemand weiß, wie das geht (mit genauer Modellbezeichnung) - Da kann sicher wer Ratschläge geben, ohne es zu beschädigen
 

Babididu

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
7
In mir regt sich nun ein böser Verdacht: Ich habe festgestellt, dass ich die Festplatte mit einem falschen Netztteil betrieben habe. Irgendwie ist das Netztteil der HDD nicht auffindbar. Daher kenne ich die genau erwarteten Werte der HDD nicht. Kennt die jemand? Es handelt sich um eine WesternDigital Elements, Modell: WD10000EB035-01.

Das falsche Netztteil, das ich verwendete war eines von einem Laptop, dass am DC Output mit 19.0V und 4,74A aufwartet.
Ich glaube, dass meine HDD nur 12V und 1,5A haben will.
Habe ich sie dadurch nun zerschossen? Oder vielleicht "nur" die USB-Platine?
 

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Ganz sicher die HDD und möglicherweise auch USB-Bridge-Chip beschädigt
schreib mal eine PM an _TK_ - der kann Dir sicher weiterhelfen
 

_TK_

Lieutenant
Dabei seit
Jan. 2009
Beiträge
707
Danke für die Blumen!

Nun, bei normalen Überspannungsschäden freut sich mein Lötkolben. Aber hier scheint irgendwie der Wurm drinzusein - eine Größe vom 2199 GB deutet entweder auf einen defekten USB-Chip, einen beschädigten Festplattencontroller, evtl. auch Vorverstärker, oder Schäden in der Firmware (Translatortabelle) hin. Weiß der Geier, warum WD seinen USB-Platten nicht einfach einen soliden Überspannungsschutz spendiert! Früher gab es für solche Fälle mal Schmelzsicherungen, die würden in Verbindung mit einer klitzekleinen Schaltung wahre Wunder bewirken.. (und das Produkt um ca. einen Euro verteuern)

Ob da was zu machen ist, kann ich aus der Ferne nicht beurteilen.
Am besten, Du öffnest erst einmal das USB-Gehäuse, und schließt die Platte direkt an den Rechner an. Die Garantie ist mit der Überspannung eh' erloschen. In 50% aller Fälle funktioniert die Platte jetzt wieder.
Falls die nicht hochdrehen sollte, verschmort riecht, oder immernoch exotische Daten zeigt, kann ich gern mal draufschauen (nicht ganz umsonst, aber zum Selbstkostenpreis).
Das defekte USB-Gehäuse gehört in den Elektronikschrott - bitte keinesfalls weiterverwenden!

Gruß

Thomas
 

Babididu

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
7
OK, hab nun also das Gehäuse geöffnet, die Platine entfernt und stattdessen die HDD direkt im PC angeschlossen. Leider ohne Erfolg. :(
Beim Booten wird ein Fehler bei der Erkennung der Festplatten angezeigt. Leider habe ich den dazugehörigen Screen jetzt nicht fotografiert. Aber die Anzeige im Bios zur Festplatte.
BIOS_Sata3.jpg
Ich nehme an, dass das Modell richtig erkannt wird, aber nicht die Größe.
Leider komme ich während des Bootens nicht über den Windows-Start-Schirm hinaus. Nach ca. 10 sek. Win-Logo kommt für sehr kurze Zeit (<1sek) ein Blue-Screen mit Neustart.

Und was nun?
 

_TK_

Lieutenant
Dabei seit
Jan. 2009
Beiträge
707
Fräulein Meier, schreiben Sie bitte:
- Platte wird mit der richtigen Modellbezeichnung erkannt, aber
- Speicherkapazität 0MB.

Hmm.
Habe vorhin mal eine nicht ganz baugleiche Platte genommen, und nur die nackige Elektronik angeschlossen. Die meldet sich nach viiieelen Sekunden mit korrekter Bezeichnung und Größe.
Also haben wir drei Möglichkeiten:
- Platte fast in Ordnung, aber Translatortabelle durcheinandergekommen. Das kann man meistens reparieren.
- Elektronik defekt - sollte auch machbar sein,
- Vorverstärker im Platteninneren defekt: unwahrscheinlich. Der wäre auch besch.. zu reparieren.

Hier bin ich mit meinem Ferndiagnose-Latein am Ende. Jetzt hilft nur noch eine ordentliche Diagnose.

PS: Für alle, die nur so interessehalber mitlesen:
Markiert Eure Stecker(netzteile) und die zugehörigen Buchsen bitte mit bunten Aufklebern, farbigem Isolierband, Kabelbindern o.ä.! Sieht lustig aus, und spart eine Menge Ärger.
 
Zuletzt bearbeitet:
Top