Grafikkarte hält die fps nicht, GPU Auslastung steigt aber nicht

Nemesis200SX

Ensign
Dabei seit
Aug. 2012
Beiträge
210
Hallo,

folgende Verständnissfrage hätte ich. Ich spiele aktuell den Ego Shooter Terminator Resistance. Alle Grafikdetails auf Maximum bei 60hz durch V-Sync gelockt. Mit 1440p keinerlei Probleme, die GPU hat hierbei eine Auslastung von 55-70% je nach Szene (habe V-Sinc mal zum Test deaktiviert, da gehen die FPS auf über 100 hoch, also genug Reserven). Wenn ich nun die Auflösung auf 2160p hochschraube, dann werden die 60fps zwar auch die meiste Zeit gehalten, in einigen Abschnitten sinken die FPS dann allerdings auf 30 und das ohne erkennbaren Grund (keine Gegner, keine aufwendigen grafischen Effekte). Die GPU bleibt aber auch hierbei bei 55-70% Auslastung.

Ich versuche nun zu verstehen warum die GPU nicht "aufdreht" wenn die FPS in den Keller gehen? Kann mir nicht vorstellen, dass hier die CPU limitiert, denn wie bereits geschrieben in 1440p läuft alles einwandfrei. Auch Grafikspeicher ist nur ca. zu einem Drittel ausgelastet. Kann mir nicht erklären wo der Flaschenhals ist.

Kanns daran liegen, dass es sich hierbei um ein Budget-Spiel handelt, das vielleicht nicht optimal für 4K programmiert ist?

AMD Ryzen 5 1600X
Asus ROG STRIX GTX 1080TI OC
16GB Ram
Windows 10

Danke
 

-Legend-Storm-

Lt. Commander
Dabei seit
Dez. 2015
Beiträge
1.879
wie hoch ist die cpu ausgelastet ? ich mein alter amd da sollte man auch drauf achten wie hoch der ausgelastet ist
 

CSOger

Commander
Dabei seit
Mai 2008
Beiträge
2.826
Wenn man ein paar Tests liest wird auch über teilweise grottige Frameraten geschrieben.
 

xxMuahdibxx

Fleet Admiral
Dabei seit
Juli 2011
Beiträge
19.545
in einigen Abschnitten sinken die FPS dann allerdings auf 30 und das ohne erkennbaren Grund (keine Gegner, keine aufwendigen grafischen Effekte). Die GPU bleibt aber auch hierbei bei 55-70% Auslastung.
Woher willst du wissen was die CPU in der einen oder anderen Situation mal nebenher berechnen tut oder muss ... und wo und wie sie das macht.

Wenn die CPU nicht genug Daten schickt dann gehts einfach mit den FPS in den Keller ...

Bei 2160p hast du aber nicht mal ohne Vsync probiert zu testen wie dann die FPS sind ... falls die dann auch unter 60 droppen ab und an ... dann weist woran es liegt.
 

syfsyn

Captain
Dabei seit
Nov. 2010
Beiträge
3.347
Auch wenn man meint je höher die Auflösung desto weniger cpu drawcals der irrt gewaltig
Es kann sein das manche stellen im game höhere CPu last verursachen.obwohl man meint das nix passiert
das kann an der Sichtweite liegen und an verdeckten Ereignissen im game.
Das kann man als nicht optimiert ansehen ist aber vom design her gewollt.
Was man dagegen tun kann ist LOD reduzieren und noch besser Sichtweite reduzieren

Das spiel müsste auf 1080p designet worden sein (das sieht man an der vram befüllung
bei 256bit sind das etwa 4-5gb)
Weil aber die Settings recht Dünn sind kann man da nix machen außer zu hoffen das mal ein patch das korrigiert.
 

Pisaro

Fleet Admiral
Dabei seit
Aug. 2007
Beiträge
10.691

CruisinX

Cadet 2nd Year
Dabei seit
Nov. 2019
Beiträge
24
Das hört sich eher nach einem forcierten Framecap an. Sowas hab ich in Star Citizen schon selbst beobachtet. Mit aktiviertem V-Sync fixiert die Bildrate auf 30 FPS sobald sie unter 60 fällt.
 

Nemesis200SX

Ensign
Ersteller dieses Themas
Dabei seit
Aug. 2012
Beiträge
210
Das dürfte es in der Tat sein, an V-Sync habe ich gar nicht gedacht. Das würde auch erklären warum die FPS auf exakt 30 fallen. Muss mal schauen wie das mit deaktiviertem V-Sync aussieht. Danke jedenfalls für den Tipp.

Zum Thema CPU: ich dachte CPU Limitierungen hätte man primär in Strategie- und Aufbauspielen, wo viele Einheiten berechnet werden müssen und Shooter wären eher GPU Lastig? Muss die CPU auch mehr leisten wenn man die Auflösung hochschraubt? Dachte dafür wäre primär die GPU zuständig. Ich bin jetzt auch kein FPS-Jäger... 60fps konstant reichen mir, übrig gebliebene Leistung geht in Grafikdetails und Auflösung.

Habe mich damals eigentlich bewusst gegen den Ryzen 7 entschieden, weil ohnehin die wenigsten Games für 8 Kerne optimiert sind... und mit 2 Jahren kann die CPU ja noch nicht wirklich veraltet sein?
 

amorosa

Commander
Dabei seit
Okt. 2013
Beiträge
2.579
Same hier bei der 2070S und dem 5820K.
In 1440P auf Ultra hat die Karte noch locker Reserven und dümpelt bei 45-60% Auslastung herum und liefert mehr als genügend Frames.

Aber bei 4K sieht das anders aus.
Die CPU liefert genug. Aber die Graka pfeift aus dem letzten Loch und kann gerade mal so die 55-60FPS halten.

Frametimes sind einfach nur grotte in diesem Game.

Das Game ist einfach mies gebaut.
Schlauchlevel und dann Kackperformance (sorry, ist so) ^^

Lg
 

Pisaro

Fleet Admiral
Dabei seit
Aug. 2007
Beiträge
10.691
Ich verstehe das Problem mit Vsync nicht. Sofern Tripple Buffering aktiviert ist kannst du auch 55, 53, 58, 45 oder 22 FPS und so weiter haben, dass schon seit bestimmt 10 Jahren.
Wurde das immer übersehen oder bewusst nie aufgezählt?
 

moshimoshi

Captain
Dabei seit
Juli 2008
Beiträge
3.872
Hier halbieren sich die Frames auch.

Auf einer KFA 2070 Super sowie Zotac 2080.
Sobald VSync raus ist, wird die GPU bis zu 99% belastet. Mit Vsync pendelt sie unter Last zwischen 60-75%.

Habe das auch bei Just Cause 4 beobachtet.

Beide jeweils angeschlossn an einen PhilIps IPS Fernseher 0ms Reaktionszeit.

Leider keine AMD Grafikkarte da für ein gegentest.
 

Silverangel

Vice Admiral
Dabei seit
Sep. 2009
Beiträge
6.587
Dafür ist nicht das "Triple Buffering" verantwortlich, sondern ob man normales Vsync oder Adaptives Vsync aktiviert hat (oder vom Spiel vorgegeben wird).
Normales Vsync halbiert die FPS sobald man unter die Refreshrate des Monitors fällt. (Also bei 144 auf 72, bei 60 auf 30 usw. )
Adaptives schaltet sich sozusagen aus, sobald man unter 60 fällt, womit dann auch 55,53,52,50 usw. möglich ist.
Aber eben zerreißen vom Bild ist dann wieder möglich. Dagegen hilft dann ein Freesync/Gsync Monitor mit ausreichend großer Range.

Wenn man also meint Vsync zu nutzen, und unterhalb von 60 direkt bei 30 landet, auf Adaptives Vsync umschalten.

Besser: Vsync ganz ausschalten und FPS gleich per externem Programm begrenzen (z.b. RTSS via Afterburner) und zusätzlich Freesync/Gsync Monitor benutzen.
 
Zuletzt bearbeitet:
Top