Partition ist weg

Gandalf1998

Cadet 1st Year
Dabei seit
März 2005
Beiträge
10
Hallo Zusammen,

ich habe ein 160 GB Festplatte (2 Partitionen 1x ca. 40GB C: und 1x ca. 120GB D: Nun habe ich ein Problem und komme nicht mehr an meine Daten auf D: dran. Konnte mit einem Datenrettungs-Tool meine Daten von C: sichern :) – aber irgendwie komme ich nicht auf die zweite Partition. :(

Ich bin nach der Test Disk Anleitung https://www.computerbase.de/forum/threads/faq-datenrettung-testdisk-anleitung.110869/ vorgegangen.

Habe meine Partition ausgewählt Disk /dev/sdb – CHS 4111 255 63 – 32247MB und dann Analyse. Anbei die Datei.
Danach bekomme ich die Meldung:
„Check the harddisk size: HD jumpers settings, BIOS detection, OS limitation…
The following partition can’t be recovered. The harddisk seems too small!”
D HPFS – NTFS 0 1 1 6707 254 63 107763957

Structure: OK

Aber was nun?
 
F

Fiona

Gast
Habe gerade gesehen, das die Festplatte nur mit 30 GB erkannt wird.

CHS 4111 255 63 – 32247MB

Daher das Problem.
Prüfe mal die Jumpereinstellung von der Festplatte auf 30 GB-Beschränkung und dein Bios auf Erkennung.
Dann sollte es eigentlich funktionieren.

Ansonsten kannst du jederzeit Fragen oder auch Screenshots setzen.

Viele Grüße

Fiona

Edit:

Ich hatte jetzt schon einige Fälle wo nicht die Festplattengröße zuerst überprüft wurde.
Werde ich wahrscheinlich in der Anleitung auch nochmal einen Hinweis im Wiederherstellungsbeispiel setzen.
Im Moment steht das noch in Post 7 unter der ersten Zitatbox.
https://www.computerbase.de/forum/threads/faq-datenrettung-testdisk-anleitung.110869/#post-1101816

Hier ist auch nochmal ein Beispiel mit dem selben Problem.
https://www.computerbase.de/forum/threads/hilfe-bei-testdisk-5-6.118469/

Danke mal für dein Denkanstoß.

Gruß

Fiona

//Ich verschiebe mal dein Thread ins Datenrettungsforum.
Fiona
 
Zuletzt bearbeitet:

Gandalf1998

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2005
Beiträge
10
An der Jumpereinstellung habe ich nichts geändert - ich wüste noch nicht mal wo ich was ändern müsste. Ich hatte die Platte mal auf „Cable Select“ gesetzt aber das hat gar nicht funktioniert – nun steht sie auf „Slave“ Ich schicke hier noch mal ein Logfile mit.
Vielleicht kannst Du damit ja was anfangen – ich nicht. ;)
Was kann ich den noch im BIOS einstellen?
 
F

Fiona

Gast
Überprüfe vielleicht die Einstellungen doch einmal.
Meistens liegt es daran.
Ansonsten sollte das Motherboard / Bios lba (Logical Block Addressing) unterstützen.
Sieht aber nicht nach deinem Problem aus.
Weil die wird ja nur mit 30 GB erkannt.
Bei einem lba-Problem wären es bereits schon 137 GB.

Es gibt bei dir auch nicht die Fat32-Beschränkung da du als Dateisystem NTFS hast.

Viele Grüße

Fiona
 

Gandalf1998

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2005
Beiträge
10
Hallo Fiona,

ich habe hier einen Screenshot – vielleicht kannst Du damit was anfangen.
Ich wüste nicht was ich an der Festplatte ändern müsste.



Habe noch einen 2. Shot
 

Anhänge

  • 127,2 KB Aufrufe: 2.040
  • 98,1 KB Aufrufe: 1.636
Zuletzt bearbeitet:
F

Fiona

Gast
Testdisk zeigt natürlich eine verkehrte Partitionsgeometrie an.
Der Grund liegt aber darin, da von 160 GB nur 30 GB erkannt werden.

Zuerst muß sichergestellt werden, das die Festplatte mit richtiger Größe erkannt wird.
Meistens legt sich das dann und alles wird richtig angezeigt.
Die Fehler weisen auf einer verkehrten Partitionsgeometrie hin.
Liegt aber an der verkehrten Erkennung.

Du kannst auch mal die Größe in der Datenträgerverwaltung überprüfen.

Wenn du absolut sicher bist, daß das Bios und die Jumper stimmen, könnte es auch an den IDE-Treiber liegen.
Den kann man notfalls löschen.
Beim nächsten start sollte der wieder via Plug'nPlay erkannt werden.

Vorher könntest du dir aber auch mal die Dos-Version von Testdisk laden und mit einer Bootdiskette probieren.
Downloadlink ist hier;
http://www.cgsecurity.org//testdisk-5.7-WIP.dos.zip
Die kannst du im Arbeitsplatz erstellen oder bei www.bootdisk.com .
Dort brauchst du nur den dos-Ordner von Testdisk draufkopieren.
Photorec wird dabei nicht benötigt.
Man kann Testdisk auch auf eine 2 Diskette kopieren und wechseln.
Dort sollte bei der Festplatte über 150 000 MB stehen.

Wenn die Festplatte mit der dos-Version richtig erkannt wird, dann weißt du, daß es an Windows liegt .

Die volle Erkennung ist immer am wichtigsten.
Sonst kannst du auch nichts wiederherstellen.

Viele Grüße

Fiona

Edit:

Hier ist auch nochmal ein Fall wo genau parallel zu deinem gelaufen ist.
Hatte genau das selbe Problem mit der Erkennung und 30 GB.
unter Bild 2 die Punkte hab ich schon alles überprüft, am Jumper wurde nix geändert, im BIOS wird die platte auch normal erkannt....
Nächstes;
kleines Update...

Auf ein,al zeigt mir Testdisk an, das ein Jumper Fehler vorliegen würde und ich das doch mal überprüfen solle... obwohl ich meine Platte vor der Windows Neuinstallation immer so laufen lassen hatte, dachte ich mir guck doch noch mal.... und siehe da, Jumper raus und schon wird wieder die richtige Größe angezeigt... unter Testdisk und unter Datenträgerverw. ... Nur leider ist sie immer noch "nicht formatiert" bzw. RAW...


EDIT: Ja, es ist halb 3 morgens und ich hab endlich meine Platte wieder
Ist der Thread hier;
https://www.computerbase.de/forum/threads/festplatte-nicht-formatiert.121973/
In diesen Screenshots siehst du auch eindeutig, daß die 160 GB-Festplatte in der Datenträgerverwaltung mit nur 31.5 GB erkannt wurde.
https://www.computerbase.de/forum/attachments/7-jpg.23481/

Das komische ist, in beiden Fällen war es für die Erkennung wichtig die Jumper zu entfernen.
Waren auch auf Slave.
Einmal in dem Thread wie genau oben in der Zitat-Box;
und siehe da, Jumper raus und schon wird wieder die richtige Größe angezeigt...
Und hier;
https://www.computerbase.de/forum/threads/120gb-sicherungsplatte-nicht-mehr-lesbar.111913/page-2#post-1144202

Vielleicht hilfts

Viele Grüße

Fiona
 
Zuletzt bearbeitet:

Gandalf1998

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2005
Beiträge
10
@Fiona

habe in der Datenträgerverwaltung nachgeschaut, dort wird die Platte mit 31,5 GB dargestellt (Fehlerfrei).
Habe mir auch eine Bootdiskette erstellt und Testdisk laufen lassen – aber leider hat er die zweite (nicht funktionierende Platte) nicht gefunden nur meine „Neue“ Platte.

Noch mal zu den Jumpern: Du meinst doch die Jumper mit denen man (Master, Slave, Cable Select) einstellt? Im BIOS wüste ich nicht was ich da einstellen müsste (LBA?) aber wo.
Meine neue Platte habe ich in zwei Partitionen unterteilt (2x 100GB) meine kaputte Platte war eine 160 GB 1x ca. 40 GB und 1x ca. 120 GB – fällt also alles noch unter 137 GB grenze.




@Fiona

Habe den Jumper von meiner alten Platte ausgebaut (nun erkennt BIOS die 160GB)
Ich lasse gerade die Analyse drüber laufen und setzt gleich noch mal ein Screenshot
So Analyse ist fertig aber was nun?
 

Anhänge

Zuletzt bearbeitet:
F

Fiona

Gast
Jetzt wird doch alles richtig erkannt! :)

Bestätige jetzt mit Enter.
Dann kommst du zum Screen wo unten [Quit] [Search] [Write] [Extd Part] steht.
Gehe mit dem Pfeil auf Write und bestätige mit Enter und y.
Beende Testdisk jeweils mit Quit.
Windows neu starten und überprüfen.
Wenn chkdsk kommen sollte, brich es erstmal ab.
Teile es dann mit.

Viele Grüße

Fiona
 

Gandalf1998

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2005
Beiträge
10
Re: Partition ist wieder da

@Fiona

dank Dir und Testdisk habe ich meine Daten wieder. :) :) Jetzt geht es erstmal ans Datensichern.
Vielen Danke noch mal für die schnelle Hilfe.
 

Smoky100

Newbie
Dabei seit
Apr. 2006
Beiträge
5
Hallo ihr Lieben,

ich habe genau dasselbe Problem nur mit dem Unterschied das ich eine externe 250 GB USB Festplatte habe. Leider ist das Gehäuse ohne Schrauben, ich müsste also das Gehäuse kaputt machen um an die Jumper der Festplatte zu kommen. Ist eine Toshiba Gigastore USB Festplatte und wird auch so im Bios angezeigt.

Hier die Fehlermeldung nach dem Search:
The harddisk (250 GB / 232 GiB) seems too small! (< 500 GB / 465 GiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

Partition Start End Size in secotors
D HPFS - NTFS 3 0 1 30403 253 63 488392002
D HPFS - NTFS 6 0 1 30406 253 63 488392002

von diesen Einträgen habe ich über 100
unten steht dann ...

[ Quit ]

NTFS, 250 GB / 232 GIB


dann klicke ich auf Quit und folgendes Fenster erscheint:

Disk 82 - 250 GB / 232 GiB - CHS 30402 255 63

Partition Start End Size in sectors


Structure: OK
Keys A: add partition, L: load backup, Enter: to continue


dann klicke ich auf Enter und folgendes Fenster erscheint:
Disk 82 - 250 GB / 232 GiB -CHS 30402 255 63

Partition Start End Size in sectors

No partition found or selected for recovery


und jetzt komme ich nicht mehr weiter.... wie schaffe ich es, das meine externe USB Festplatte richtig erkannt wird?

Ich hoffe ihr könnt mir auch helfen und vielen Dank schonmal im vorraus :)

LG
Smoky100
 

Smoky100

Newbie
Dabei seit
Apr. 2006
Beiträge
5
Ich bin es nochmal :)

war eben nochmal im Bios und da steht unter Advanced -> USB Configuration -> USB Mass Storage Device Configuration:

USB Mass Storage Reset Dealy [20 sec]
Device #1Toshiba Gigastore
Emulation Type [Auto]


sonst steht da nichts mehr ausser rechts die Information zu Emulation Type:
If Auto, USB devices less than 530 MB will be emulated as Folppy and remaining as hard drive. Forced FDD option can be uses to force a HDD formatted drive to boot as FDD (Ex. ZIP drive).

denke mal das Auto richtig ist.

so, ich probiere noch ein wenig und dann ins Bettchen :)

LG
Smoky100
 

Smoky100

Newbie
Dabei seit
Apr. 2006
Beiträge
5
hihi, jetzt bin ich süchtig dieses Problem zu lösen.
Ich habe mir nochmal alles von Fiona durchgelesen und festgestellt das auch meine Endzylinder der Partition grösser sind als die Endzylinder der Festplatte. Mir ist zwar nicht ganz wohl bei der Sache aber ich versuche es jetzt mal mit der Option Geometry.

...ich melde mich wieder :)
 

Smoky100

Newbie
Dabei seit
Apr. 2006
Beiträge
5
Kein Erfolgserlebnis :(
wenn ich denke das ich es richtig habe und auf write klicke kommt nur noch Partition: Write error.

gehe jetzt gefrustet ins Bettchen :(
 

Smoky100

Newbie
Dabei seit
Apr. 2006
Beiträge
5
und doch noch nicht aufgegeben *g*
Ich habe die ganze Zeit mit der Testdisk DOS gearbeitet und eben habe ich mit WinXP den letzten Versuch mit Testdisk Win probiert.....und siehe da, alles geklappt.

Trotzdem vielen vielen Dank für die Super Anleitung Fiona, könnte Dich küssen.
Die Daten waren mir sehr wichtig und bin jetzt richtig Happy :)

also dann.....Guts Nächtle ihr Lieben

Smokey100 :) *freu* *spring*
 

R!ZZ

Newbie
Dabei seit
Sep. 2007
Beiträge
5
Hi @ all!

Hab leider auch das problem das nachdem ich meine windows partition platt gemacht hab eine weitere partition fehlt...
nachdem ich mit partition magic kein erfolg gehabt habe wollte ich das ganze mit testdisc probiern wobei mir allerdings dieser lba fehler angezeigt wird, was komisch ist da partition magic das ganze wie gesagt erkennt. Hat irgendjemand eine ahnung was ich da machen kann??
 

Anhänge

R!ZZ

Newbie
Dabei seit
Sep. 2007
Beiträge
5
Mensch das geht hier ja schnell^^ Danke. Hab ich auch danach nochmal geschaut und mit SP 2 hats dann geklappt. also Testdisk is nur zu empfehlen
 

hauwegdenmist

Newbie
Dabei seit
Dez. 2007
Beiträge
4
Hallo Leute,

habe auch das Problem mit der Partition:

habe meinen Rechner neu installiert. Habe eine 60GB Platte in meinem Rechner als Master und eine 320GB Platte als Slave. Die 320GB Platte wird nur noch als 137GB Platte erkannt.

Habe jetzt schon folgendes gemacht:

- Im BIOS wird die Platte mit vollen 320GB erkannt.
- TestDisk erkennt die Platte nur als 137 GB Platte.
- SP1 draufgeschmissen, erfolglos.
- den Registry Eintrag geändert, so wie es bei Microsoft beschrieben wird, erfolglos.
- SP2 installiert, immer noch nix.

Bin am verzweifeln, da es vor der Neuinstallation auch geklappt hat mit der HDD und ich extra meine ganzen Daten auf die Platte geschmissen habe, damit es keinen Datenverlust gibt.... :mad:

Hat jemand von euch einen Tipp für mich?

PS: Jumper hatte ich auch schon überprüft... vorher war es gegliedert in Master/Slave, jetzt habe ich es auf Cable Select umgestellt....
 
F

Fiona

Gast
Wenn die Festplatte im BIOS richtig erkannt wird, ist es schonmal gut!
Am einfachsten ist es eine Reparaturinstallation mit Servicepack 2 zu machen!
Gehe dazu wie folgt vor und stelle alle Services und Hintergrundprozesse wie Virenscanner ab, die ein schreiben verhindern können.

Gehe auf Start / Ausführen / msconfig
Deaktiviere alles bei Systemstart.
Gehe auf den Reiter Dienste.
Setze bei Microsoft Dienste ausblenden den Haken, sonst startet Windows nicht richtig.
Deaktiviere auch den Rest.
Starte neu und installiere das Servicepack 2 nochmal drüber.
Bei msconfig kann alles wieder aktiviert werden.
Starte neu und überprüfe es.
Wenn das nicht hilft, kann die Datei atapi.sys aus dem Servicepack 2 extrahiert und in den Windows/system32/drivers-Ordner kopiert werden.
Dabei gibt es einiges zu Beachten.
Nur wenn es nicht funktioniert.

Viele Grüße

Fiona
 
Top