Excel Frage: Umsetzung in Formel

mosrae

Lt. Junior Grade
Dabei seit
Okt. 2009
Beiträge
261
Hallo!

Da meine Excel-Kenntnisse etwas heruntergekommen sind und ich zu meinem Arbeitsprojekt dringend Hilfe benötige, was Formelberechnen angeht, möchte ich gerne wissen wie man folgendes in eine Formel in OpenOffice Calculator umsetzt

Wenn C2 größer als b7, aber kleiner als b8, dann schreibe in a1 rein "x", sonst versuche in a1 reinzuschreiben "y"

Ich hoffe in etwa war das richtig angesetzt, nun fehlt mir halt nur noch die übersetzung in die "excel Sprache"

MfG Lukas
 
In a1 folgende Formel einfügen:

Wenn(c2>b7;Wenn(c2<b8;"x";"y");"y")

ohne es getestet zu haben
 
Ok. Dankeschön :-)
 
So geht's auch:

=WENN(UND(c2>b7;c2<b8);"x";"y")
 
Ich würde sagen:

=WENN(UND(C2>B7;C2<B8);"X";"Y")


edit: ach MorkVomOrk76; immer diese Vordrängler :D
 
@Mr. Snoot:
Mach Dir nichts draus, wir waren ja quasi gleichzeitig...
 
Ouh mist. Neues Problem.

Folgendes hat sich aufgebaut:

Wenn a1 zwischen b1 und c1 liegt, dann berechne die differenz zwischen a1 und c1

Wäre nett wenn ihr mir das auch noch erklären könntet.
 
Ist B1 kleiner oder größer als C1, oder ist das beliebig?

  • B1 kann größer oder kleiner als C1 sein:
    =WENN(UND(A1<B1;A1>C1);A1-C1;WENN(UND(A1>B1;A1<C1);C1-A1;""))​
  • B1 ist immer kleiner als C1:
    =WENN(UND(A1>B1;A1<C1);C1-A1;"")​
  • B1 ist immer größer als C1:
    =WENN(UND(A1<B1;A1>C1);A1-C1;"")​
 
Zuletzt bearbeitet:
Also ich meine das so:

- er soll dann die differenz in das kästchen reinschreiben

- In Zahlen ausgedrückt wäre die Formel z.b.

Wenn 1000 zwischen 500 und 1100 liegt, dann berechne die differenz zwischen 1000 und 1100.

Schreibe dann die differenz in das kästchen

Welche Formel soll ich dann dafür verwenden?
 
Die, die zu deinen Werten passt. Ich hab ja oben alle Möglichkeiten aufgeführt.

Wenn B1 größer oder kleiner als C1 sein kann, dann nimm die erste.
Wenn B1 immer kleiner ist als C1, dann nimm die zweite.
Wenn C1 immer kleiner ist als B1, dann nimm die dritte.

Theoretisch bleibt aber auch noch die Möglichkeit, dass B1 gleich C1 ist ... Das muss man ggf. berücksichtigen.
 
Zuletzt bearbeitet:
A1 ist ja 1000
B1 500
C1 1100

Bei mir kann a1 Sprich 1000 sowohl größer als C1 (1100) sein aber auch kleiner als b1 sein...

a1 ist szsg. eine variable, Ich möchte dann aber nur eine Formel verwenden, die mir meinetwegen entweder einen Error gibt oder die differenz..

Wär cool wenn das dann klappen würde

Hauptsache ist ob es möglich ist zwischen a1 (1000) und c1 (1100) eine differenz berechnet werden kann
dabei muss die differenz immer über 0 sein und a1 darf nie größer als c1 sein.

Möglichkeit wäre dann ein Error der mir symbolisiert dass Es unter 0 oder über c1 ist

Ich möchte die Gleichung in der Praxis bei mehreren Werten testen, damit ich sehen kann zwischen welchen
Beiden variablen b1 und c1 es eine differenz gibt die einen positiven wert hat.
 
Und was genau gefällt dir an den Formeln nicht? :D

Wenn ein "Fehler" angezeigt werden soll, dann müsstest du lediglich noch zwischen die Anführungszeichen am Ende deinen Fehlertext schreiben:
=WENN( ... ;"Fehlermeldung")​
 
Oh es klappt mit der 2.

Vielen Dank.! :)
 
Zurück
Top