Excel rundet unendlich bei Zeitumrechnung

ede875

Newbie
Dabei seit
Sep. 2013
Beiträge
3
Hallo,

wie kann ich verhindern, dass Excel2010 beim Umrechnen von Uhrzeiten (Endzeit-Anfangszeit) in Dezimalzahlen unendlich rundet und so hinterher "falsch" addiert?

Beispiel:

Beginn 7:45 Uhr Ende: 13:35 Pause: 15 min. ergibt 5,83(333333333334)
Beginn: 9:00 Uhr Ende: 15:05 Uhr Pause: 15 min. ergibt 5,83(33333334)

Zusammen ergibt das 11,6666667, was wiederum aufgerundet wird.

Jetzt habe ich in Excel2010 also in einer Spalte "2 Dezimalstellen" anzeigen gewählt, erhalte in der Summe aber die Enziffer 7 statt der erwarteten 6. Wie kann man das beheben?

Ede
 

simpsonsfan

Commander
Dabei seit
Feb. 2008
Beiträge
2.811
Keine Ahnung, was genau du vor hast, aber dann verwende halt ABRUNDEN, wenn du nicht normal runden willst. Überhaupt ist das auch nur die Anzeige, der eigentliche, richtige Wert bleibt momentan erhalten.
 

blablub1212

Commodore
Dabei seit
Sep. 2009
Beiträge
5.092
du kannst dir das runden auch ersparen.
deine 4 spalten (beginn, ende, pause, arbeitszeit) formatierst du als uhrzeit.
in den spalten beginn, ende und pause trägst du die werte in folgender vorm ein: hh:mm, z.B. 07:45.
in der spalte arbeitszeit kommt die funktion: =summe(b2-b3-b1)

dann bekommst du die arbeitszeit ebenfalls in der form hh:mm angezeigt. bei einem wert von zb. 04:13 wurde dann 4 stunden und 13 minuten gearbeitet.
 

ede875

Newbie
Ersteller dieses Themas
Dabei seit
Sep. 2013
Beiträge
3
Vielen Dank schonmal für die Antworten.

@simpsonsfan:

Ich möchte ja erreichen, dass der richtige Wert abgerundet wird und nicht nur der angezeigte.

=WENN(C10-B10-E10+F10=0;"";ABRUNDEN((C10-B10-E10+F10)*24;2))

hat mir da weitergeholfen.

Der WENN-Teil hat nur kosmetische Gründe (Feld bleibt leer, wenn keine Angabe gemacht wird).

Gruß

Ede
 

simpsonsfan

Commander
Dabei seit
Feb. 2008
Beiträge
2.811
Rechtsklick->Zellen formatieren->benutzerdefiniert
 
Top