Neuer PC mit diverse Bluescreens - vor allem CLOCK_WATCHDOG_TIMEOUT und SYNTHETIC_WATCHDOG_TIMEOUT

b00kie

Cadet 4th Year
Registriert
Juni 2008
Beiträge
77
Moin CB-Forum

Leider habe ich mit meinem neu zusammen gebauten PC sehr viel ärger. Ich bin inzwischen mit meinem Latein völlig am Ende und hoffe jemand kann mir weiter helfen.

Vorne Weg die Specs:
  • Mainboard: MSI MAG B660 Tomahawk WIFI DDR4 ATX So.1700 retail
  • CPU: Intel Core i7 12700 12 (8+4) 2.10GHz So.1700 BOX
  • Grafikkarte: ASUS GeForce RTX3070 Gaming OC NOCTUA-Edition
  • Arbeitsspeicher: Crucial Ballistix Black 32GB DDR4 Kit (2x16GB)
  • Netzteil: EVGA SuperNOVA G6 80+Gold 750 Watt
  • Kühler: Scythe SCFM-2000 FUMA 2
  • Festplatte/SSD:
  • -500GB Samsung SSD 980 Pro
  • -2TB Samsung 970 Evo Plus
  • -6TB Seagate Skyhawk Surveillance ST6000VX001
Nach dem Zusammenbau startete der PC soweit normal und auch Windows lies sich problemlos installieren.
Doch seit Stunde Eins lief das System dabei sehr instabil, so dass ich pro Stunde oft mehrere Bluescreens hatte.
Dabei waren es auch unterschiedliche Bluescreens, u.a. :
  • 0x00000157 (KERNEL_THREAD_PRIORITY_FLOOR_VIOLATION)
  • 0x0000000A (IRQL_NOT_LESS_OR_EQUAL)
  • 0x00000101 (CLOCK_WATCHDOG_TIMEOUT)
  • 0x000001ca (SYNTHETIC_WATCHDOG_TIMEOUT)
Auffällig war, dass es meist bei geringer Last (beim idle in Windows/Youtube/Stream) zum Absturz kam. Auch die Art der Crashes war dabei sehr seltsam.

Manchmal ist der PC einfach "eingefroren", so dass kein Keyboard/Mouse Input mehr möglich war, obwohl Ton/Bild für 1-2 Minuten weiter lief. Danach kommt es entweder zum Bluescreen oder es passiert einfach garnichts bis zum manuellen Reset. Andere Male kommt es direkt zum Bluescreen, wieder andere friert nun auch Bild/Ton ein und man sieht seltsame Artefakte. Scheinbar wahllose Aktionen, wie das Ein/Ausschalten von Bluetooth oder WLAN triggern einen Bluescreen oder auch nicht.
Alles verhält sich jedenfalls sehr inkonsistent und es ist nicht einheitlich bzw. erkennbar was genau passiert.

Ein Update aller Treiber von der Herstellerseite brachte keine Linderung (Chipsatz, NVIDIA, LAN, etc.) sondern machte das Problem gefühlt eher schlimmer.
BIOS Memory Profile XMP an/aus änderte nichts (an lief gefühlt etwas besser).
Ich setzte das System hier bereits mehrfach neu auf und testete ob der Bezug der Treiber über die Windowsupdate Funktion etwas ändern Würde. Auch negativ.
Auch ein update des B660 Mainboards auf das aktuellste BIOS (7D41v23 vom 31.03.22) half nichts.

Nach Recherche im Web war ich dann auf den Tipp gestoßen im BIOS die CPU Powersavingfeatures zu deaktivieren.
Ich deaktivierte also Intel C-State, Intel Speed Shift Technology und EIST.
Danach wurde es zum ersten mal besser. Das System crashte nicht mehr und ich "feierte" - leider verfrüht - meinen "Sieg".
Für gute ~6 Stunden (verteilt über drei Tage) gab es nicht einen Bluescreen.
Inzwischen zeigte sich aber, dass es leider doch noch nicht vorbei war mit den Problemen.

Seit dem deaktivieren der CPU Powersavingfeatures erhalte ich "nur" noch Bluescreens für:
-0x000001ca (SYNTHETIC_WATCHDOG_TIMEOUT)
- passiert ausschließlich bei niedriger Last beim idle in Windows/Youtube/Stream
- ca. alle 3-5 Stunden einmal
- ntoskrnl.exe+4bdb5a
-0x00000101 (CLOCK_WATCHDOG_TIMEOUT)
- passiert ausschließlich beim gaming ca. alle 1-3 Stunden
- ntoskrnl.exe+436e60

Andere Bluescreens kommen nicht mehr vor.
Auf diesem Stand bin ich jetzt seit gut 10 Tagen.
Das Verhalten ist dabei komplett reproduzierbar und ein reaktivieren der BIOS Features erhöht die Frequenz und Art der Bluescreens wieder deutlich.

Aus Verzweiflung habe ich bereits angefangen mir die Crashdumps via WinDbg mit "!analyze -v" anzugucken.
Es scheint jedenfalls in 100% der Fälle an "ntoskrnl.exe" zu liegen.

Ich weiß leider nicht weiter und tue mich sehr schwer wie ich nun am besten vorgehen sollte.
Erfahrung im debugging eines BSOD habe ich nicht.
Ich denke inzwischen aber, dass ein Softwareproblem nahezu ausgeschlossen sein sollte.
Leider bin ich über mein 14-Tage Rückgaberecht hinaus und möchte mir daher möglichst sicher sein, welcher Teil der Hardware die Probleme verursacht, bevor ich Ewigkeiten mit dem Austausch/Rücksenden der Parts beschäftigt bin.

Gerne kann ich auch die Crashdump files zur Verfügung stellen wenn dies helfen sollte.

Mein Hauptverdächtiger ist das Mainboard selbst oder gar die CPU.
Danach würde ich Netzteil oder GPU vermuten.
Dies ist aber alles mehr Bauchgefühl als Wissen.


Ich bitte um eure Hilfe!
 
Zuletzt bearbeitet:
Das Bios ist aktuell? Ja, sorry...

Sonst würde ich einfach mal eine Runde MemTest86 versuchen. Auch wenn du XMP bereits deaktiviert hast, wäre es schon hilfreich auszuschließen, dass hier eine Inkompatibilität besteht.
 
Mit den Verdächtigen hast du glaub ich nicht unrecht, meine Vermutung die CPU ist nicht stabil
 
In welchen Slots sitzt der Ram ?
Auch mal nur mit einen Riegel probiert ?
 
clock watchdog ist ziemlich sicher eine instabile cpu, also zu wenig vcore oder zu viel takt. obs an der cpu oder dem board liegt ist schwer zu sagen.

kannst du im bios ein cpu vcore voltage offset einstellen? oder Loadline Calibration?
 
  • Gefällt mir
Reaktionen: Ultrafigo und Nickel
Der Arbeitsspeicher steckt in DIMMA2 und DIMMB2.

MemTest86 kann ich erst in ca. 1 Stunde testen. Habe bisher nur das Windows Memory Diagnostics Tool durchlaufen lassen, dort gab es keine Auffälligkeiten. Melde MemTest86 Ergebnis sobald ich kann.
 
Im Ordner C:Windows/Mindump
befinden sich die Informationen zum blue screen.
Die letzten fünf Files auf den Desktop kopieren.
Mit rar oder zip verpacken.
Hier im Forum hoch laden.
 
@Drewkev @Amaoto
Habe Memtest86 jetzt für 2 1/2 Stunden laufen lassen.
IMG_20220521_221424.jpg

IMG_20220521_221518.jpg

Könnte über Nacht den Test nochmal vollständig durchlaufen lassen, aber wollte zumindest heute noch Rückmeldung geben.
Ergänzung ()

Silver Server schrieb:
Im Ordner C:Windows/Mindump
befinden sich die Informationen zum blue screen.
Die letzten fünf Files auf den Desktop kopieren.
Mit rar oder zip verpacken.
Hier im Forum hoch laden.
Anbei die dmp files. Allesamt von heute. Alle melden ntoskrnl.exe
3x CLOCK_WATCHDOG_TIMEOUT
2x SYNTHETIC_WATCHDOG_TIMEOUT

Bin über jede weitere Erkenntnis dankbar!
 

Anhänge

  • BSOD_0x000001ca_0x00000101.zip
    1,1 MB · Aufrufe: 154
Zuletzt bearbeitet:
STACK_TEXT:
ffffe280`99919c88 fffff806`0ca4be60 : 00000000`00000101 00000000`0000000a 00000000`00000000 fffff806`0ae35180 : nt!KeBugCheckEx
ffffe280`99919c90 fffff806`0c879e0d : 00000000`00000000 ffffe280`99900180 00000000`00000246 00000000`0005f52f : nt!KeAccumulateTicks+0x1d5270
ffffe280`99919cf0 fffff806`0c87a3b1 : 00000000`0005f52e 00000000`00038d14 ffffe280`99900180 00000000`00000001 : nt!KiUpdateRunTime+0x5d
ffffe280`99919d40 fffff806`0c874223 : ffffe280`99900180 00000000`00000000 fffff806`0d2468a8 00000000`00000000 : nt!KiUpdateTime+0x4a1
ffffe280`99919e80 fffff806`0c87cc22 : ffff8303`7053fa10 ffff8303`7053fa90 ffff8303`7053fa00 00000000`00000000 : nt!KeClockInterruptNotify+0x2e3
ffffe280`99919f30 fffff806`0c842a15 : 0000000e`34554cca ffffd18b`68cc22a0 ffffd18b`68cc2350 ffffdeb3`db92c9e9 : nt!HalpTimerClockInterrupt+0xe2
ffffe280`99919f60 fffff806`0ca0e7fa : ffff8303`7053fa90 ffffd18b`68cc22a0 00000000`000003fa 00000000`00000000 : nt!KiCallInterruptServiceRoutine+0xa5
ffffe280`99919fb0 fffff806`0ca0ed67 : ffff8303`7053fb30 00000000`00000001 00000000`00040046 fffff806`0c874b78 : nt!KiInterruptSubDispatchNoLockNoEtw+0xfa
ffff8303`7053fa10 fffff806`0ca1087a : 00000000`00000000 ffffe280`9990b540 ffffd18b`cb8e2680 00000000`000003fa : nt!KiInterruptDispatchNoLockNoEtw+0x37
ffff8303`7053fba0 00000000`00000000 : ffff8303`70540000 ffff8303`70539000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a


STACK_COMMAND: .thread 0xfffff8060d33ca00 ; kb

SYMBOL_NAME: nt!KeAccumulateTicks+1d5270

MODULE_NAME: nt

IMAGE_NAME: ntkrnlmp.exe

IMAGE_VERSION: 10.0.19041.1682

BUCKET_ID_FUNC_OFFSET: 1d5270

FAILURE_BUCKET_ID: CLOCK_WATCHDOG_TIMEOUT_IDLE_THREAD_VRFK_nt!KeAccumulateTicks
OS_VERSION: 10.0.19041.1
Bei den Stapelverarbeitung des Prozessor entstehen eine Ansammlung von Ticks. Das ist oft ein Problem der Einstellungen, der Treiber wie Chipsatztreiber oder Bios.
Erste Maßnahme das Bios aktualisieren. Den Chipsatztreiber des Motherboard Hersteller neu installieren.
Dann abwarten ob es noch zu einem blue screen kommt?

https://de.msi.com/Motherboard/MAG-B660-TOMAHAWK-WIFI-DDR4/support
https://de.msi.com/Motherboard/MAG-B660-TOMAHAWK-WIFI-DDR4/support#driver
 
duskstalker schrieb:
clock watchdog ist ziemlich sicher eine instabile cpu, also zu wenig vcore oder zu viel takt. obs an der cpu oder dem board liegt ist schwer zu sagen.

kannst du im bios ein cpu vcore voltage offset einstellen? oder Loadline Calibration?
Also das Board bietet die Funktion durchaus. Ich habe damit allerdings keine Erfahrung. Bisher sind alle Voltage Settings auf Auto. Ich würde hier ungerne unwissentlich herumspielen. Welche Werte bzw. welchen Mode würdest du testweise wählen?

MSI_SnapShot_1.jpg


MSI_SnapShot_2.jpg

Ergänzung ()

@Silver Server
Das Bios wurde bereits als eine recht frühe Maßnahme von mir aktualisiert. Eine neuere Version existiert noch nicht.

Der Chipsatz (und auch alle anderen Treiber) wurden bereits mehrfach neu installiert.
Selbst komplett Windows wurde mehrfach neu aufgesetzt und mit allen möglichen Treibervariationen ausprobiert.

Dies hilft leider nicht :/
 
Wie so arbeitet Dein Prozesssor mit 2100MHz?
Das ist auch in der Dumpfile zu sehen
[Processor Information (Type 4) - Length 48 - Handle 0050h]
Socket Designation U3E1
Processor Type Central Processor
Processor Family c6h - Intel Pentium M processor
Processor Manufacturer Intel(R) Corporation
Processor ID 72060900fffbebbf
Processor Version 12th Gen Intel(R) Core(TM) i7-12700
Processor Voltage 88h - 0.8V
External Clock 100MHz
Max Speed 4900MHz
Current Speed 2079MHz
Status Enabled Populated
Lade mal beim Bios die Default Einstellungen.
 
Silver Server schrieb:
Wie so arbeitet Dein Prozesssor mit 2100MHz?

Warum dem so ist weiß ich nicht.

Wie bereits im OP beschrieben, hatte ich durch Recherche "Intel C-State", "Intel Speed Shift Technology" und "EIST" deaktiviert. Abgesehen davon ist alles auf default.
[Anmerkung: Memory auf XMP ist wohl auch nicht auf default, das System läuft aber zumindest gefühlt besser mit XMP]

Ich kann gerne nochmal alles auf default zurück setzen, aber dann werde ich nur mit noch mehr bluescreens terrorisiert.
 
https://de.msi.com/Motherboard/MAG-B660-TOMAHAWK-WIFI-DDR4/support#cpu
2100 MHz scheint bei dem Prozessor mit dem Motherboard Normal zu sein.

--------

Ergänzung
CLOCK_WATCHDOG_TIMEOUT (101)
An expected clock interrupt was not received on a secondary processor in an
MP system within the allocated interval. This indicates that the specified
processor is hung and not processing interrupts.

Eine erwartete Taktunterbrechung wurde auf einem sekundären Prozessor in einem nicht empfangen MP-System innerhalb des zugewiesenen Intervalls. Dies zeigt an, dass die angegebene Prozessor hängt und verarbeitet keine Interrupts

Wenn Du keine Lösung findest würde ich den Prozessor vom Händler austauschen lassen.
 
Zuletzt bearbeitet:
b00kie schrieb:
Könnte über Nacht den Test nochmal vollständig durchlaufen lassen, aber wollte zumindest heute noch Rückmeldung geben.
Ja, das wird wohl keine neue Erkenntnisse mehr bringen. Aber versuch mal den Rechner mit einem Riegel laufen zu lassen und schau, ob es die Bluescreens immer noch gibt.

b00kie schrieb:
Das Bios wurde bereits als eine recht frühe Maßnahme von mir aktualisiert. Eine neuere Version existiert noch nicht.
D.h. diese Probleme gab es auch schon mit einem älteren Bios?

Silver Server schrieb:
2100 MHz scheint bei dem Prozessor mit dem Motherboard Normal zu sein.
Eigentlich mit jedem Mainboard. Das ist der Basistakt der CPU.

Screenshot 2022-05-21 Intel® Core™ i7-12700 Prozessor (25 MB Cache, bis zu 4,90 GHz) – Produkt...png
 
Silver Server schrieb:
Lade mal beim Bios die Default Einstellungen.
@Silver Server Also ich hatte das Bios jetzt nochmal auf default gesetzt (und damit Intel C-State etc. wieder aktiviert). Als Folge wurde ich in unter 30 Minuten mit drei Bluescreens beglückt. Wie erwartet sind nun auch andere BSOD wieder mit von der Partie.

Konkret waren es:
  • 0x0000000a (IRQL_NOT_LESS_OR_EQUAL)
  • 0x00000101 (CLOCK_WATCHDOG_TIMEOUT)
  • 0x000001ca (SYNTHETIC_WATCHDOG_TIMEOUT)
Anbei die drei dmp files. Vielleicht lässt sich daraus ja etwas anderes lesen?

Ich habe jedenfalls C-State etc. erstmal wieder deaktiviert damit das System wenigstens für ein paar Stunden nicht crasht.
 

Anhänge

  • BSOD_DefaultBios.zip
    657,9 KB · Aufrufe: 153
Am Fehler hat sich nichts geändert, es ist der gleiche Fehler.
Ich würde den Prozessor vom Händler austauschen lassen.
 
Zurück
Oben