Niedrige FPS bei externem Monitor

SaxnPaule

Admiral
Registriert
Okt. 2010
Beiträge
9.262
Hallo Community,

ich hab mal wieder eine Herausforderung für die ich fast vermute, dass es keine Lösung gibt.

Habe hier ein Notebook (HP 745 G5) mit Ryzen und Vega 8 Grafik. Schließe ich einen Monitor über HDMI an habe ich in meiner Testszene ~50 FPS. Spiele ich auf dem integrierten Display, ebenfalls ~50 FPS.

Nun ist es so, dass ich an dem Laptop normalerweise ein Dell D6000 Dock per USB-C angeschlossen habe. Daran hängt der Monitor und die restliche Peripherie. Starte ich jetzt mein Spiel habe ich nur ~20FPS, also weniger als die Hälfte.
Alle Einstellungen identisch. Gehe ich recht in der Annahme, dass in diesem Moment nicht die interne Vega 8 zum Rendern genutzt wird, sondern die im Dock verbaute Display Link irgendwas GraKa?

1574192738352.png


Alle anderen Anzeigen habe ich zu diesem Zeitpunkt deaktiviert. Der Monitor ist der einzige Bildschirm auf welchem etwas dargestellt wird.
Monitor hatte ich zu diesem Zeitpunkt auf FullHD mit 60Hz gestellt, genauso wie beim Test über HDMI.

Die Frickellösung ist es natürlich jedes Mal zusätzlich ein HDMI Kabel anzuschließen und am Monitor auf diesen Eingang zu wechseln. Will ich aber nicht, wenn es auch eine schöne Lösung gibt.
 
Wäre ja eine Bestätigung für meine Annahme:
SaxnPaule schrieb:
Gehe ich recht in der Annahme, dass in diesem Moment nicht die interne Vega 8 zum Rendern genutzt wird, sondern die im Dock verbaute Display Link irgendwas GraKa?
 
Ich glaub die Vega 8 ist für 4K einfach zu Langsam.
Viele games Initieren die auflösung bei jedem start neu, d.h. wenn du das USB C dock einsteckst Drückt die Auflösung deine FPS.
 
Dir ist aber schon bewusst, dass die Grafikkarte bei einer UHD Auflösung vier Mal so viele Pixel zu berechnen hat, wie bei FullHD?
 
Soll ich mich nochmal wiederholen? Der Monitor war zu jedem Zeitpunkt des Tests auf FullHD = 1920x1080 eingestellt!

Selbst wenn nicht, im Spiel ist die Einstellung ebenfalls hart auf 1920x1080 eingestellt.
 
SaxnPaule schrieb:
Wäre ja eine Bestätigung für meine Annahme:
Nein, ist es in deinem Fall nicht. Das Dock hat keine integrierte Grafikeinheit und bei dir kann nicht auf die "falsche" gewechselt werden, weil du nur eine hast.

Die Antwort ist doch direkt in der ersten Antwort* unter dem Link von Weasel0815 zu finden, du musst nur lesen.

Es geht mit dem Dock nicht. Punkt. Anderes Dock kaufen oder HDMI Kabel umstecken, etwas anderes bleibt dir nicht übrig.

*It’s because the Dxxxx series docks use DisplayLink rather than tapping into native GPU outputs. DisplayLink uses a driver to have the CPU and GPU compress video for transmission as regular USB traffic, and then a chip in the dock decompresses it and transmits it to the displays. That’s why you’re seeing all that CPU activity and horrible performance. DisplayLink is fine for basic productivity tasks, but when lots of the display area is changing at once, such as when gaming or watching full screen video, that’s a lot more work to do, so your CPU gets busy and you can end up with jerky/judder-y video. You can also see these types of issues if your USB bus is busy with other traffic, such as a large file transfer. And even without any of that, DisplayLink’s compression isn’t lossless, so you can end up with visible judder or blocky video for that reason alone.
 
Zuletzt bearbeitet von einem Moderator:
Ja, das habe ich ja bereits befürchtet. Anderes Dock geht nicht, da mir 2x4K@60Hz wichtig sind und da gibt's nur zwei Docks auf dem Markt.

Also extra Strippen ziehen :(
 
Zurück
Oben