Windows hängt sich ohne erkennbaren Grund auf - SSD schuld?

Stanceland

Ensign
Dabei seit
März 2006
Beiträge
157
Hallo,

vorab einmal die Daten des Rechners:

Asrock P67 Extreme6
Intel Core i7-2600k (gekühlt mit einem Scythe Mugen 3)
Gainward GTX 570 Phantom
16 GB Corsair DDR3-1333
G.Skill Falcon II 128 GB
3x 2 TB Western Digital HDD + 1x 500 GB Samsung HDD
beQuiet Straight Power 500 Watt
Windows 7 Premium 64 Bit

Abgesehen von der SSD, der 500 GB HDD und dem Netzteil habe ich alle Komponenten vor 8 Monaten erworben. Die SSD ist ca. 1 Jahr alt, die 500 GB Platte ist ca. 3 Jahre alt.

Nun habe ich seit ca. einem halben Jahr ein Problem, dass leider immer wieder auftritt. Dies äußert sich schlicht und ergreifend darin, dass sich Windows mehr oder weniger aufhängt - und zwar weder nach einer bestimmten Zeit, noch bei einer bestimmten Aktivität (manchmal passiert es erst nach einer Woche, manchmal nach 15 Minuten, manchmal beim Zocken, manchmal beim Surfen)

Dieses "Aufhängen" äußert sich dadurch, dass keine Programme mehr gestartet werden können - es passiert einfach nichts. Versuche ich bereits geladene Programme zu schließen oder den Taskmanager zu erreichen, so erhalte ich diverse Fehlermeldungen (je nach Programm unterschiedlich, meist irgendwelche kryptischen Speicherfehler oder der Windows-Hinweis, dass das System nicht mehr reagiert und neu gestartet werden muss).

Windows kann auch nicht mehr auf traditionelle Art und Weise heruntergefahren werden, ich muss den Rechner per Knopfdruck ausschalten. Nach einem Neustart funktioniert alles wieder tadellos, Windows startet normal, ich kann gänzlich normal weiterarbeiten.

Rufe ich anschließend die Ereignisanzeige auf, erhalte ich folgenden Bericht:

Ereignis-ID: 41
Quelle: Kernel-Power
EventData:
- BugcheckCode 0
- BugcheckParameter1 0x0
- BugcheckParameter2 0x0
- BugcheckParameter3 0x0
- BugcheckParameter4 0x0
- SleepInProgress false
- PowerButtonTimestamp 0

Nachdem ich hier ein wenig recherchiert habe, bin ich auf unterschiedliche Lösungsmöglichkeiten gestoßen:

1) Der Fehler könnte im Zusammenhang mit dem Nvidia HD Audio Treiber stehen. Diesen habe ich testweise deinstalliert. Das Problem blieb unverändert bestehen.
2) Der Fehler könnte im Zusammenhang mit Energiesparmaßnahmen stehen. Ich habe probeweise sämtliche Energiesparmaßnahmen sowohl im Bios als auch unter Windows ausgeschaltet, leider ebenfalls ohne Erfolg.

Es wird aber noch merkwürdiger: Ich habe den Rechner in den letzten 8 Monaten insgesamt 3x formatiert und Windows 7 neu aufgesetzt (einmal ganz zu Beginn, als ich den Rechner neu zusammengestellt hatte). Nach der Formatierung tritt der Fehler mindestens einen Monat (!) niemals auf.

Sofern nicht gerade der besagte Fehler auftritt, kann ich z.B. Prime95 den ganzen Tag laufen lassen, ohne, dass irgendwas passiert. Die Temperaturen sind allesamt im grünen Bereich. Auch habe ich den Arbeitsspeicher schon einmal mit Memtest86+ getestet (lief 24 Stunden durch - Ergebnis: nicht ein einziger Fehler).

Meine Vermutung, als es zum ersten Mal zu dem Problem kam und eine Formatierung geholfen hatte, war, dass es sich um einen Windows-Fehler handelt. Aber leider Gottes kann ich nun schon erfahrungsgemäß sagen, dass dies so gut wie ausgeschlossen ist. Denn nach der Ersteinrichtung des Systems, ändere ich kaum bzw. gar nichts mehr an den Windows-Einstellungen. Seit dem letzten Mal Formatieren habe ich nichtmals mehr neue Treiber oder sonst irgendetwas installiert (abgesehen vom allerersten Tag halt). Und auch hier lief der PC bis heute 1,5 Monate absolut problemlos und stabil.

Nun wäre meine Vermutung, dass das Problem bei der SSD liegt. SATA-Controller würde ich ausschließen, da genug andere Festplatten am Mainboard hängen und der Fehler somit doch eigentlich deutlich häufiger auftreten müsste. Auch das Netzteil kann es ja eigentlich nicht sein, da dieses ja wohl eher beim Zocken den Dienst quittieren würde als beim Surfen.

Ich möchte eigentlich nur ungern auf unbestimmte Zeit wieder eine normale Festplatte verwenden, um sicherstellen zu können, dass beim Betrieb eben jener das Problem nicht auftritt (wie gesagt, nach dem Formatieren läuft der PC mindestens einen ganzen Monat oder länger stabil). Natürlich habe ich keine 2. SSD zur Hand :D

Deswegen wollte ich mich hier erkundigen, ob es theoretisch denn überhaupt möglich wäre, dass es an der SSD liegt oder ob eher eine andere Komponente in Frage käme.

Vielen Dank für eure Hilfe im Voraus!
 

FireBird352

Lieutenant
Dabei seit
Nov. 2010
Beiträge
538
Versuch mal nur 4/8GB Ram zu verwenden, vielleicht kommt dein Board mit der Ram Menge nicht mit.
 
U

uNrEL2K

Gast
Der Sandforce-Controller in deiner SSD ist für seine Unzuverlässigkeit bekannt. Das kann also daran liegen.
Aber vllt. ist es ja nur ein kaputtes SATA-Kabel -> das der SSD kannst du ja mal austauschen. Um klein anzufangen ;)
BSODs hast du nicht erwähnt, ich nehme an das keine Auftreten wenn sich dein System aufhängt, weshalb man hier leider nicht ansetzen kann.
Ein etwas größerer Schritt wäre temporär auf eine HDD umzusteigen. Fix das System von SSD auf HDD geclont und geschaut, ob besagtes Problem immer noch auftritt.
Wenn du genug RAM hast um alle Programme offen zu lassen und immer brav den Standby verwendest (anstatt Herunterfahren) lässt sich der Speed-Rückschritt auf die HDD ertragen. Ich spreche hier aus Erfahrung ;) und ist ja nicht auf Dauer
 

Halo20

Ensign
Dabei seit
Jan. 2005
Beiträge
159
1. Hast du schon ein BIOS Update versucht?
2. Werden bei einer Windows Festplattenüberprüfung (Checkdisk) Fehler auf der SSD gefunden?
 

Birke1511

Lt. Commander
Dabei seit
Aug. 2010
Beiträge
1.315
Leider habe ich das gleiche problem mit meiner 1. Jahr alten ocz vertex 2 ex.der rechner bleibt einfach hängen und nichts geht mehr.ich tippe ganz klar auf einen defekt der ssd.
 
U

uNrEL2K

Gast
@meckswell

ow, hast recht, hab seine G.Skill Falcon mit einer anderen Serie dieses Herstellers verwechselt, dessen Sortiment mir nicht so geläufig ist :freaky:

Aussage bleibt dennoch die selbe. Indilinx hat sich dahingehend nämlich auch nicht gerade mit Ruhm bekleckert.

@Stanceland

Gib uns mal die SMART-Werte der SSD hier durch.
 
Zuletzt bearbeitet:

Stanceland

Ensign
Ersteller dieses Themas
Dabei seit
März 2006
Beiträge
157
Vielen Dank erstmal für die schnellen Antworten.

Vom Arbeitsspeicher könnte ich natürlich mal probeweise 2 Riegel entfernen, obwohl ich mich dann wirklich fragen würde, warum der PC frisch nach dem Formatieren nie Probleme mit den 16 GB hat.


Das SATA-Kabel hatte ich bereits einmal gewechselt, ebenso habe ich vor ca. 3 Monaten ein Bios Update durchgeführt (habe leider vergessen dies auch noch zu erwähnen, da ich mittlerweile schon soviel probiert habe...).

Die Windows-Festplattenüberprüfung hat keine Fehler auf der SSD ergeben.


Ich werde wohl wirklich am Wochenende mal den Versuch mit einer HDD starten und das bestehende System klonen.

Da Birke1511 exakt das gleiche Problem mit der Vertex hat, liegt es in meinen Augen nun wirklich am nahe, dass die SSD schuld ist (auch wenn es ein Indilinx und kein Sandfroce Controller ist. Wer kann schon sagen, ob Indilinx nicht auch derartige Probleme verursacht, wenn auch eventuell seltener?). In dem Falle kann ich persönlich wiederum nur sagen, dass ich mit G.Skill SSDs ganz schön Pech hatte - es ist nämlich schon meine 3. Falcon II in ~2 Jahre :D

Die erste wurde nach einem guten halben Jahr an meinem alten PC nicht mehr erkannt und ich durfte sie einschicken. Die neue SSD, die sie zurückgeschickt hatten, war von Anfang defekt und wurde an keinem einzigen PC erkannt. Und sollte sich der Verdacht bestätigen, wäre die jetzige 3. Falcon II ebenfalls kein Musterbeispiel für Zuverlässigkeit...

Anbei die SMART-Werte der SSD (das "Vorsicht" bei der einen Festplatte bezieht sich auf einen "schwebenden Sektor". Dabei handelt es sich um die alte 500 GB Festplatte, die schon knapp 20.000 Betriebsstunden auf dem Buckel hat - sollte aber eigentlich kein Problem darstellen, solange es nicht mehr Fehler werden, oder?)
 

Anhänge

Zuletzt bearbeitet:
U

uNrEL2K

Gast
Vielen Dank erstmal für die schnellen Antworten.

Vom Arbeitsspeicher könnte ich natürlich mal probeweise 2 Riegel entfernen, obwohl ich mich dann wirklich fragen würde, warum der PC frisch nach dem Formatieren nie Probleme mit den 16 GB hat.
Das der RAM Probleme macht halte ich für unwahrscheinlich, hast ja schon nen rel. langen Memtest gemacht.

Anbei die SMART-Werte der SSD (das "Vorsicht" bei der einen Festplatte bezieht sich auf einen "schwebenden Sektor". Dabei handelt es sich um die alte 500 GB Festplatte, die schon knapp 20.000 Betriebsstunden auf dem Buckel hat - sollte aber eigentlich kein Problem darstellen, solange es nicht mehr Fehler werden, oder?)
Darauf liegen wahrscheinlich keine Daten deines OS', daher wahrscheinlich kein Zusammenhang zu deinem Problem.

Kann es sein, dass die 5 Lesefehler mit der Anzahl der Aufhänger des OS' korrelieren?
 

Stanceland

Ensign
Ersteller dieses Themas
Dabei seit
März 2006
Beiträge
157
Leider nein, insgesamt dürfte sich der PC schon eher ~25x aufgehangen haben in den letzten 6 Monaten :(
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
54.915
Prüfe mal ob der Schlüssel CrashDumpEnabled in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl] auf 3 steht, denn dann sollte bei jedem BSOD ein Minidump geschreiben werden. Mit Blue Screen View kannst Du Dir die mal ansehen. Sind keine vorhanden, so rückt das Systemlaufwerk in den Focus und wenn viele verschiedene Ursachen auftauchen, so teste mal mit Memtest86 das RAM. Dazu von CD oder USB-Stick booten, min. 6 PASS abwarten und es darf dabei kein Fehler auftreten (also am Besten über Nacht laufen lassen).

RAM-Fehler können die unmöglichsten Bluescreens erzeugen, man sollte also immer erstmal sein RAM testen, wenn man Bluescreens bekommt oder am RAM etwas verändert hat.
 
Top