Ein paar Fragen zu Einstellungen bei Linux

N30cron

Cadet 3rd Year
Registriert
Feb. 2006
Beiträge
50
Da ich Open Suse endlich als 10.3-Version zum Laufen bekommen hab, tun sich nun ein paar fragen bei mir auf:
1. Wie kann ich die Bildwiederholungsfreqenz höher stellen? (im augenblick flackert mir der Monitor 60Hz entgegen...und das macht schon nen unterschied, wenn man 85Hz gewohnt ist unter Windows)
2. Wie kann ich die ganzen updates, die sich Linux jetzt einzeln runterläd alle auf einmal laden lassen? (ich habs satt, das ich alle 2min nen Passwort eingeben muss...)
3. Wie kann ich Linux beibringen, das meine Grafikkarte 3D unterstützt? (Bisher zeigt er mir immer an, das die dafür nicht konfiguriert sei...)
4. Wo finde ich einen Treiber für meine Grafikkarte? (auf der ATI-seite gibs keinen für die x1950serie)
auch wenn das vllt dumme Fragen sind, aber als Linux-Einsteiger weiß ich an dieser stelle nich weiter.
 
Zuletzt bearbeitet:
Als allererstest solltest du mal lernen, das es nicht nur "Linux" gibt, es gibt viele verschiedene Arten von "Linux" da du Version 10.3 erwähnt hast, schätze ich du hast OpenSuSE, unter anderem wären auch noch Ubuntu eventuell eine Distribution was für dich.

Ich hab mein SuSE grad nicht da, aber heute abend werde ich vielleicht mal booten...

Es wäre aber besser du findest zumindest das erste selbst heraus ;)

3D unterstützung kannst du einstellen unter:
Yast (pw eingeben) -> Hardware (glaube ich) -> Grafikkarte (oder ähnlich)
dann geht ein fenster auf und (ehrlichgesagt hab ichs am anfang auch übersehen) in dem fenster weiter unten sollte ein kästchen sein, in das du nur klicken musst ;)
(sry für die vagen antworten, hab wie gesagt suse grad nich parat)

Wegen den Updates, weiß ich grad garnich was du meinst, bei mir is da das SuSE symbol in der "Taskleiste" und wenn updates verfügbar sind schreit das halt, einmal pw eingeben, und schon saugt und installt er alles notwendige :p

MFG
Wayne
 
also das mit dem 3D-Kästchen hab ich gefunden, is aber deaktiviert.
Ich bekomm auch immer ne Fehlermeldung, wenn ich auf Grafikkarte und Monitor zugreifen will:
"SaX2 kann keine Aktivierung des 3D-untersystems anbieten, weil ihre grafikkarte bzw. ihr Grafikkartentreiber kein 3D unterstützt."

so...was mach ich da nun??
hab mir shcon den Treiber für Linux hier von Computerbase.de gezogen, aber wie installier ich den jetzt?

das nächste ist, das er jetzt schon ewig versucht immer das gleiche Update zu saugen und zu installieren.
dann sag ich ihm er solls machen, dann passiert auch was und kurze zeit später zeigt er wieder an, das er das was er bereits gezogen hat gern nochmal ziehen will und installieren.
 
Zuletzt bearbeitet:
SaX2 erkennt die Karte auch nicht.
Du musst den ATI Treiber "fglrx" installieren, am Besten mit:
1-Click Install:
http://opensuse-community.org/ati.ymp
Klicke auf diesen Link, und der aktuelle Grafikkartentreiber für ATI wird automatisch installiert.
Siehe auch "The Easy Way":
http://en.opensuse.org/ATI#The_Easy_Way

Siehe auch hier zu weiteren Paketen mit 1-Click Install:
http://opensuse-community.org/1-click-collection

Siehe auch diesen Thread:
https://www.computerbase.de/forum/t...l-linux-auf-den-pc.379197/page-3#post-3807333

Siehe auch diese Linkliste mit vielen Verweisen auf wichtige Doku zur Konfiguration:
https://www.computerbase.de/forum/t...t-fuer-mich-die-richtige.259765/#post-3818647

gruss, limoni
 
Zuletzt bearbeitet: (The Easy Way)
So hab nun über die 1-Click Install das installiert, aber immer noch bekomm ich diese Fehlermeldung und kann auch nicht dieses Kästchen anklicken, der den 3D-Beschleuniger aktiviert.
 
N30cron schrieb:
so...was mach ich da nun??
hab mir schon den Treiber für Linux hier von Computerbase.de gezogen, aber wie installier ich den jetzt?
Der Treiber von Computerbase ist eine .bin datei. Also eine ausführbare Datei. probier es einfach mal mit
sudo pfad
(der Pfad is wahrschienlich /home/Benutzername/Desktop/Dateiname oder so)
 
"SaX2 erkennt die Karte auch nicht."
das funktioniert trotzdem.

hast du folgendes aus der Anleitung beachtet?
Open a terminal and type "sudo aticonfig --initial". This will configure X to use the ATI driver.

was sagt
fglrxinfo
?

gruss, limoni
 
Du kannst die Frequenz in der xorg.conf (sofern Du xOrg verwendest) einstellen:

/etc/X11/xorg.conf

Hier ein Beispiel meiner Konfiguration (DualScreen)

Code:
Section "Monitor"
Identifier     "Monitor1"
VendorName     "HannsG"
ModelName      "HSD HC194D"
HorizSync       31.0 - 81.0
VertRefresh     56.0 - 75.0
Option         "DPMS"
EndSection

Section "Monitor"
Identifier     "Monitor0"
VendorName     "HannsG"
ModelName      "HSD HC194D"
HorizSync       31.0 - 81.0
VertRefresh     56.0 - 75.0
Option         "DPMS"
EndSection
 
Dafür wird doch das "Catalyst Control Center" mitinstalliert:

image.php

http://www.phoronix.com/scan.php?page=article&item=671&num=1

Das müsste sich irgendwo im Systemmenu wiederfinden.

edit:
Und was sagt der Aufruf von SaX2?
Siehe auch folgende Optionen für SaX2:
https://www.computerbase.de/forum/threads/suse-wie-kann-ich-gcc-installen.313776/page-3#post-3106435

gruss, limoni
 
Zuletzt bearbeitet:
Den Befehl in die konsole eingeben habsch vergessen. Habs nun nach gemacht aber:
Fehlermeldung nach wie vor.
musste meinen Monitor noch mal komplett neu manuell einstellen.

fglrxinfo:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.7276 Release

Aufm Arbeitsplatz wird jetz auch angezeigt, das der fglrx als Treiber und das der 3D-unterstützung bietet.
kanns allerdings immer noch nich aktivieren.

ich hab das auch alles nochmal als screen angehängt: http://www.hostpix.de/file.php?dat=iROxiu0s.jpg
 
das is dann mal meine xorg.conf:
# /.../
# SaX generated X11 config file
# Created on: 2008-02-17T15:46:26+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "Logic3 / SpectraVideo plc PS/2+USB Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 386 290
HorizSync 30-91
Identifier "Monitor[0]"
ModelName "PHILIPS 109E5"
VendorName "PHL"
VertRefresh 50-160
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 106.97 1280 1360 1496 1712 1024 1025 1028 1059
Modeline "1152x864" 107.91 1152 1224 1352 1552 864 865 868 903
Modeline "1152x864" 98.61 1152 1224 1344 1536 864 865 868 900
Modeline "1152x864" 90.48 1152 1224 1344 1536 864 865 868 897
Modeline "1024x768" 100.19 1024 1088 1200 1376 768 769 772 809
Modeline "1024x768" 88.50 1024 1088 1200 1376 768 769 772 804
Modeline "1024x768" 76.16 1024 1080 1192 1360 768 769 772 800
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
Modeline "800x600" 60.07 800 840 928 1056 600 601 604 632
Modeline "800x600" 53.14 800 840 928 1056 600 601 604 629
Modeline "800x600" 45.50 800 840 920 1040 600 601 604 625
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
Modeline "1152x864" 108 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
Driver "fglrx"
Identifier "Device[0]"
Screen 0
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
 
Hallo!
"SaX2 erkennt die Karte auch nicht."
Wie oft soll ich dass denn noch sagen?
Das funktioniert trotzdem.

Der Treiber ist laut fglrxinfo aktiviert.
Die Einstellungen laufen nun über das Catalyst Control Center.

Hast du einfach mal eine 3D Anwendung gestartet?
Wie viele FPS liefert
glxgears
?
Alternativ:
fglrxgears
?

gruss, limoni
 
Zuletzt bearbeitet:
glxgears
43484 frames in 5.0 seconds = 8696.686 FPS
37443 frames in 5.0 seconds = 7488.506 FPS
35184 frames in 5.0 seconds = 7036.685 FPS
36922 frames in 5.0 seconds = 7384.292 FPS
37205 frames in 5.0 seconds = 7440.996 FPS
36868 frames in 5.0 seconds = 7373.490 FPS
40165 frames in 5.0 seconds = 8032.823 FPS

Hab bisher keine 3D Anwendung ausprobiert.
Wenn allerdings glxgears ein Indikator dafür ist, das es funktioniert, wäre das damit ja abgeschlossen.
was mich allerdings immer noch ärgert ist, das ich die Bildwiederholfrequenz nicht geändert bekomm.
Auch über Catalyst kann ich nicht umstellen. denn eigentlich könnt ich bei 1280*1024 85Hz fahren, aber ich schaffs nich es einzustellen. und 59Hz sind doch echt augenkrebs erzeugend^^ (vor allem bei Röhremonitor)

ach ja: warum läd der updater die ganze zeit immer die gleiche Datei?? http://www.hostpix.de/file.php?dat=mvoOijPA.jpg
 
Zuletzt bearbeitet:
Deine "Modeline" für die 1280er Auflösung ist falsch, bzw. du hast keine Modeline für 85Hz, sondern nur für eben 59Hz!
So wäre sie richtig, ermittelt mit gtf:
Code:
[B]gtf 1280 1024 85[/B]

  # 1280x1024 @ 85.00 Hz (GTF) hsync: 91.38 kHz; pclk: 159.36 MHz
  Modeline "1280x1024_85.00"  159.36  1280 1376 1512 1744  1024 1025 1028 1075  -HSync +Vsync
Diese 2 Modeline Zeilen (# ist der Kommentar) in der xorg.conf Section "Modes" hinzufügen.

siehe auch:
https://www.computerbase.de/forum/threads/fedora-core-6-installationsprobleme.243829/#post-2381278

edit:
Ach ja, deine FPS unter glxgears sind schon sehr hoch, das läuft also mit 3D Hardwareunterstützung.
Achtung, glxgears ist kein Benchmark, sondern liefert nur relative Vergleichsmöglichkeiten.

gruss, limoni
 
Zuletzt bearbeitet:
du musst die datei als root ändern.
empfehlung:
installiere dir vorher mit yast einen einfacheren editor als "vim", z.B. "nano"
alternativ mit "zypper"
Code:
[B]su[/B]
Passwort:

[B]zypper install nano[/B]
bevor du etwas änderst, erstelle eine kopie:
Code:
[B]cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak[/B]
die kannst du im fehlerfall zurückspielen.

dann mit nano als root die xorg.conf editieren:
Code:
[B]nano /etc/X11/xorg.conf[/B]
das alles passiert natürlich auf der konsole bzw. im terminal.
was das ist, wirst du ja hoffentlich wissen...

Alternativ mit KDE: (unter Gnome musst du mal selber schauen, siehe auch die Doku)
KMenu / System / Dateiverwaltung / Konqueror(Systemverwaltungsmodus)
root Passwort eingeben
nach /etc/X11 navigieren
rechtsklick auf die xorg.conf
öffnen mit: "Kate"
und die xorg.conf editieren.
abspeichern.

Für weitere Einsteigerfragen verweise ich nochmals auf meine Linkliste:
https://www.computerbase.de/forum/t...t-fuer-mich-die-richtige.259765/#post-3818647
Schau dich dort ruhig erst einmal um.

gruss, limoni
 
Zuletzt bearbeitet: (xorg.conf pfad korrigiert / alternativ Systemverwaltungsmodus KDE)
falls du nicht wissen solltest, wie man das als root macht:
sudo nano /etc/xorg.conf


edit:sry. bin (k)ubuntu gewöhnt^^
hab aber schon mehrere HIlfethreats gesehen, in denen mit sudo gearbeitet wird *am Kopf kratz*
 
Zuletzt bearbeitet:
dein Pfad ist falsch!
unter openSUSE wird üblicherweise nicht mit "sudo" gearbeitet.

edit:
sudo funktioniert unter openSUSE 10.3 auch, nur wird hier das root Passwort abgefragt, und nicht das des Users.
Das bringt mehr Sicherheit, als alles mit einem einzigen User Passwort zu erledigen, welches nur der Bequemlichkeit dient..

Allerdings sind die meisten Anleitungen für Konfigurationsaufgaben darauf angelegt,
dass man eben als root angemeldet ist - und dafür gibt es den root ja auch.
Ist halt ein anderes Konzept, welches Ubuntu da verfolgt.

gruss, limoni
 
Zuletzt bearbeitet:
^^ ich wüsst gar nich, was ich ohne euch und das Computerbase.de-Forum machen würd.
THX für eure tolle Hilfe^^ endlich kein geflacker mehr und allein hätt ich das mit meinen Einsteigerskills nie im Leben hinbekommen.
Damit wären dann schon 2 Probleme gelöst.
Verbleibt nur noch 1: warum läd der updater die ganze zeit immer die gleiche Datei?? ich hab da mal von nen Screen gemacht: http://www.hostpix.de/file.php?dat=mvoOijPA.jpg
 

Ähnliche Themen

Antworten
19
Aufrufe
1.255
Antworten
145
Aufrufe
8.169
Antworten
36
Aufrufe
1.939
Wochenende
W
Zurück
Oben