[HTML] Problem mit Flasheinbindung

Po§tm@n_VS

Ensign
Dabei seit
Sep. 2002
Beiträge
156
HTML Problem mit Flasheinbindung

Hallo ich habe folgendes Problem beim Einbinden von Flash als Banner in HTML. Ich will die Flash-Animation auf ne Website verlinken. Das klappt auch und wenn ich im Browser die Animation mit der Maus berühre wird der Link gezeigt aber nicht ausgeführt. (Internet Explorer)
Unter Mozilla funktioniert es aber:

Code:
<a href="http://XXX.html">

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width=315 height=72 align=center id=banner>

<PARAM name="Movie" value="button1.swf">
<PARAM name="loop" value="true">
<PARAM name="wmode" value="transparent">

<EMBED src="button1.swf" width=600 height=100 align=middle LiveConnect=true pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" LOOP=FALSE wmode="transparent" name="banner"></EMBED>

</OBJECT>

</a>
 
Zuletzt bearbeitet:

Dytec

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
94
Re: HTML Problem mit Flasheinbindung

Wenn ich es richtig verstanden habe möchtest du mit dem Flashbutton einen Link öffnen, richtig ? Wenn das mit dem JS Befehl in HTML nicht funktioniert dann lege einfach folgenden AS-Befehl auf den Button:

getURL ("www.deineverlinkteSeite.de/seite.htm", "_blank");
 
Zuletzt bearbeitet:

Po§tm@n_VS

Ensign
Ersteller dieses Themas
Dabei seit
Sep. 2002
Beiträge
156
Danke.

Sorry für die doofe Frage aber an welcher Stelle binde ich das ein?
 

niz

ᴬ7ᵪ
Dabei seit
Nov. 2001
Beiträge
24.292
warum legst du kein on_press als aktion in das flash? also, dass du den link mit target in die animation eingibst und nicht im html code.
 

Dytec

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
94
@ Postman
Dazu benötigst du Flash selbst und natürlich die Fla Datei (Quelldatei) des Buttons.

@DunkelAngst: Das On Press hate ich vergessen ;)
 

Po§tm@n_VS

Ensign
Ersteller dieses Themas
Dabei seit
Sep. 2002
Beiträge
156
Flash habe ich nicht benutzt. Habe anhand Mix-FX die Flash-animation erstellt. Dort kann man keine Links einbauen. Deshalb die Lösung anhand des a href.

Die Frage ist warum es unter Mozilla Firebird funzt und beim IE nicht!

@Dytec: kannst du mir geturl in den obrigen Code einbinden?

Danke
 

value

Commander
Dabei seit
Dez. 2003
Beiträge
2.086
Eventuell könnte es auch nur daran liegen das sich der IE am <embed> gestört fühlt. Embed kommt eigentlich von NN und wird von IE zumindest offiziell nicht unterstützt.
Du kannst auch hier mit <object> arbeiten.
 

Po§tm@n_VS

Ensign
Ersteller dieses Themas
Dabei seit
Sep. 2002
Beiträge
156
nein das klappt dann auch immer noch nicht
 

Po§tm@n_VS

Ensign
Ersteller dieses Themas
Dabei seit
Sep. 2002
Beiträge
156
ok mach ich. danke für das Angebot
 

Dytec

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
94
@Postman ich habe mir mal die Flashdatei angeschaut und habe nun folgendes Problem. Da die Buttonanimation per AS eingebunden wurde und nicht als Tweenanimation, kann ich dem Button leider nicht die gewünschte Funktion verpassen (da es schon am Import scheitert). Denn bei einer Tweenanimation hätte ich von der Animation jeweils alle Einzelbilder importieren und hätte problemlos einen Button darunter deklarieren können.
Ich hatte zwar auch das AS analysiert und auf einen Textbutton übertragen, allerdings bewegt sich dieser dann nicht wie in der ursprünglichen Quelldatei.
Ich könnte jetzt noch versuchen die Animation per Tween nachzustellen wenn dir das reichen würde ?
P.s: Ich bräuchte noch den Buttonfont.
 
Zuletzt bearbeitet:

Po§tm@n_VS

Ensign
Ersteller dieses Themas
Dabei seit
Sep. 2002
Beiträge
156
danke das du dir so viel Mühe machst. Das Font ist nicht so wichtig - sollte nur so ähnlich aussehen.
 
Top