Apache Server mit Passwort schützen

Black.--.Hawk

Lt. Junior Grade
Dabei seit
Juli 2005
Beiträge
313
Hi!
Ich habe ein Problem und zwar klappt das bei mir nicht mit dem Passwort.
Kann mir mal einer erklähren, was ich genau machen muss, damit ich die Datein auf meinem Server sichern kann?
Habe den Apache/1.3.35
Währ echt nett!
Thx schonmal.
Greetz
 

Keita

Lt. Commander
Dabei seit
Dez. 2006
Beiträge
1.282
Du benötigst in der einfachsten Variante eine .htaccess-Datei im zu schützenden Verzeichnis sowie eine Datei mit mit den User/Passwort-Kombinationen möglichst außerhalb des DocumentRoots. Die .htaccess-Datei hätte folgenden Aufbau:
Code:
AuthType Basic
AuthName "Mein Tresor"
AuthUserFile /pfad/zur/passwort/datei
Require valid-user
Die Passwort-Datei (in diesem Fall) /pfad/zur/passwort/datei legst Du mit Hilfe des Programms htpasswd an:
Code:
htpasswd -c /pfad/zur/passwort/datei BlackHawk
htpasswd wird dich nach dem Passwort fragen und bei erfolgreicher Verifikation die Datei anlegen, danach kannst Du auf das Verzeichnis mit dem Benutzernamen BlackHawk und dem passenden Passwort auf das Verzeichnis zugreifen. Sollen weitere Benutzer hinzugefügt oder bestehende Passwörter geändert werden, rufst Du htpasswd ohne den Parameter -c (wie create) auf:
Code:
htpasswd /pfad/zur/passwort/datei Keita
Wichtig ist noch, daß für das Verzeichnis die Option AuthConfig gesetzt ist, d.h. Du mußt ggf. in der httpd.conf für das Verzeichnis diese Option setzen:
Code:
<Directory /der/pfad/zum/tresor>
Options AuthConfig
</Directory>
greetings, Keita
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
also erstmal digges danke für die schnelle hilfe!
ich hab jetz nur das prob das ich die .htaccess datei nich erstellen kann...
ich kann die auch übers command net umbenennen....
oder kann ich die auch datei.htaccess nennen?
 

Keita

Lt. Commander
Dabei seit
Dez. 2006
Beiträge
1.282
Windows ist da etwas eigen, viele Programme können in der Tat keine Dateien mit solchen Namen anlegen, die vermeintlich nur aus dem Suffix bestehen... Interessanterweise funktioniert das aber mit WordPad, Du mußt lediglich beim Speichern darauf achten, daß die Datei als "text-Datei" gespeichert wird.

greetings, Keita
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
naja so hab ichs halt gemacht... wordpad->speichern als .txt ->dann im cmd versucht zu renamen aber kommt nur syntaxfehler...
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
jetz muss ich mal ganz dumm nachfragen:
ich nenn die doch so um:
in den ordner rein wo die txt datei drin is-> ren C:\pfad\pfad\pfad\datei.txt .htaccess
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
ah! es hat funktioniert! :D
das prob is nur das es trotzdem noch nicht funzt...wenn ich auf die Seite geh, muss ich kein pw eingeben...
 
E

ExtiQ

Gast
Das kann an den Einstellungen deines Webservers liegen.
Such ma (falls du Zugriff hast und das ganze nicht beim ServerProvider liegt :D) im Apache Ordner\Conf\ die httpd.conf Datei und öffne diese mit Notepad o.ä.
und such mal nach
Code:
#
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All
Wenn dort "AllowOverride None steht, einfach auf All stellen, dann sollte es gehen :D
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
ok habs jetz auf All...ich dachte ich hätt das scho vorher eingestellt ....:-[
naja aber es geht trotzdem noch net...ich hab das gefühl das der diesen password container ned findet....
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
muss ich hier noch was amchen:
#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all
</Directory>
 

Black.--.Hawk

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
313
ok, ich weiss nich warum, aber es geht auf einmal!
thx an alle die mir geholfen ham!!!
Greetz
Black-Hawk
 
Top