EXCEL Wenn...dann...Formel

AvenDexx

Vice Admiral
Dabei seit
Juni 2005
Beiträge
7.151
Hallo zusammen, ich bräuchte mal euer Schwarmwissen. Generell ist die "Wenn...dann"-Formel ja kein Problem, mich beschäftigt gerade aber eine Frage, auf die ich keine Antwort habe, bzw. bei der ich gar nicht weiß, ob ich mit dieser Formel überhaupt arbeiten kann.

Folgendes Problem:

Ich habe eine Excel-Tabelle mit ca. 500 Einträgen. Dort sind Artikelnummern und Preise hinterlegt. Das sieht ungefähr wie folgt aus:

2110100 35,00
2110101 35,00
2110102 35,00
2110110 25,00
2110101 25,00
2110102 25,00

Ich möchte nun Zuschläge zu den Preis addieren lassen und das anhand der letzten Ziffer in der ersten Spalte. Ist dort eine 0 sollen 1,50 addiert werden, ansonsten (bei 1 oder 2) eben 2,10 Euro. Das sollte am Ende dann so aussehen:

2110100 35,00 36,50
2110101 35,00 37,10
2110102 35,00 37,10
2110110 25,00 26,50
2110101 25,00 27,10
2110102 25,00 27,10

Wie gesagt, es sind ca. 500 Artikel und es gibt nicht bei allen die Endung 0, 1 oder 2. Ich kann also nicht so vorgehen, dass ich einfach eine 0, 1 oder 2 in eine weitere Spalte eintrage und die "Wenn...dann"-Formel darauf anwende.

Ich hoffe ihr habt so ungefähr verstanden, wo das Problem ist.

Kann ich das mit einer Wenn-Funktion lösen und wenn ja wie? Falls nicht, gibt es eine andere Funktion, mit der ich das lösen kann?

Danke und Gruß
Aven
 

max40

Ensign
Dabei seit
Nov. 2010
Beiträge
236
das letzte Zeichen aus dem Feld bekommt du mit
Code:
=RECHTS(A1;1)
Damit solltest du zu deiner Lösung kommen.
 

vll

Lt. Junior Grade
Dabei seit
Nov. 2016
Beiträge
305
Hallo,

Du kannst ganz einfach zwei Wenn Funktionen verschachteln:
Dazu noch ein ODER() und gut ist:

=B1+WENN(RECHTS(A1)="1";1,5;WENN(ODER(RECHTS(A1)="2";RECHTS(A1)="0");2,1;0))
 

Mustang1978

Lt. Commander
Dabei seit
Apr. 2010
Beiträge
1.973
Damit es übersichtlicher bleibt, würde ich eine Hilfsspalte anlegen in der ich mit
=Rechts(A1;1)
die letzte Ziffer auslese, diese wird dann abgefragt (hier Spalte G)
=WENN(G1="1";B1+2,1;WENN(G1="2";A2+2,1;WENN(G1="0";B1+1,5;B8)))


so oder so ähnlich
 

spcqike

Lieutenant
Dabei seit
Dez. 2008
Beiträge
965
Wenn gilt, dass nur bei "0" 1,5 draufaddiert werden sollen, und sonst immer 2,1, dann tut es folgende Formel:
"=WENN(RECHTS(A1;1)="0";B1+1,5;B1+2,1)" in C1
 

AvenDexx

Vice Admiral
Ersteller dieses Themas
Dabei seit
Juni 2005
Beiträge
7.151
Oh man, darauf hätte ich auch alleine kommen könne. Super, ihr seit die Besten! Vielen Dank für eure Hilfe! :)
 
Top