Festplatte wird in BIOS boot Einstellungen nicht angezeigt, im boot Menü aber schon

Artanis

Cadet 3rd Year
Dabei seit
Aug. 2007
Beiträge
53
Hallo zusammen,

ich hab letztens Linux neben Win 10 installiert und mir damit fast den gesamten PC zerschossen. Lag vermutlich an meiner eigenen Inkompetenz. Nun ja, ich habe mittlerweile fast alles wiederherstellen können, allerdings gibt es noch ein kleines boot Problem.

Ich habe zwei Festplatten, eine "SSD Toshiba Q-Serie 2,5" 128GB" auf der Windows 10 installiert ist und eine "Seagate ST2000DM001 2000GB" wo hauptsächlich Programme und Dateien abgespeichert sind.

yjbr2af.jpg

Wie man hier sehen kann, ist die Seagate Platte die erste Festplatte in der boot Reihenfolge. Das wollte ich ändern, da das Ergebnis wenn ich von dieser Platte boote dieses hier ist. (Wurde den Ubuntu Mist nicht vollständig los)

syVqDgV.png

Das Problem ist, die Toshiba Festplatte steht gar nicht zur Auswahl

SNG01Ua.jpg

Und das obwohl sie von BIOS eindeutig erkannt wird.

gWpOycL.jpg

Dazu kommt noch, dass wenn ich nicht ins BIOS setup gehe sondern NUR das boot menu beim start aufrufe, dann ist die Festplatte auf ein mal wieder da.

dcZbJPS.jpg

Ich muss also jedes mal beim Systemstart F11 drücken und im Bootmenü meine Windows 10 Festplatte auswählen, ansonsten kommt dieser Linux grub Fehler Mist (Ich würde mich übrigens auch darüber freuen falls mir jemand nebenbei erzählen kann wie ich das komplett wegbekomme). Kann mir vielleicht jemand helfen und mir sagen wie ich mein kleines boot Problem wieder in den Griff bekommen kann? Würde mich sehr freuen. Das Mainboard ist übrigens ein MSI Z87-G45 Gaming.

Vielen Dank an alle im Vorraus!
 

leipziger1979

Commander
Dabei seit
Dez. 2014
Beiträge
3.063
Was passiert wenn nur die Toshiba dran ist ?

Was ist auf der 2TB Platte denn jetzt drauf ? Welche Partitionen/Dateisystem ?
 

Artanis

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Aug. 2007
Beiträge
53
Was passiert wenn nur die Toshiba dran ist ?

Was ist auf der 2TB Platte denn jetzt drauf ? Welche Partitionen/Dateisystem ?
Hardware technisch was am PC zu verändern wäre momentan sehr aufwendig, außerdem habe ich da Angst was kaputt zu machen. Die 2TB Platte ist in 3 Partitionen aufgeteilt, ca. 700GB, 900GB und 300GB, alles NTFS. 7,87 MB sind nicht belegt. Bis vor kurzem war die 300GB Partition noch der Platz wo ich Linux installiert hatte.
 

leipziger1979

Commander
Dabei seit
Dez. 2014
Beiträge
3.063
Vermutlich hast die Platte nur neu partitioniert und formatiert, jedoch der Bootloader ist noch drauf.
Das erklärt die Grub Meldung wenn die Platte als Bootlaufwerk angesprochen wird.
Würde nicht auffallen wenn die SSD im Bootmenü direkt vorhanden sein würde.

Hardware technisch was am PC zu verändern wäre momentan sehr aufwendig
Das ist natürlich schade.

Hast auch das aktuellste BIOS drauf ?
 

PsychoX7

Lieutenant
Dabei seit
Aug. 2008
Beiträge
528
Hast du Windows 10 nicht im UEFI-Modus installiert?
Die Frage nur so am Rande.

In vielen Fällen ist die andere Festplatte einfach nur an die erste Position in der Hard-Disk-Priority gerutscht.
Den Menüpunkt (Screenshot1) "Hard Disk Drive BBS Priorities" mal öffnen und dort schauen, dass die SSD, von der du booten möchtest, an der ersten Position steht.
Wenn nicht: SSD an die erste Position; Einstellungen speichern und neu starten.
Testen.
 

leipziger1979

Commander
Dabei seit
Dez. 2014
Beiträge
3.063
@PsychoX7

Die SSD taucht in der Auswahlliste im BIOS nicht auf, siehe Bild 3. ;)
Nur im Bootmenü wenn er beim booten F11 drückt.
 

PsychoX7

Lieutenant
Dabei seit
Aug. 2008
Beiträge
528
Bild 3 ist lediglich die Liste der Boot-Devices, welche ausgewählt werden können. Es ist nach wie vor gut möglich, dass die SSD in der HDD-Priority weiter hinten steht und deswegen nicht direkt als Boot-Device hinterlegt werden kann. ;)

Das würde eben auch genau das beschriebene Verhalten erklären, weshalb er es nicht fest hinterlegen, beim Boot-Menü allerdings trotzdem auswählen kann..

Edit: Lass' uns doch einfach warten bis der TE sich zurückmeldet.

Wie eine Prioritätenliste aussieht ist mir durchaus klar. Die unterscheiden sich von Hersteller zu Hersteller nicht großartig. Jedoch scheinst du den Punkt mit der HDD-BBS nicht ganz zu berücksichtigen.

Die Bootreihenfolge und die HDD-BBS-Priority sind immer noch zwei unterschiedliche Punkte.

Beispielhaft:
1. Bootreihenfolge
#1 DVD-LW
#2 HDD
#3 USB-HDD

2. HDD-BBS-Reihenfolge
#1 HDD Seagate 2TB
#2 HDD Toshiba SSD 128GB

Somit wird oft in der Bootreihenfolge nur die erste Festplatte, welche in der HDD-BBS-Reihenfolge steht sichtbar.
Möchte man von einer anderen Festplatte booten, muss die HDD-BBS-Reihenfolge geändert werden.
Ein Screenshot dieses Menü-Punktes, oder einfach das testen meiner Lösung würde uns die komplette Diskussion und das "Raten" ins Blaue ersparen
 
Zuletzt bearbeitet: (Ergänzungen nach Beitrag #8)

Artanis

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Aug. 2007
Beiträge
53
Ja, Version 1.9. Scheint die neuste Version zu sein. Außerdem hat das ganze vorher ja auch funktioniert.

Hast du Windows 10 nicht im UEFI-Modus installiert?
Die Frage nur so am Rande.
Da bin ich überfragt.

In vielen Fällen ist die andere Festplatte einfach nur an die erste Position in der Hard-Disk-Priority gerutscht.
Den Menüpunkt (Screenshot1) "Hard Disk Drive BBS Priorities" mal öffnen und dort schauen, dass die SSD, von der du booten möchtest, an der ersten Position steht.
Wenn nicht: SSD an die erste Position; Einstellungen speichern und neu starten.
Testen.
Kein Screenshot diesmal, das Menu sah folgendermaßen aus. Es gab zwei Menüpunkte und das ganze sah etwa so aus:

Boot Option #1 - [disabled]
Boot Option #1 - [Toshiba 128GB]

Ja, zwei mal #1. Bei der ersten ließ sich nichts anderes auswählen als "disabled" und bei der zweiten nichts anderes als die Toshiba Festplatte.
 
Top