M.2 ssd wird im Bootmenu erkannt, aber nicht in der Datenträgerverwaltung

Hpuser037

Newbie
Dabei seit
Dez. 2018
Beiträge
5
Hallo,
nachdem ich gefühlt das gesamte Internet durchforstet habe versuche ich es mal hier mit meinem Problem.
Ich habe einen HP Pavilion bc006ng. Dieser hat einen freien M.2 (m key) slot.
Gekauft habe ich nun eine WD green Sata ssd 128 gb (b+m key)
Erkannt wird diese allerdings nur im Bios.

Im WD ssd dashboard wird die SSD ebenfalls nicht erkannt.
Auch per Diskpart ist die SSD nicht sichtbar.
 

Anhänge

  • Datenträgerverwaltung.PNG
    Datenträgerverwaltung.PNG
    145 KB · Aufrufe: 276
Zuletzt bearbeitet:

En3rg1eR1egel

Banned
Dabei seit
Feb. 2014
Beiträge
7.343

Tzunamik

Lt. Commander
Dabei seit
Okt. 2008
Beiträge
1.097
Was erzählt dir den der Gerätemanager unter Windows?
Er sollte die SSD erkennen oder zumindest ein Device das er nicht erkennen kann.
Du solltest aber definitiv eine nVME PCIE SSD nehmen, sind um Faktor 10 schneller je nach Situation.
 

Hpuser037

Newbie
Ersteller dieses Themas
Dabei seit
Dez. 2018
Beiträge
5
Was erzählt dir den der Gerätemanager unter Windows?
Er sollte die SSD erkennen oder zumindest ein Device das er nicht erkennen kann.
Du solltest aber definitiv eine nVME PCIE SSD nehmen, sind um Faktor 10 schneller je nach Situation.
Auch der Gerätemanager erkennt nichts.

Bisher konnte ich sie nur im Bootmenu aufspüren. Da wird mit eingebauter SSD eine Option mehr angezeigt.

Ich überlege tatsächlich es einfach dabei zu belassen und direkt eine nVME zu kaufen. Ärgert mich halt trotzdem, dass ich den Fehler nicht aufspüren kann
 

Rokitt

Lt. Commander
Dabei seit
Dez. 2017
Beiträge
1.450
Der Fehler wurde doch schon genannt. Falsche Hardware..
Die Sata M.2 muss nicht kompatibel mit deinem M.2 Steckplatz sein, der ja auch eindeutig als PCIe/NVME ausgewiesen ist
 

Rokitt

Lt. Commander
Dabei seit
Dez. 2017
Beiträge
1.450
Der Name der Platte ist doch nur ein Teil des ganzen Datenpakets. Durchaus denkbar, dass der halt korrekt übermittelt wird, aber sonst einfach nichts funktioniert.
Immerhin passt die Karte ja rein mechanisch
 

Holt

Banned
Dabei seit
Mai 2010
Beiträge
59.532
Wenn sie im BIOS erkannt wird, dann unterstützt der Slot ja auch M.2 SATA SSDs. Wenn das BIOS und auch CrystalDiskInfo sie anzeigt, dann funktioniert sie. Schau mal ob die Storage Spaces sie nicht vereinnahmt haben, denn dann erscheint sie auch nicht in der Datenträgerverwaltung.
 

h00bi

Fleet Admiral
Dabei seit
Aug. 2006
Beiträge
14.929
Ich seh das auch so, wenn das Ding im BIOS auftaucht muss die grundlegende Ansteuerung schonmal stimmen. Check die Storage Spaces, ansonsten ggf. einfach mal die bisherige HDD/SSD raus und ne Testinstallation auf die M.2 SATA SSD starten.
 
T

TecFan

Gast
Also Leute! Hoffentlich lehne ich mich jetzt nicht zu weit aus dem Fenster... ;)

Ich denke mal, das Bios unterhält sich nur mit dem Controller. Das OS muss aber über den Controller auf den DATENTRÄGER, den Speicher schauen. Dazu muss das Protokoll, das das Bios und der Controller beherrschen, NVMe ODER Sata, stimmen. Wenn das Bios NVMe quatscht und der Controller nur Sata versteht, dann wir das nichts.
 

Holt

Banned
Dabei seit
Mai 2010
Beiträge
59.532
Ich denke mal, das Bios unterhält sich nur mit dem Controller.
Richtig, es fragt dessen Device Ident Daten ab, nur kann es das bei einer SATA SSD nicht, wenn an dem M.2 Slot nicht auch ein SATA Port verfügbar ist.
Dazu muss das Protokoll, das das Bios und der Controller beherrschen, NVMe ODER Sata, stimmen
Da wirfst Du nun das elektronische (also Hardware) und das logische (Software) Protokoll durcheinander. NVMe ist ein reines Softwareprotokoll für SSDs die über PCIe angebunden sind. SSDs mit SATA als Anbindung verwenden (bei Hardware verwendet man besser das Anbindung statt Protokoll um genau diese Verwechselung zu vermeiden), nutzt AHCI als Softwareprotokoll und AHCI unterstützt jeder BIOS und jedes normale Betriebssystem, weil es eben seit vielen Jahren auch für Kommunikation mit HDDs der Standard ist.

Wenn die SSD also im BIOS erscheint, dann hat der M.2 Slot in dem die steckt neben PCIe Lanes auch einen SATA Ports, sonst würde die SSD gar nicht, auch nicht vom BIOS, angesprochen werden können und das BIOS wüsste dann auch nichts von ihr.

Wenn eine Platte im BIOS erscheint aber nicht in der Datenträgerverwaltung, dann sind es eigentlich immer die Storage Spaces die sie vereinnahmt haben und da muss man sie entfernen um sie normal in der Datenträgerverwaltung verwenden zu können.
 

h00bi

Fleet Admiral
Dabei seit
Aug. 2006
Beiträge
14.929

Rokitt

Lt. Commander
Dabei seit
Dez. 2017
Beiträge
1.450
Wenn ich das richtig versteh, dann ist dieses "Storage Spaces" doch eine Art Softwareraid?
Dann müsste man das doch von Hand anlegen?

Das würde mich dann auch mal interessieren, wie das von ganz allein, auf einem nagelneuen Drive eingerichtet wird
 

Holt

Banned
Dabei seit
Mai 2010
Beiträge
59.532
hast du einen Ansatz WARUM das manchmal passiert?
Nein, leider kenne ich den Grund dafür auch nicht.
dann ist dieses "Storage Spaces" doch eine Art Softwareraid?
Sowas in der Art, ich würde es eher als LVM bezeichnen, denn man kann im Gegensatz zu einem SW-RAID eben auch nur eine einzelne Platte dort haben.
Dann müsste man das doch von Hand anlegen?
So sollte man es erwarten, aber irgendwie passiert es eben bei einigen Leuten trotzdem das die Storages Spaces die neuen Platten sofort in Beschlag nehmen.
 

Holt

Banned
Dabei seit
Mai 2010
Beiträge
59.532
Einfach mal googlen, dann erfährt man wie man in die Verwaltung der Storage Spaces kommt und wie man die Platte dort wieder entfernt.
 
Top