Windows Defender 100% CPU Auslastung beim scannen

1lluminate23

Lieutenant
Registriert
Aug. 2018
Beiträge
1.012
Guten Morgen lieber CB'ler,

ich scanne selten meine komplette Festplatte in diesem Falle mein Laufwerk C: (SSD). mit dem Windows Defender ( Windows 10 Pro ).
Auffallend dabei ist, dass der Windows Defender eine 100% Auslastung der CPU vornimmt ( INTEL i7 4790k) siehe angefügtes Bild. Die Auslastung führt dazu, dass man nichts mehr machen kann am PC, Firefox ruckelt beim Abspielen von YouTube Videos etc. pp. Auch treibt er die Temperatur der CPU ordentlich in die Höhe, trotz 5 Lüfter im Fractal Design R5.

Defender.JPG


Jetzt wollte ich fragen, ist das bei euch auch so, eine volle CPU Auslastung bis alles ruckelt?

An einer Drittsoftware habe ich kein Interesse, der Windows Defender erledigt seine Arbeit gewissenhaft. Es geht mir eher um Erfahrungsberichte, wie es bei euch aussieht und ob sich noch etwas "tweaken" lässt. Vielen Dank für eure Bemühungen, wünsche einen guten Start in den Tag.
 
Gerade getestet, CPU schießt auf 100% um danach wieder in den Idle zu fallen.. (also während er den Scan macht..)

Was hier auffällig ist, du nutzt eine benutzerdefinerte Suche, kann sein, dass er hier 100% Prio hat oder er Dateien scannt, wofür er maximale Power brauch.. who knows..
 
Guten Morgen @Toaster05 ,

bei mir bleibt die CPU Auslastung fast während des kompletten Scannvorganges auf 100%, manchmal fällt er auch auf ca 75%, aber der Defender lastet das System beim Scannen schon ordentlich bei mir aus, jedoch nicht bei der Schnellprüfung.
 
Ich versteh ehrlich gesagt das Problem nicht? Du gibst deinem PC ne Aufgabe die er schnellstmöglich abarbeiten will und wunderst dich dann über CPU Auslastung ... ?
 
  • Gefällt mir
Reaktionen: CMDCake, thunderclap, Amischos und 2 andere
Wie wäre es denn wenn du einen Screenshot schickst, welche Prozesse wieviel CPU Last erzeugen.
zusätzlich wäre die Transferrate der SSD bei dem Vorgang interessant.
 
1lluminate23 schrieb:
der Defender lastet das System beim Scannen schon ordentlich bei mir aus, jedoch nicht bei der Schnellprüfung.

Wie in Post #2 schon gesagt, lastet der Dienst auch bei der Schnellprüfung das System zu 100% aus.
Du merkst es nur nicht, da die Prüfung sehr schnell geht.
Wenn Du aber eine benutzerdefinierte Suche (gesamte Platte? - warum?) durchführst, dann dauert das eben.
 
Ich glaube, man kann irgendwo einstellen, wieviel CPU der Defender für sich beanspruchen darf, bin mir aber nicht ganz sicher und kann auch gerade nicht nachschauen, da auf Arbeit... :heilig:
 
@muesler
Eigentlich sollte der Defender bei Scans per Voreinstellung maximal 50% CPU Last erzeugen, tut er aber bei Vollscans derzeit nicht und ignoriert diese Voreinstellung.

Einsehbar ist diese Einstellung in der Powershell mit dem Befehl: Get-Mppreference, die Zeile "ScanAVGCpuLoadFactor" gibt an (in %) welche Cpulast der Defender maximal erzeugen darf. Mit dem Befehl: Set-Mppreference -ScanAVGCpuLoadFactor 50 (Angabe in % - in Fünferschritten) kann man diese Vorgabe anpassen. Dieser Wert ist per se auf 50% eingestellt.
 
  • Gefällt mir
Reaktionen: Mihawk90 und Kazuja
Wie ist es bei CPUs mit mehreren Kernen?
Der von Ihm hat 4 Kerne.
Werden 8 oder 12 Kerner auch so stark ausgelastet oder hat man dort eher „1 Kern frei“ zum weiterarbeiten.
 
Ich habe gerade festgestellt das es bei mir auch so ist. 100% -Aber nur wenn auf der System SSD (bei mir M.2 NVMe) gescannt wird. Vorher im RAM und danach auf den mech. HDDs geht die Auslastung herunter auf 20%~50% schwankend.

i7-6850K im X99M MB - Konnte in der 100% Phase (ca. 3min lang) normal Anderes tun ohne Hänger in der Bedienung.

Dabei habe ich gleich noch bemerkt das ich meine WaKü reinigen muss... Der Scanner hat in dem Zeitraum mit 100% die CPU Temp Warnmeldung kommen lassen. Die hab ich vor ca. 1Jahr programmiert in der Aquasuite und wusste das erst mal gar nicht zu deuten... Lollo...
 
Zuletzt bearbeitet:
Ist bei mir mit der jetztigen Windows 10 Version ebenfalls so, bin deswegen über die Suche auf den Thread hier gestoßen, ist wohl ein bug, Rückmeldung an MS dürfte das Problem schneller beseitigen wenn mehrere Leute das Problem melden.
 
Zuletzt bearbeitet:
Also bei mir war das auch so! 100% CPU Last und kein Weiterarbeiten!

Die Lösung ist unter den Energieoptionen, Prozessorenverwaltung, maximaler Leistungszustand des Prozessors auf 95% einzustellen!

dann funktioniert es wie sein soll!

MfG.
 
  • Gefällt mir
Reaktionen: Rotlicht
Zurück
Oben