ASRock J3455M mit RTL8111/8168/8411 WakeOnLan unter Ubuntu 18.04

pseudopseudonym

Admiral
Registriert
Mai 2017
Beiträge
8.895
Servus!

Ich versuche gerade verzweifelt mein ASRock J3455M, auf welchem Ubuntu Mate 18.04 (Linux 5.4.0-42-generic) läuft, zu WakeOnLAN nachm Standby zu überreden.

Der LAN-Controller ist dieser:
Code:
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
    Subsystem: ASRock Incorporation Motherboard (one of many) [1849:8168]
    Kernel driver in use: r8168
    Kernel modules: r8168

Im BIOS habe ich natürlich aktiviert, dass PCIe-Devices das Gerät wecken können.

Code:
$ sudo ethtool enp1s0
Settings for enp1s0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                         100baseT/Half 100baseT/Full
                                         1000baseT/Full
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

Aktiviert habe ich WOL unter Ubuntu so:
Code:
$ sudo ethtool -s enp1s0 wol g

Was zu der Ausgabe führt:
Code:
$ sudo ethtool enp1s0
Settings for enp1s0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                         100baseT/Half 100baseT/Full
                                         1000baseT/Full
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

Nach dem Standby sieht's wie vorher aus (Spoiler "WOL Ausgangslage").
Gut, wie das gelöst wird, ist hier beschrieben:
https://wiki.ubuntuusers.de/Wake_on_LAN/

Blöd nur, dass der Rechner per WOL gar nicht erst ausm Standby aufwacht. Was ich versucht habe, ist das r8169-Modul durch das r8168-Modul zu ersetzen (sieht man im Codespoiler oben). Gemacht habe ich es so:
https://askubuntu.com/questions/1052971/r8168-r8169-realtek-driver-module-troubles

Ändert aber nichts. Hat noch jemand Ideen? WOL wäre schon nett.
 
shinXdxd schrieb:
Funktioniert WoL wenn der PC ausgeschalten ist?
Nein.

shinXdxd schrieb:
Und hast du es auch im UEFI/Bios aktiviert?
Eine eigene Option gibt es dafür nicht, aber Wake by PCIe ist aktiviert.

"Lustigerweise" leuchten auch die LEDs am LAN-Port nicht, wenn der PC nicht voll da ist. Irgendwas stimmt da so gar nicht.
 
Das ist merkwürdig.
Die sollten normalerweise leuchten, bei mir war es ausreichend wol im Bios zu aktivieren, ich verwende es aber auch nur um einen PC einzuschalten. (Der PC hat aber auch ein älteres Asus Mainboard)

ACPI
im Bios auch an?
pseudopseudonym schrieb:
Eine eigene Option gibt es dafür nicht, aber Wake by PCIe ist aktiviert.
PCI Devices Power on wird wohl das gleiche sein wie Wake by PCIe vermute ich mal.

If the link light on the network switch is enabled when the computer is turned off but wake on LAN is still not working, booting the system using the r8168 kernel module at least once and then switching back to the r8169 kernel module included with the kernel seems to fix it at least in the following configurations:
Das ist eine mögliche Lösung vom Arch-Wiki. Kann mir aber weniger vorstellen, dass das funktioniert.
 
Der Fehler ist trivial und peinlich:
Hatte von einem anderen System noch
acpi_enforce_resources=lax
in den Bootoptionen stehen, geht jetzt.
Aber trotzdem Danke!
Ergänzung ()

Zu früh gefreut, da muss noch was anderes sein.
 
Zuletzt bearbeitet:
Zurück
Oben