linux Kernel panic

S

serge

Gast
hi , habe unter suse 8.2 den kernel 2.6.1 installiert.

beim booten kommt die fehlermeldung:

udf-fs: no partition found (1)
kernelpanic : vfs: unable to mount root fs on hdb2

und hängt sich auf.

hdb2 ist neine root partition

was für eine partion fehlt denn?

gruß serge
 

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
haste im Kernel die Chipsatz/IDE-Treiber für dein System drin ?
Treiber fürs Dateisystem mit reinkompiliert ?
evtl. Module in der initrd geladen.


btw: 2.6x suckt, hab jetzt schon 10 mal kompiliert und nix bootet bzw funzt richtig.
 

karuso

Captain
Dabei seit
Juni 2001
Beiträge
4.000
habt ihr auch immer die neuen init scripts drin?
bei mir lief der 2.6er einwandfrei...
 

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
Zitat von karuso:
habt ihr auch immer die neuen init scripts drin?
Keine Ahnung wovon du redest. Was muss man da machen ?

Unabhängig davon, auf dem System an dem ichs probiert habe, hat der den kernel geladen und 1 sec später das system resettet. Da dürfte noch keine Init dran beteiligt sein.

Bei 2.System hab der mir nach 2 sec. den ssh deamon beendet.

Beim 3. System hab ich den 2.6 test5 oder so per rpm von der suse 9 cd installiert: kernel geladen und sofort auch hier reset.

Außerdem ist 2.6 zu groß, selbst ohne Sound, USB und den ganzen Schmu mit minimalen treibern ist der für lilo zu groß, wenn man keine module benutzen will.
 

mahdi

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
116
Zitat von Blutschlumpf:
Keine Ahnung wovon du redest. Was muss man da machen ?

Unabhängig davon, auf dem System an dem ichs probiert habe, hat der den kernel geladen und 1 sec später das system resettet. Da dürfte noch keine Init dran beteiligt sein.

Bei 2.System hab der mir nach 2 sec. den ssh deamon beendet.

Beim 3. System hab ich den 2.6 test5 oder so per rpm von der suse 9 cd installiert: kernel geladen und sofort auch hier reset.

Außerdem ist 2.6 zu groß, selbst ohne Sound, USB und den ganzen Schmu mit minimalen treibern ist der für lilo zu groß, wenn man keine module benutzen will.
Dann hast du bei der Konfiguration was falsch gemacht, denn die minimale Codebasis ist kleiner als bei 2.4, warum eigentlich keine Module? Das verstehe ich echt nicht, sogar Dateisysteme bieten sich an, als Module zu benutzen. Ist ja schon monolithisch, man kann es aber auch uebertreiben :) => http://l4ka.org

fuer obiges: das hier, falls du es nicht kennst: http://kerneltrap.org/node/view/799
man muss ein wenig mehr machen, als nur den kern neu zu bauen

ssh daemon ist etwas, was mit dem kern nicht direkt was zu tun hat (natuerlich braucht ssh gewisse dienste), warum denn eigentlich den daemon? meinste nicht vielleicht eher den server?
 

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
Ganz einfach: ich installier mehrere Rechner pro Woche, da hab ich keine Zeit jedesmal den kernel zu kompilieren, da nehm ich den ohne Module kompilierten Kernel, den ich als Datei runterladen kann, in Lilo eingetragen und fertig.

Ist der ssh server bei dir kein daemon ?
 

mahdi

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
116
Zitat von Blutschlumpf:
Ganz einfach: ich installier mehrere Rechner pro Woche, da hab ich keine Zeit jedesmal den kernel zu kompilieren, da nehm ich den ohne Module kompilierten Kernel, den ich als Datei runterladen kann, in Lilo eingetragen und fertig.

Ist der ssh server bei dir kein daemon ?
oops, hab daemon und client irgendwie zusammen gebracht, weil ich noch was anderes geschrieben hatte. mea culpa.

ich seh ein, das diese art zu installieren schnell geht, aber kannst du nicht einfach noch das modules verzeichnis mit rein nehmen. Und sind die Rechner so heterogen, dass kein image der kompletten installation moeglich ist? Das geht doch auch bei nicht indentischen Rechnern?
 

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
Ich hab mich jetzt nochmal an nem 2.6er (2.6.5) probiert. Ich bekomms immer noch nicht hin.

Der Kernel bootet, lokal kann ich mich einloggen. Der Bootvorgang dauert fast 3 mal so lang wie bei 2.4.25 und schmeißt mit segmentation fault um sich. Und der SSH Deamon stirbt sobald ich mich einlogge.

System ist Debian 3r1, alle Packages aktuell.
"Hardware" ist ne VM Ware Workstation.
2.4.* läuft perfekt.
Der Kernel ist selbstgemacht, aber ich hab auch schon ne Config probiert, die bei nem bekannten auf knapp hundert Systemen läuft.

Ich hab mich mal durchgegoogelt, folgende Packete hab ich gefunden, was man evtl. benötigt:

initscripts
module-init-tools
binutils
bzip2
coreutils
fileutils
gcc
libc-dev
make
kernel-package

Ist alles drauf und aktuell.

Fehlt da noch irgendetwas, was ich vielleiht vergessen hab ?
Oder muss ich beim 2.6er irgendwas machen, was ich bei 2.4er nicht brauch oder anders machen muss ?

fyi: Ich mach das wie folgt:
Quellen runterladen (ftp.kernel.org)
entpacken
make menuconfig
make / make bzImage
Image nach /boot/ kopieren und in lilo.conf eintragen
lilo starten und rebooten
 

karuso

Captain
Dabei seit
Juni 2001
Beiträge
4.000
mach mal noch ein make install:
also:
make menuconfig
make
make install
lilo.conf editieren falls bei make install kein eintrag erstellt wurde
lilo ausführen


bei make install werden normalerweise alle dateien die man benötigen könnte ins /boot verzeichnis kopiert
 

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
nope, kein Unterschied.

btw: Hat den schon jemand auf ner VM zum laufen gebracht ?
Vielleicht such ich ja an der falschen Stelle.
 

karuso

Captain
Dabei seit
Juni 2001
Beiträge
4.000
also ich hab gestern gentoo aufgesetzt mit kernel 2.6.2 und der hat von anfang an wunderbar gefunzt - ich weiss also nicht was du da schaffst :p ;)
 
Top