NAS am Laptop mounten - bei Bedarf nachträglich (cifs, /etc/fstab)

pseudopseudonym

Admiral
Registriert
Mai 2017
Beiträge
8.890
Servus!

Ich möchte über die /etc/fstab Samba-Shares mounten (Ubuntu Mate). An sich alles kein Problem und auf die Netzwerkverbindung beim Booten zu warten, ist auch kein Problem.
Code:
x-systemd.automount,x-systemd.requires=network-online.target

Blöd wird die Geschichte nur, wenn man den Laptop außer Haus hochfährt und dann irgendwann nach Hause kommt. Klickt man dann den Share an, gibt's ne Fehlermeldung, dass nur Root den Share mounten kann.
Wie kann man das umgehen? Ich möchte mit dem hochgefahrenen Laptop nach Hause kommen können und dann auf die in der fstab eingehängten Mounts zugreifen, ohne "sudo mount -a" ausführen zu müssen.
 
@GaborDenes
Erstmal Danke.
Und Respekt an die Entwickler. Ich habe schon lange mit Linux zu tun, aber sowas kompliziertes ist mir noch nicht untergekommen. Bis das bei mir nach Wunsch läuft...
Ergänzung ()

Gibt's sonst was, das es normalen Nutzer erlaubt, das Mounten für die Samba-Shares durchzuführen?
 
Zuletzt bearbeitet:
Wenn ich "users" in den Optionen angebe, kann der Nutzer den Share später selbst einbinden.
Nur hängt sich alles auf, wenn dann auf den Share zugegriffen wird, dieser aber nicht mehr verfügbar ist.
Wie kann ich da ein Timeout einbinden?

Bodennebel schrieb:
Windows benutzen 😜
Da kannst du mir ja gleich zu Stift und Zettel raten.
 
Ich binde meine NFS-Shares auf dem Notebook mit diesen Optionen ein:
Code:
rw,suid,dev,exec,noauto,x-systemd.automount,user,async
Hab das damals mithilfe von Ubuntuusers zusammengestellt.
Trägt man in einem fstab-Eintrag die mount-Optionen noauto,x-systemd.automount ein, so wird die Partition bzw. Netzwerk-Freigabe nicht schon beim Systemstart, sondern erst bei einem Zugriffsversuch automatisch eingebunden. Fügt man noch zusätzlich die Option x-systemd.idle-timeout=60 ein, so wird die eingebundene Partition bzw. Freigabe nach einer Untätigkeit von 60 Sekunden wieder automatisch ausgehängt. Natürlich kann der Wert für das Timeout beliebig verändert werden.

Vielleicht hilft dir das weiter.
 
  • Gefällt mir
Reaktionen: Alexander2
pseudopseudonym schrieb:
, aber sowas kompliziertes ist mir noch nicht untergekommen.
Einrichten und benutzen, da ist nicht viel kompliziertes dran.
Ich nutze das täglich bei meinen Satreceivern (enigma2),die ich natürlich nicht ständig extern benutze...

da reicht ein einfacher Eintrag in /etc/auto.network,, um den CIFS/NFS-Share zu mounten.
Der Mount wird nur genutzt, wenn darauf zugegriffen werden soll, in deinem Falle also wenn du wieder Zuhause bist und auf den Mount zugreifst.
 
nachdem cifs in den letzten jahren bei jeder neuinstallation neue parameter brauchte habe ich nun statt in der fstab die Ordner mittels shell script mit SSHFS und per .desktop Datei im autostart eingerichtet:

Ersetze <user> mit deinem Benutzernamen
Ersetze <ssh_user> mit deinem SSH Benutzer für die NAS
Ersetze <IP> mit der IP Adresse deiner NAS

Ich habe auf meiner NAS den gleichen User wie am PC, daher ist im Mount 2x der gleiche Pfad angegeben.
Die SSH Verbindung wird mittels Identity File und Schlüssel authentifiziert.

mount-fuse-shares.desktop:
INI:
[Desktop Entry]
Name=mount fuse shares
Comment=mount fuse shares
Exec=/home/<user>/.mount-fuse-shares.sh
Icon=network
Terminal=false
Type=Application
DBusActivatable=true
StartupNotify=true

.mount-fuse-shares.sh
Bash:
#! /bin/bash

# OIDA bitte mounte einfach meine Ordner beim Starten ohne Fehlermeldungen.
# Früher ging das mit /etc/fstab
# Jetzt irgendwelche systemd fehler
# @see home/<user>/fstab.bak
#
# how to fuse
# https://www.maketecheasier.com/sshfs-mount-remote-filesystem-linux/
# https://wiki.archlinux.org/index.php/SSHFS
#
# Add user to group "fuse" (maybe old not neccessary)
# https://www.maketecheasier.com/sshfs-mount-remote-filesystem-linux/
# https://www.linuxquestions.org/questions/linux-software-2/fuse-works-but-fuse-group-does-not-exist-614992/
#
# fuse needs to have "allow_other" be activated in config file /etc/fuse.config if this option is used
# no link, derived from error message
#
# Run this script at startup
# https://stackoverflow.com/questions/12973777/how-to-run-a-shell-script-at-startup
#
# make this file executeable
# chmod +x /home/<user>/.mount-fuse-shares.sh
#
# Method a) Cron
#
# Autostart this file with cron
# sudo crontab -e
# @reboot sh /home/<user>/.mount-fuse-shares.sh
#
# Method b) desktop file autostart
#
# Create mount-fuse-shares.desktop
# [Desktop Entry]
# Name=mount fuse shares
# Comment=mount fuse shares
# Exec=/home/<user>/.mount-fuse-shares.sh
# Icon=network
# Terminal=false
# Type=Application
# StartupNotify=false
#
# Copy it to the autostart folder in /home/<user>/.config/autostart
# Copy it also into /home/<user>/.local/share/applications to add it to the overview search

sshfs <ssh_user>@<IP>:/home/<user>/Projekte  /home/<user>/Projekte -o rw,noauto,user,_netdev,reconnect,uid=1000,gid=1000,IdentityFile=/home/<user>/.ssh/id_rsa,idmap=user,allow_other
sshfs <ssh_user>@<IP>:/home/<user>/Videos  /home/<user>/Videos -o rw,noauto,user,_netdev,reconnect,uid=1000,gid=1000,IdentityFile=/home/<user>/.ssh/id_rsa,idmap=user,allow_other
## weitere Ordner der einfachheit halber entfernt
 
Zuletzt bearbeitet:
Ich bin jetzt bei @Natriumchlorid s Lösung mit
Code:
x-systemd.idle-timeout=60
gelandet. Das hatte ich zwar schon mal getestet, aber irgendwie ging's nicht. Jetzt schon, passt also.

Doof ist nur, dass die Ordner doppelt angezeigt werden, wenn sie aktiv sind:
Bildschirmfoto.png


Aber ein Anfang ist es.

@GaborDenes Ich muss mir Automount definitiv nochmal angucken, von der Idee her scheint es das bessere zu sein. Da fuchse ich mich allerdings doch lieber irgendwann anders mal ein.

@netzgestaltung SFTP ist in dem Fall leider nicht das, was ich haben will. Dennoch Danke für das Script.
 

Ähnliche Themen

Zurück
Oben