USB-WLAN weigert sich hartnäckig

Sugar39

Cadet 4th Year
Dabei seit
Feb. 2005
Beiträge
86
So, hier mal eine Knobelei für echte Experten:

Mein etwas älterer Dritt-PC (Athlon 3500, 2GB, Win XP) weigert sich hartnäckig, per USB-WLAN stabil und dauerhaft ins Internet zu kommen, obwohl zwei andere PCs (WLAN + Kabel), ein Notebook (mit Intel-pro-WLAN), ein Smartphone und auch eine PS3 in unserem Haus problemlos am selben Router (Speedtouch 585i v6) funktionieren.

Das Merkwürdige: Per LAN-Kabel funktioniert der besagte PC einwandfrei! Schnelles und stabiles Internet. Aber nicht per USB-WLAN. An der Kiste wurden inzwischen drei verschiedene USB-WLAN-Sticks getestet (Netgear, Belkin, AVM), alle mit demselben Phänomen: Der WLAN-Stick findet den Router, verbindet sich, gute bis sehr gute Verbindung. Manchmal kann man für kurze Zeit normal aufs Internet zugreifen, dann ist irgendwann Feierabend. Trotz bestehender Verbindung zum Router: Null Internet.

Manchmal hilft es, den USB-Stick in eine andere USB-Buchse zu setzen. Meist schmiert jedoch nach kurzer Zeit wieder die Verbindung ab (obwohl sie laut Info-Tool der jeweiligen Software nach wie vor besteht!). Und wenn Internet mal funktioniert, dann sehr zähflüssig - auch wenn der Router nur einen Meter entfernt ist.

Was ich alles schon probiert habe:
Auch der Austausch des Routers brachte nichts: Exakt dasselbe Problem.

Viren sind definitiv nicht drauf.

Eine Firewall ist auf dem Rechner nicht aktiv (ich nutze die Router-interne).

Energiesparfunktionen der Sticks sind ausgeschaltet.

Andere USB-Geräte funktionieren an besagtem PC problemlos (externe Festplatte, DVBT-Stick).

Verschlüsselung ist nicht das Problem: Selbst ohne Verschlüsselung dasselbe Phänomen.

Andere WLAN-Netze, die irgendwie stören könnten gibt es in der Umgebung nicht.

Tools zum Optimieren der Internetverbindung (TCP-Optimizer) halfen ebenfalls nicht

Auch ein frisch aufgesetztes System hilft nicht weiter: USB-WLAN hakt (egal welcher der drei Sticks), Internet per LAN-Kabel problemlos.

Genutzt wird XP SP3 (mit SP2 dasselbe Problem).

Warum will der Rechner nicht mit WLAN-Sticks funktionieren???
 

Complication

Banned
Dabei seit
Okt. 2009
Beiträge
4.277
Oft ist an solchen Problemen mit WLAN unter XP die Wireless Zero Konfiguration schuld:
Deaktivieren und Hersteller Tool verwenden zum konfigurieren: http://tech.ifelix.net/2000.html
 

Sugar39

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Feb. 2005
Beiträge
86
Danke für die Tips.

Ich werde mir nachher mal eine PCI-WLAN-Karte im örtlichen Media-markt holen (und zurück bringen, wenn es NICHT funktioniert).

Und das mit der Wireless Zero Konfiguration ist auch eine gute Idee.

Ich werde morgen mal berichten :-)
Ergänzung ()

An der Sache mit der Wireless Zero Konfiguration hat es leider nicht gelegen (stand auf automatisch, hab sie deaktiviert). Immer noch dasselbe Problem.

Die PCI-Karte kann ich erst morgen testen.

Was mir aufgefallen ist: Schließe ich den USB-WLAN Stick an und geh per task-manager auf "Prozesse", sehe ich, dass ständig die Datei ipconfig.exe als Prozess geladen wird...alle 2-3 Sekunden wieder neu ... manchmal steht sie sogar mehrfach in "Prozesse". Entsprechend hoch ist auch die CPU-Auslastung, selbst wenn der Rechner eigentlich gar nichts macht.

... und die Kiste rötert und rötert und rötert ... vorhin hatte ich beim Blick in die Prozesse mindestens zwanzigmal "ipconfig.exe" drin stehen. Nichts ging mehr, musste den Rechner per Kaltstart neu hochfahren.

Ziehe ich den USB-WLAN STick raus, ist (natürlich) Schluss mit dem Prozess.

Was verursacht diesen sändigen Aufruf des Prozesses ipconfig.exe?
 

Sugar39

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Feb. 2005
Beiträge
86
BINGO :)

Da hab ich endlose Stunden damit verbracht, den Rechner mit USB-WLAN ans Netz zu bekommen ... alles vergeblich. Heute hab ich dann mal die PCI-WLAN-Karte getestet (hama, 19 Euro) ... UND ES LÄUFT!

Sehr sehr genial! Vielen Dank für den Tip. Und wer auch immer Stress und Ärger mit USB-WLAN_Sticks hat, sollte das WLAN mal mit ner PCI-Karte testen. Der Tip war goldrichtig!

Danke !!!
 
Top