Virtualbox mit Win 7 unter OSX - kein Aero möglich

E

etheReal

Gast
Ich habe gerade mal testweise Win 7 Home Premium als Gastsystem in Virtualbox installiert (auf OSX Lion) und ich habe auch 3D und 2D Beschleunigung für die Grafik aktiviert, und der Grafikkarte 256MB RAM zugewiesen.
Allerdings kann ich in Windows jetzt kein Aero aktivieren, man kann in diesem Zustand nicht mal die Fensterfarbe ändern, ausser, man nimmt den alten Windows 2000 Look.

Ist das normal? Ich meine, es ist nicht schlimm, da ich die VM im Prinzip nur für Internet Explorer brauche (um die Weboberfläche von Lotus iNotes zu benutzen, die nicht richtig mit anderen Browsern läuft).
Aber trotzdem, das komische hellblau der Fenster geht mir schon jetzt aufn Keks... ich würde wirklich gerne irgendwie die 3D Beschleunigung aktivieren.
 

Ed40

Commander
Dabei seit
Apr. 2010
Beiträge
2.918
Hast du denn Extension-Pack und Gasterweiterung installiert?
 

Ed40

Commander
Dabei seit
Apr. 2010
Beiträge
2.918
Jau..dat wär was. Ohne Gasterweiterung keine 3d-Beschleunigung. Die ist, soweit ich weiß, Vorraussetzung für Aero

Ich geh mal davon aus, du weisst, das die Gasterweiterung im abgesicherten Modus von Windows installeirt werden sollte...
 
Zuletzt bearbeitet:

easy.2ci

Commodore
Dabei seit
Mai 2006
Beiträge
4.167
Aero läuft doch erst ab Direct X 9 fähiger Grafikkarte.

Ist denn der virtuelle Grafikadapter den VirtualBox bereitstellt Direct X9 fähig?
 

Ed40

Commander
Dabei seit
Apr. 2010
Beiträge
2.918
Also ich lass XP mit DirectX9 im W7-Host laufen .

Laut SIW funktioniert die im Gast wohl auch :siehe Bild
 

Anhänge

Zuletzt bearbeitet:

Rossie

Captain
Dabei seit
Dez. 2010
Beiträge
3.853
Unter Mac OS X habe ich es nicht ausprobiert (das MacBook ist zu schwachbrüstig), aber auf meinem Linux-Rechner läuft Win 7 unter VirtualBox mit Aero. Von daher würde ich davon ausgehen, dass es auch unter Mac OS X funktioniert. Die Gasterweiterungen müssen natürlich installiert sein.
 
E

etheReal

Gast
Es funktioniert! Man muss den "experimentellen" 3D Treiber der Gasterweiterungen installieren, dann läuft es.
Die Grafik im Leistungsindex wird zwar weiterhin nur mit 1.9 bewertet, aber es geht, und das sogar recht flüssig.

Der Mac, auf dem ich es jetzt installiert habe, ist ein Mac Pro (2010) 8-Core mit einer Radeon HD 5770.
Jetzt bin ich mal gespannt, ob es auf einem 2008er MacPro und einem 2008er (?) iMac auch funktioniert - aber das probiere ich heute nicht mehr. Feierabend! :)
 
Top