DNS mit Raspberry Pi und NextCloud funktionietr nicht

Crazy Helper

Newbie
Dabei seit
Nov. 2019
Beiträge
4
Hallo zusammen,

ich probiere einen Nextcloud-Server auf meinem Raspberry pi einzurichten und beim letzten Schritt komme ich langsam zum verzweifeln. Ich hatte anfangs schon ein paar Probleme mit IPv6, aber die habe ich meines Erachtens mittlerweile in den Griff bekommen. Jetzt hängt es nur noch am DNS über einen Provider wie spdns oder No-IP. Also zusammengefasst sieht es so aus:

  • NextCloud bzw. OwnCloud ist auf dem Raspberry eingerichtet und betriebsbereit
  • Portweiterleitungen zum Raspberry (TCP/UDP 80, 8080, 443) sind eingerichtet
  • ich habe einen IPv6-Internetzugang mit DS-Lite, welches die Kompatibilität zu IPv4 sicherstellt
  • ich kann über das Netzwerk über die lokale IPv4-Adresse des Raspberry auf den Server zugreifen, https://192.168.xxx
  • ich kann über das Netzwerk über die lokale IPv6-Adresse des Raspberry auf den Server zugreifen, https://[xxxx::yyyy:xxxx...]
  • ich kann aus dem Internet über die globale IPv6-Adresse des Raspberry auf den Server zugreifen, https://[xxxx::yyyy:xxxx...] --> daraus schlussfolgere ich, dass die Portweiterleitung funktioniert
  • Konfigurationen für No-IP sind auf dem Raspberry und in NextCloud hinterlegt, auch wenn ich da zugegebenermaßen nicht viel Ahnung habe und das einfach nach Anleitung gemacht habe
  • die weiterleitung durch einen dns-server über no-ip.com oder spdns.de funktioniert leider nicht

Ich hatte schon relativ viel rumprobiert, bis ich herausgefunden hatte, dass die Portweiterleitung wie bei IPv4 nicht funktioniert und habe deshalb sowohl bei No-IP als auch spdns.de die IPv6-Adresse eingegeben. Erstmal ohne dynamisches Update durch meinen Router, weil ich es ja erstmal nur zu Testzwecken verwende. Dass die Port-Weiterleitung prinzipiell erstmal geht, sieht man ja daran, dass ich über das Internet über die globale IPv6 auf die Cloud zugreifen kann.

Wenn ich auch meine eingestellte URL, z.B. https://xxx.spdns.de/, gehe, dann steht einfach nur da:

--------------

Seite wurde nicht gefunden

Die Verbindung mit dem Server xxxx.spdns.de schlug fehl.

-------------

Dazu habe ich jetzt erstmal nichts weiter gefunden. Hat jemand eine Idee, wie ich von hier aus weiter analysieren kann, woran es liegt?

VG
Crazy
 

DeusoftheWired

Fleet Admiral
Dabei seit
Juni 2009
Beiträge
10.238
Ein Link zur Anleitung, nach der du vorgegangen bist, wäre ganz hilfreich.

ich habe einen IPv6-Internetzugang mit DS-Lite, welches die Kompatibilität zu IPv4 sicherstellt
Äh … nee. Oder zumindest nur von innen nach außen. Mit DS-Lite kommst du via IPv4 nicht aus dem WAN in dein LAN. Dafür brauchst du einen Portmapper. Hier ist ein Beispielthread von einem Leidensgenossen: https://www.computerbase.de/forum/t...ia-dslite-portfreigabe.1901658/#post-23279424

ich kann aus dem Internet über die globale IPv6-Adresse des Raspberry auf den Server zugreifen, https://[xxxx::yyyy:xxxx...] --> daraus schlussfolgere ich, dass die Portweiterleitung funktioniert
Mit IPv6 sind NAT und Portweiterleitungen passé. Man kann jedes Gerät über Routergrenzen hinweg direkt ansprechen. Es funktioniert nicht wegen, sondern ungeachtet der eingerichteten Portweiterleitungen.

[*]Konfigurationen für No-IP sind auf dem Raspberry und in NextCloud hinterlegt, auch wenn ich da zugegebenermaßen nicht viel Ahnung habe und das einfach nach Anleitung gemacht habe
Die Aktualisierung einer DynDNS-Domäne sollte am besten das Gerät übernehmen, das die Ein- und Auswahl auslöst, und zwar der Router. Das bekommt nämlich als erstes mit, wenn sich die IP ändert, und muß das nicht wie die Skripte auf dem Raspi erst durch ein Abfrageverfahren alle x Stunden in Erfahrung bringen.

Welches Modell von welchem Hersteller ist das bei dir?

Außerdem: Welcher Internettarif bei welchem Anbieter? DS-Lite riecht ja erst mal nach Unitymedia/Vodafone/Kabeldeutschland oder einem anderen DOCSIS-Anbieter.
 

Crazy Helper

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2019
Beiträge
4
Hallo Deus,

die Anleitungen sind folgende:
Nextcloud einrichten
DNS mit No-IP einrichten

Das mit den Portmappern habe ich schon gelesen, aber wie du auch schon sagst, ist das in meinem Fall bei IPv6 dann ja nicht mehr relevant.

Die Aktualisierung der DynDNS-Domäne über den Router habe ich eingerichtet, aber die funktioniert leider genauso wenig wie die Weiterleitung auf meine IPv6 über das DNS über die Internetadresse selber. Mein Router ist eine FritzBox 7583. Dort kann man bei DynDNS als Anbieter sogar direkt No-IP.com auswählen. Aber wie gesagt, trotz Neustart aktualisiert der die IP nicht.

Ungeachtet dessen sollte das ganze ja erstmal für die derzeit manuell konfigurierte IPv6 funktionieren, selbst wenn die Aktualisierung der IP durch die Fritzbox erstmal nicht klappt.

Internetanbieter ist 1&1.

VG
Crazy
 

Crazy Helper

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2019
Beiträge
4
Hallo zusammen,

keiner mehr eine Idee? :(
Bin auch über weiterführenden Lesestoff dankbar.

VG
Crazy
 

r34ln00b

Lt. Commander
Dabei seit
Feb. 2006
Beiträge
1.031
Du kannst auch den DNS-Service von AVM nutzen: Anleitung: MyFritz-Konto als DynDNS-Ersatz nutzen.
Wenn unter den Freigaben die richtige IPv4/IPv6 eingerichtet ist, kann ich den RaspberryPI auch über eine URL erreichen.
Aber: Problematisch ist aktuell, dass sich die IPv6-Adresse regelmäßig ändert und ich diese immer händisch in der Freigabe anpassen/aktualisieren muss. Kenne mich mit IPv6 nicht gut genug aus, vermute es sind die Pirvacy Extensions und ich schaffe es nicht, die Aktualisierung der temporären Adresse zu unterbinden.
So könntest du aber den RapsberryPi sowie die NextCloud darauf mittels URL zu einer IPv6-Adresse erreichen.
 

Crazy Helper

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2019
Beiträge
4
Hallo r34ln00b,

das hatte ich auch bereits probiert, aber leider hatte das ebenso nicht funktioniert. :(

Ich habe jetzt aber nochmal gegoogelt und eine super Anleitung gefunden, wo es speziell um den Raspberry, IPv6, DS-Lite und dynDNS ging. Knackpunkt war letztendlich die Konfiguration im Router:

https://steemit.com/deutsch/@gldhnc...-lite-aus-dem-internet-erreichbar-teil-1-ipv6

Worauf ich dadurch nochmal besonders wert gelegt habe:
  • Unter Netzwerk-->Netzwerkeinstellungen--> IPv6-Adressen die 3. Option, dass auch Netzwerkgeräte über DHCPv6 eine IPv6 bekommen
  • Die Kontrolle der IPv6-Interface-ID zwischen Router und Pi
  • Die Auswahl der weiteren IPv6-Optionen bei den Freigaben

Und siehe da, es funktioniert einwandfrei!
Trotzdem vielen Dank für die Hilfe und ich hoffe diese Hinweise helfen anderen, die ebenfalls mal so ein Problem haben.

VG
Crazy
 
Top