Excel - Datum im Zeitfeld?! AutoSum falsch

Andymiral

Lieutenant
Dabei seit
Apr. 2011
Beiträge
782
Hallo zusammen,

Gleich vorab, ich kenne mich mit Excel kaum aus und benötige Hilfe bevor ich durchdrehe :D

Bei meiner Firma in der ich Arbeite gibt es ein Zeiterfassungsystem. Die Zeiten kann ich mir in einer Excel-Tabelle aus dem System ziehen. Hat auch bis vor kurzem alles wunderbar funktioniert und wenn ich die Felder mit den Zeitangaben markiert habe wurde per AutoSum auch alles richtig zusammen gerechnet. Soweit so gut!

Da ich einen neuen PC gekauft habe musste ich Windows 10 und Office neu installieren. (Hab die gleiche office version wie davor installiert - Office 2013)

Wenn ich jetzt die gleiche Datei öffne wird bei AutoSum falsch gerechnet, den Grund habe ich offenbar entdeckt:

In dem Feld in dem nur die Zeitangabe steht erscheint aber auch ein Datum wenn man es markiert. Dieses Datum scheint Windows oder Excel irgendwie von selbst hinzuzufügen?!

Da müsste eigentlich stehen 0:30
Aber wenn man das Feld markiert sieht man in der Excel Kopfzeile 10.01.1900 08:30
Woher zum teufel kommt auf einmal 10.01.1900 ?

Wenn man dann natürlich AutoSum anwendet kann gescheites ergebniss rauskommen bei 10.01.1900 08:30

Kann mir jemand sagen wie ich das Datum entfernen kann?
 

Jedi3

Lt. Junior Grade
Dabei seit
Sep. 2005
Beiträge
336
Excel unterscheidet nicht zwischen Zeit und Datum, die Werte werden nur je nach Formatierung anders dargestellt.
In deinem Fall werden volle 24h in Tage umgerechnet und unglücklicherweise dazu als Datum dargestellt.
Der 0. Januar 1900 ist der Beginn der Zeitrechnung bei Excel mit dem Wert 0, deshalb liegen deine Werte in der Nähe.

Ändere bei Start -> Zahl die Formatierung deiner Zahlen in die benötigten Zeitformate.
(falls du dich da nicht zurechtfindest: Strg+1 drücken, Benutzerdefiniert, [h]:mm eingeben)
 
Zuletzt bearbeitet:

Cave Johnson

Commodore
Dabei seit
Dez. 2012
Beiträge
4.229
Das liegt nur an der Formatierung. Es steht "im Hintergrund" immer ein Datum dabei, weil Excel nunmal so mit Zeiten und Daten rechnet.

Wenn du die Zelle markierst und Strg + F1 drückst, kannst du die Formatierung einstellen.

Wie du bspw. hier im Bild siehst, steht in der Zelle nur 00:30, in der Eingabezeile siehst du aber auch die Sekunden 00:30:00 und würde ich ein Datumsformat wählen, stünde dort 00.01.1900, obwohl ich eine Uhrzeit eingetippt habe.

Bild 007.jpg

Du rechnest bei dir jetzt ggf. mit negativen Zeiten bzw. Zeiten vor dem Jahr 1900, was nicht klappt. Dazu musst du die 1904-Datumswerte in den Optionen aktivieren.

Bild 008.jpg
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Danke für die Infos

Die Formatierung hab ich auch schon vermutet und auch bereits auf TIME umgestellt.

wenn nun dran steht
0:30
1:00

und ich AutoSum ausführe kommt raus:
481:30:00

Was mache ich falsch? :(

Diese 1904-Datumswerte habe ich auch in den Optionen aktiviert.
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Ja bitte.

Es geht um die 2 Felder ganz weit rechts

hab auch einen Screenshot gemacht.
Bei den 2 markierten Zeilen müsste eigentlich 01:30 als Gesamtergebniss herauskommen. Ging früher ohne probleme. Seit der Windows 10 Neuinstallation nicht mehr...
 

Anhänge

Cave Johnson

Commodore
Dabei seit
Dez. 2012
Beiträge
4.229
Hm, so auf Anhieb fällt mir da nichts ein.

Aber das Format der Datumseingaben ist schon seltsam; auch weil zwischen Datum und Uhrzeit zwei Leerezeichen stehen. Kommt das direkt so aus dem System? Ist es möglich, dass zufällig auch dort etwas verändert wurde?

Standardmäßig steht ja als Datum 00.01.1900 in der Zelle - du hast jetzt jeweils 10 Tage, also 240 Stunden in jeder Zelle.
 

Ash1983

Lt. Junior Grade
Dabei seit
Apr. 2012
Beiträge
334
Lt. Libreoffice steht in der Zelle: "240:30:00". Wenn ich das Zellformat ändere, zieht er jedoch die Summe korrekt:
xls.png
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Scheint nicht am System zu liegen, das Problem besteht nämlich auch wenn ich mir alte Zeiterfassungen aufrufe die bereits früher ohne Probleme gelaufen sind.
Ergänzung ()

Lt. Libreoffice steht in der Zelle: "240:30:00". Wenn ich das Zellformat ändere, zieht er jedoch die Summe korrekt:Anhang 735299 betrachten
Wie hast du das hinbekommen das unten die korrekte Summe angezeigt wird?
Edit: achso benutzt ein anderes Programm namens Libreoffice? Kenne ich gar nicht
 

Ash1983

Lt. Junior Grade
Dabei seit
Apr. 2012
Beiträge
334
Doch, scheint exakt an deinem Excel zu liegen.

Ja, warst du denn längere Zeit weggesperrt? :)
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Normalerweise brauche ich Excel kaum und in der Firma nutzen sie Office 365.

Daheim habe ich noch Office 2013.

Mich wundert aber das es früher ohne Probleme ging. Ich musste keine Zellen formatieren oder ähnliches. AutoSum hat funktioniert.

Ich hab die gleiche office version installiert wie davor auch. Versteh ich nicht wieso das jetzt so rum spinnt...
 

Jedi3

Lt. Junior Grade
Dabei seit
Sep. 2005
Beiträge
336
Sehr seltsam, warum da der 10.1.1900 steht, kann ich auch nicht sagen. Excel rechnet jedoch richtigerweise 240h für die 10 Tage nach 0.1.1900 in die Summe.

Du könntest aber das Zeitformat der anderen Zahlen auf deine Summe übertragen.
Dann würden die falschen Zahlen zumindest nach deinen Wünschen angezeigt.
Clipboard02.jpg Clipboard01.jpg
 

Pyrukar

Lt. Commander
Dabei seit
Jan. 2013
Beiträge
1.944
irgendwie ist die Datumsformatierung immer etwas eigen in Excel ... ich habe eine Tabelle in der ich Uhrzeiten erfasse ... leider gehen die auch über den Tageswechsel weshalb ich dann auch schon mal 25:20 statt 01:20 angebe. Bis 24:59 aka 00:59 gibts auch keine Probleme aber wehe es geht über die 1 Uhr schwelle ... dann hab ich ähnliche Formatierungsschwierigkeiten wie hier besprochen wurden ... ich fände es irgendwie nachvollziehbar, wenn es ab 00:00 probleme gibt aber ab 01:00 ... ach ja ich nutze Excel 2010 und ja wenn man lang genug ihm sagt, wie die Formatierung sein soll dann nimmt er es irgendwann ... aber jedes mal aufs neue gibts stress :(
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Ich hab mal eben testweise ein Notebook von der Arbeit mit Office 365 gestartet und die Excel Datei mit Office 365 geöffnet.

Dort sind alle werte korrekt. In den Feldern wo die uhrzeit steht wird die Uhrzeit auch richtig dargestellt. AutoSum funktioniert korrekt.

Es wird aber auch in der Kopfzeile kein Datum angezeigt, sondern nur die Zeit.

Dann muss es ja eigentlich an meiner Office Version liegen...bzw. an den Einstellungen nach der Win10/Office2013 Neuinstallation.

Hab es eben noch in OpenOffice probiert, gleiches Problem.
 
Zuletzt bearbeitet:

Ash1983

Lt. Junior Grade
Dabei seit
Apr. 2012
Beiträge
334
Bringt die Änderung der Zellformatierung von hh:mm in [hh]:mm Besserung?
 

cumulonimbus8

Admiral
Dabei seit
Apr. 2012
Beiträge
9.888
Ist das eine neue Mappe auf Basis dieses W10? Ist es noch das selbe Office?

Jedenfalls bleibt es dabei wie es erklärt wurde:
(A) was du als datumbasierten Wert (und Zeit ist das) eintippst, oder mehr: was Excel dank seiner Intelligenz (?) als so was erkennt, das zählt ab 1.1.1900 (0der eben 1904). 36 Stunden ≡ Mittag am 2. Januar 1900. Unter der Motorhaube. Und effektiv ist das auch nur eine Zahl!
(B) Zellen haben Formate - ich kann jede Zahl auf mögliche und unmögliche Weise darstellen. 27,5 kann sein 3h:30min, als [hh]:mm sind es 27:30. als Tage ausgewiesen rund 1,15. Alles Optik, Camouflage, Fassade!

CN8
 

GunMum

Lt. Junior Grade
Dabei seit
Jan. 2009
Beiträge
258
Moin,
ich behaupte, dass das Zeiterfassungssystem Werte liefert, die Excel fehlerhaft interpretiert. Wie "holst" du dir denn die Werte? - In der Musterdatei steht ganz klar 10,0208333333333 in Q3 (Standard-Formatierung). Und wenn ich in die betroffenen Zellen eine Zeit von Hand eingebe, klappt auch alles wunderbar.

ABER: Ich werde das Gefühl nicht los, dass du uns hier nur ein WERT-Ergebnis präsentierst und vorher in irgendeiner Form Formeln mit im Spiel waren ... Und du kannst eine Korrektur vornehmen, indem du irgendwo diese Formel eingibst:
Code:
=Q3-GANZZAHL(Q3)
... die Formel entsprechend kopierst und dann ALS WERT in Q3 ff einfügst. Ich würde das übrigens ohne dieses Hilfs-Gedöns mit VBA erledigen, wenn Fehler im externen Programm und 80cm vor dem Bildschirm ausgeschlossen werden können ...
 

Andymiral

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
782
Leider kenne ich mich wie gesagt in Excel nicht wirklich aus. Ich kann nur sagen

Ich hatte auf meinem privaten PC Win10 und office 2013. Ich hab den Auszug aus dem Zeiterfassungsystem gemacht und man bekommt vom System eine Excel Datei. Diese habe ich bisher immer geöffnet und alle werte waren korrekt eingetragen. Ich musste keine Zellen formatieren oder ähnliches. AutoSum hat auch funktioniert.

Jetzt habe ich ein neues Sytem und auch wieder Win10 und office 2013 installiert. (Exakt die gleiche version, von CD)

Wenn ich jetzt eine Zeiterfassung öffne die schon monate alt ist (und die damals ohne probleme funktioniert hat) dann spinnen wie gesagt die Werte/zellen.

Dabei hab ich früher ja auch nichts verstellen müssen.

Wenn ich die gleiche Datei am Notebook von der Arbeit öffne mit o365 geht alles wunderbar. Also sind die Zellen und Formeln wohl richtig :/

EDIT: Hab es eben deinstalliert und neu installiert um zu sehen ob sich irgendwas ändert. Leider nicht
Hab übrigens Käse erzählt. Es ist nicht office 2013 sondern Office 2007 :D

EDIT2: Hab eben die gleiche Office 2007 Version auf einem anderen Notebook das ich hier noch habe installiert um rauszufinden ob der Fehler mitwandert: JA! TUT ER!

Also liegt es doch nicht an meinem PC...vermutlich eher an office 2007. Komisch nur das es früher ging...
 
Zuletzt bearbeitet:

cumulonimbus8

Admiral
Dabei seit
Apr. 2012
Beiträge
9.888
Dann hat sich der PC verändert :D

Mutmaßlich ist irgendwas im Betriebssystem anders eingestellt. Vielleicht sinngemäß vergleichbar mit meinem Fall - da ist es die Sprache. Vielleicht sind es bei dir Datumsformate oder Trennsymbole auf die 2007 mit Aufstoßen reagiert.

CN8
 
Top