PPPoE (WinXP) - welches NIC wird verwendet ?

kuehnch

Lt. Junior Grade
Dabei seit
Dez. 2004
Beiträge
269
Bisweilen habe ich zur Herstellung der Internetverbindung immer auf Drittherstellerprotokolle gesetzt, wo ich klar sagen konnte, über welchen (meiner beiden) Netzwerkadapter ich nun ins WAN gehe, denn hier musste ich dem jeweiligen Adapter immer das zuvor installierte PPPoE-Protokoll hinzufügen. Nun verwende ich aber seit einer Neuinstallation den WAN-Miniport für PPPoE, welchen WindowsXP mir mitliefert. Leider kann ich nicht erkennen, welchen Adapter der Treiber nun verwendet.
Es schaut bei mir so aus, dass ich eben an dem Adapter, mit dem ich ins Inet möchte, sämtliche Protokolle/Dienste.. deaktiviert habe. Der andere Adapter, welcher an einem LAN-Switch hängt (genauer ein Router, allerdings ist der Standardgateway nicht gesetzt, damit der Rechner nicht über den Router aufs WAN zugreift), ist mit einer festen IP konfiguriert und es klappt auch alles prächtig. Deaktiviere ich den "WAN-Adapter" so komme ich auch tatsächlich nicht ins Netz. Wo aber kann ich erkennen, welcher Adapter nun der dauerhafte Adapter fürs WAN ist (wird hier lediglich anhand des gesetzten Standard-Gateways entschieden oder wie läuft das) ?
Fragen und Anregungen sind willkommen :)
 

Der Turl

Lt. Commander
Dabei seit
Juli 2002
Beiträge
2.033
also so ganz hab ich den text jetzt nicht gecheckt...entweder is der tag schon so lange...oder es is a bissi undeutlich geschrieben :(

aber ich würd mal folgendes vorschlagen:
gehst mal in den DOS prompt ( eingabeaufforderung ) und gib: "route print" ein ( ohne anführungszeichen), dann siehst auf welcher nic / ip addy welche routen gesetzt sind und wohin diese gehen !
 

[Moepi]1

Lt. Commander
Dabei seit
Jan. 2002
Beiträge
1.233
Die NIC, die ne Verbindung zu nem DSL Modem via PPPoE bekommt, wird verwendet. Falls Du das Modem an ein Switch hängen würdest und beide Netzwerkarten an das Switch angeschlossen wären, so würde sich Windows eine Karte aussuchen. Das wird aber in den seltensten Fällen der Fall sein - außer bei mir :D
 

kuehnch

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Dez. 2004
Beiträge
269
Das ist ja doof. Also ich habe hier einen Mehrplatzzugang - ich kann mich bis zu zehn Mal parallel einwählen und erhalten auch bis zu zehn IP-Adressen. Nun hat mein Rechner halt zwei NICs onboard (Board ist ein Asus A8N-SLI Deluxe), wobei der nVidia-Controller ja eine Firewall umfasst, weshalb ich eben genau über dieses Interface direkt ans Internet möchte, während der andere Adapter (Marvell) an einem Switch im lokalen Netz hängt - wobei sich in diesem lokalen Netz eben auch noch ein Router befindet, welcher dann ebenfalls Internet-Zugriff gewährt.
Wenn ich aber weiter überlege, so scheint das Problem durch deine Aussage also geklärt zu sein. der nVidia-Controller hängt direkt am DSL-Modem, während der Marvell am (Router)-Switch hängt, wobei der Router mit seinem WAN-Port am DSL-Modem baumelt. Ich muss also lediglich aufpassen, dass ich beim Marvell den Standardgateway nicht eintrage (oder per DHCP durch den Router eintragen lasse), damit der nVidia-Controller als Standardgateway Verwendung findet.

Vielen Dank für die Hilfe!
 
Top