Problem mit Tastaturbelegung in DosBox

Benji

Lieutenant
Dabei seit
Jan. 2004
Beiträge
974
Hi!
Hab mir gerade DosBox installiert (auf nem Ubuntu Linux System) und hab sie gestartet aber es funktionieren nicht alle Tasten. Wenn ich die Umlaute drücke kommt gar nichts.
die normalen Buchstaben und Zahlen funktionieren.
Teilweise ist es auch das englische Tastaturlayout jedoch ist z und y normal.
Aber wie kann ich jetzt einen : oder / machen?
Wie kann ich die Tastenbelegung auf deutsches oder englischen Layout einstellen so das alle Tasten funktionieren?

MfG Benji
 

beten

Lt. Junior Grade
Dabei seit
Juni 2003
Beiträge
286
hi

ich hab zwar nur die Win-Version aber die Belegung wird wohl nich anders sein.

/ is auf - (neben Shift rechts)
: is auf Ö (Shift+ö)
\ is auf #

ob man das umstellen kann weiß ich aber auch nich

gruß beten
 

Benji

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2004
Beiträge
974
Ja nur wenn ich diese Tasten drücke kommt gar nichts!
 

beten

Lt. Junior Grade
Dabei seit
Juni 2003
Beiträge
286
Ich hab gerade auch gelesen, das man mit STRG+F1 einen Keymapper aufrufen kann.
Da müsste man eigentlich was einstellen können, ich hab nur im Moment keine Zeit um das auszuprobieren.

gruß beten
 

Lichterer

Commander
Dabei seit
Juni 2002
Beiträge
2.334
Also bei mir ist es das normale englische Tastaturlayout (unter Windows).

y und z vertauscht.
: bei Taste ö
\ bei Taste #

usw.

Ob das unter Linux anders ist, weis ich aber auch nicht.

Edit:

Jupp, in DosBox STRG-F1 gedrückt, kannst du die Tastenbelegung betrachten/ändern.

Die Buchstaben ä, ö, ü, bekommst du dadurch aber nicht. Du kannst nur die Tasten neu belegen.
 

Anhänge

Zuletzt bearbeitet:

Benji

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2004
Beiträge
974
Wenn ich STRG-F1 drücke passiert auch nichts.
 

Lichterer

Commander
Dabei seit
Juni 2002
Beiträge
2.334
Welche DB-Version hast du?
 

Benji

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2004
Beiträge
974
Ich hab DOSBox 0.63.
Kann es sein das ich vielleicht irgendwas in der ner Config-Datei oder so ändern muss?
Hab es nämlich nur installiert und sonst nix eingestellt?
 

Lichterer

Commander
Dabei seit
Juni 2002
Beiträge
2.334
Ich hab mir grade mal die German languagefile runtergeladen und ausprobiert,
woraufhin bei mir auch Eingabe-Probleme auftraten, z.B. die Taste ö hatte keine Funktion mehr, also auch im engl. Layout kein : mehr.

Seltsamerweise funktionierte es auch nicht mehr, nachdem ich wieder das Standardlayout benutzte.

Hab DosBox 0.63 dann gelöscht und neu aufgespielt, seitdem funktionierts wieder.

edit:
Hab das Language-File jetzt mal in die Config-Datei geschrieben, statt als angehängten Parameter zur Startdatei, da funktioniert jetzt das engl. Layout wieder.
 
Zuletzt bearbeitet:

Benji

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2004
Beiträge
974
Danke für die Hilfe!
Selber hab ich keines installiert aber kann sein das es schon so integriert war.
Werde es dann mal wieder löschen und ein anderes ohne das LanguageFile installieren
 

Lichterer

Commander
Dabei seit
Juni 2002
Beiträge
2.334
Das deutsche Layout funktioniert. (Ich sollte die beiliegende Readme-Datei halt richtig durchlesen) :D

Musst nur einen Tastaturtreiber laden, wie unter (normalem) DOS auch. :rolleyes:

Download: DOSBox-german-lang-063.zip

Hier noch beschrieben, wie ich es gemacht hab.

Das Zip-File in den DOSBox-Ordner entpacken und dort die Datei dosbox.conf editieren.
Unter [dosbox] hinter "language=" "deutsch.lng" eintippen. (also language=deutsch.lng )

Um noch automatisch das deutsche Tastatur-Layout beim Start vom DosBox zu laden,
die dem Language-File beiliegende KEYB_GR.zip entpacken
und folgende Zeilen in der dosbox.conf unter [autoexec] eingeben:

mount y "Pfad zu den entpackten Keyb-Dateien"
y:\keyb gr
mount -u y
 
Zuletzt bearbeitet:
Top