Ältere SSDs - Fragen dazu

EDV-Leiter

Lieutenant
Registriert
Juni 2014
Beiträge
662
Hallo,

Ich habe gerade 2 ältere SSDs vor mir liegen ,beide Samsung PM810 mit 256GB, beide mit etwa 3 Jahre alt.
Die eine hat laut Crystal Disk Info folgende Werte: ca. 1 TB gelesen, ca. 700 GB geschrieben, 380 Stunden Betrieb, Zustand 81%.
Die andere: 1,2 TB gelesen, 1,4 TB geschrieben, ca. 3500 Stunden Betrieb und 82%.
Wie kann es sein daß beide SSDs erheblich langsamer sind als im Neuzustand?
Gemessene Werte: Schreiben ca. 100 MB/s, neu waren es um die 180, Lesen um die 180 MB/s, neu waren es bis zu 280.
Eine Dritte baugleiche SSD, ähnlich alt, kommt auf nahezu die alten Werte.
Warum bricht die Leistung so stark ein? Genutzt wurden die Geräte mit AHCI unter Windows 7 x64, ein Secure Erase wurde auch schon erfolglos durchgeführt.
Weiterhin interessiert mich warum trotz der stark unterschiedlichen Nutzung nahezu der gleiche Verschleiß angegeben wird.
Ich jetzt bei den Laufwerken das Alter oder doch mehr die Nutzung entscheidend?

Vielen Dank
 
Zuletzt bearbeitet:
Das kommt auf den "Schätzungsalgorithmus" an welchen Samsung da implementiert. Crystal Disk fragt das nur an, die SSD selber antwortet. Und da wird die Nutzungsdauer von Samsung mittels typischer Szenarien recht stark miteinfliessen.

Was die Leistung anbelangt, klingt nach ner verkorksten garbage collection. Warum das ist, keine Ahnung. In der Regel sollte sich das wieder normalisieren wenn man eine SSD "in Betrieb" lässt aber sie eben nicht ständig wirklich arbeiten lässt, damit der controller Zeit für das wiederaufbereiten der Zellen hat.

Bei der Schreibleistung würd ich mir aber keine Gedanken machen. Selbst so alte SSDs sollten mal locker 10TB abkönnen, eher 50 oder mehr.
 
Gute Frage warum die langsamer geworden sind, evtl. stimmt das Partitionsoffset/Alignment nicht?
Mal den AS SSD Benchmark laufen lassen.
Der unterschiedliche Zustand könnte durch einen unterschiedlichen Füllstand begründet sein, also die SSD mit 1,4TB Schreibvolumen war dann leerer, somit hat sich die Schreiblast auf mehr freie Speicherzellen verteilt.
Its aber nur eine Vermutung aus der Ferne.
 
Beide SSDs waren komplett leer; Sie wurden per Secure Erase gelöscht und anschließend mit Windows 7 neu partititioniert. AS-SSD-Werte folgen noch.
 
Und wie wurden sie partitioniert?

Das Offset der Partitionen ist extrem wichtig und hat, wenn es falsch ist, extreme Auswirkungen auf die Geschwindigkeit.

Schnell kannst Du das Offset mit AS SSD überprüfen.
 
Dem kann ich eigentlich nur meine Werte entgegensetzen.

Samsung 830 256 GB
Betriebszeit 6841 Std - Schreibrate 6,43 TB - Zustand 100%

OCZ Vertex 2E 128 GB
Betriebszeit 13485 Std - Schreibrate 5,56 TB - Zustand 100%

Beide haben bedeutend mehr Stunden auf den Buckel und auch die Schreibrate ist deutlich höher. Die Werte die du hier hast sind für eine SSD noch völlig unkritisch. Hast du schon mal andere Diagnosetools probiert welche Werte dort angezeigt werden. Und wie bereits angesprochen "Passt auch das Aligment"

Die Schreib und Leseleistung hat sich in dieser Zeit bei mir auch kaum verschlechtert.
 
Zuletzt bearbeitet:
So, hab nochmal neu getestet.
Vorgehensweise:
1. Secure Erase
2. bestehendes OS eines Laptops geklont (Core2Duo, P45m, AHCI)
3. Windows beruhigen lassen (Windows 8.1 x64)
4. Getestet
Ergebnis:
Beide kommen sequentiell etwa auf 235(read) und 225(write)
IOPS bei 4k/64Thr: 31k (read) und 16k (write), scheint wohl recht normal zu sein.
AS-SSD-Benchmark
Ausrichtung: OK laud AS-SSD

Interessantes Ergebnis, die Dinger scheinen sich wohl wieder erholt zu haben oder irgendwas anderes war faul...
 
Ein Secure Erase kann eine SSD schon komplett durcheinander bringen. Und ist im Grunde auch unnötig.
 
Wenn sie langsamer geworden sind und dann nach einem Secure Erease wieder schneller wurden, so sind sie vorher vermutlich nicht getrimmt worden. Der alten Intel AHCI Trriber vor Version 9.6, wie er mit Sicherheit noch auf den Treiber CD so einer alten Boards zu finden ist und sehr wahrscheinlich auch auf der Treiberseite des Boardherstellers, unterstützt noch kein TRIM.

Man sollte daher immer auch mal prüfen ob TRIM wirklich funktioniert. fsutil behavior query DisableDeleteNotify zeigt aber nur an, ob Windows überhaupt TRIM Befehle schickt und Tools wie CrystalDiskInfo zeigen die Eigenschaften der Disks an, also ob der Controller überhaupt TRIM Befehle versteht. Beides sind aber nur zwei der Voraussetzungen damit es klappt, denn wird nirgends angezeigt, ob der Controller wirklich TRIM Befehle bekommt. Das kann man nur mit dem Tool TrimCheck prüfen, man lässt es zweimal laufen, beim ersten mal wird die Testdatei erzeugt und gelöscht, beim zweiten mal wird geschaut ob TRIM funktioniert hat. Dazwischen sollte man nichts am Rechner machen und ein paar Minuten warten. Wurde TRIM nicht als funktionierend erkannt, kann man es auch erneut laufen lassen und es prüft die Daten noch einmal. TrimCheck muss auf der SSD liegen, wenn es ausgeführt wird.
 
Zurück
Oben