Defragmentierung funktioniert wegen chkdsk nicht

handschigl

Newbie
Dabei seit
Nov. 2006
Beiträge
3
Hallo,

bei mir erschein folgende Fehlermeldung, wenn ich eine Defragmentierung starten möcht:
Diskeeper hat erkann, dass die Ausführung von CHKDSK auf dem nachstehenden Datenträger geplant ist: Windows XP (C: ).
Die Ausführung erfolgt entweder aufgrund einer Benutzeranfrage oder weil das Betriebssystem einen Fehler im Dateisystem gefunden hat. CHKDSK wird beim nächsten Neustart automatisch ausgeführt.
Solange CHKDSK nicht ausgeführt wurde, kann Diskeeper diesen Datenträger nicht defragmentieren.
Ich habe einmal CHKDSK für einen Systemstart geplant, aber das ist schon lange her. Damals kam aber immer die Meldung, dass CHKDSK das Volume nicht überprüfen konnte und hat deshalb jedes Mal abgebrochen. Jedoch kam das dann bei jedem Systemstart. Seit ein oder zwei Wochen startet CHKDSK am Systemstart nicht mehr darum dachte ich, dass es sich abgestellt hat, was aber anscheinend nicht der Fall ist.

Kennt jemand eine Lösung CHKDSK abzustellen, dass ich meinen Datenträger wieder defragmentieren kann?
 

Mueli

Admiral
Dabei seit
Aug. 2005
Beiträge
7.533
Dein Problem wird eher sein, dass chkdsk noch nicht vollständig/oder überhaupt nicht durchgelaufen ist. Ein Defrag läuft nur, wenn das Filesystem clean ist, überprüfen kann man es in einer Console mit fsutil dirty query <LW>: (wobei für LW der betreffende Laufwerksbuchstabe eingesetzt werden muss.
Im Internet kursieren viele Tips, wie man den Autocheck (zum Systemstart) abschaltet und dies wird wohl auch allzugern von Usern befolgt (evtl. weil die Meldungen nerven), nur wird damit ein Symptom beseitigt und nicht die Ursache, die u.U. ein defekter Sektor der Disk oder nur ein Fehler im Dateisystem sein kann. Als Optionen im Chkdsk sollte auf jeden Fall /f /r dabei sein (chkdsk -? für die Hilfe). Eine Datensicherung sollte aber vorher zur Sicherheit immer gemacht werden.
 

Kuhni Lingus

Lieutenant
Dabei seit
Aug. 2006
Beiträge
605
Auch wenn Mueli natürlich im Prinzip mit seiner Rede vom Kurieren an den Symptomen Recht hat :

Mit :

CHKNTFS /X C:

schaltest du die Prüfung des Laufwerks C: ab.
 

Nostromo33

Lt. Junior Grade
Dabei seit
Okt. 2005
Beiträge
494
Laß einfach wie beschrieben chkdsk /F laufen, dann sollten die Fehler im Dateisystem beseitigt werden, eben bei c: am nächsten Neustart, dann kannst du auch wieder defragmentieren.
 

handschigl

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
3
@Nostromo33: Das habe ich leider vorher schon vergeblich versucht. Da erscheint die gleiche Fehlermeldung, wie nachfolgend angegeben.

@Kuhni Lingus: Ich habe deinen Vorschlag versucht, allerdings erscheint dann folgende Fehlermeldung:
Das aktuelle Laufwerk kann nicht gesperrt werden.
CHKDSK kann nicht ausgeführt werden, weil das Volume von einem anderen Prozess verwendet wird. Soll das Volume überprüft werden, wenn das System das nächste Mal gestartet wird? (J/N)
@Mueli: Wenn ich das teste, steht dran, dass das System fehlerhaft ist, aber wenn ich dann chkdsk /f /r ausführe, erscheint die vorhergenannte Fehlermeldung.
 

Mueli

Admiral
Dabei seit
Aug. 2005
Beiträge
7.533
Wurde denn gleich nach der Meldung auch ein Reboot gemacht?

Zur Not könnte auch ein Boot in die Recovery-Console und ein manuelles ausführen des Befehls helfen. Du solltest sicher sein, dass er durchgelaufen ist.

Ein Defrag läft jedenfalls erst, wenn das Filesystem Clean ist.
 

handschigl

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
3
Ich kenne mich mit diesem Bereich des Computers nicht so gut aus, deshalb wäre es hilfreich, wenn die Vorschläge besser erklärt wären. Danke! Ich weiß z.B. nicht wie ich das machen soll:
Boote mal von der Wiederherstellungskonsole
und wenn ich chkdsk /p einfach so ausführe erscheint die Meldung unzulässiger Parameter.

Außerdem kam dieses Mal beim Starten des Computers das CHKDSK konnte jedoch wieder nicht ausgeführt werden weil es irgendwie keinen Zugriff auf das Volume erhalten kann. Vielleicht hilft euch das weiter.

Aber nochmals danke für euer Bemühen.
 
Top