Excel - Fehlerhafte Messwerte korrigieren

Sherman123

Fleet Admiral
Dabei seit
Nov. 2002
Beiträge
12.337
Ich habe hier ein Messung, die einen Haufen Wertepaare erzeugt. (ca 2500 Zeilen pro Messung)
Leider sind einige Wertepaare korrumpiert und machen Probleme beim Einlesen in Excel:
Code:
28.31065,1.119637E-02
28.31065,1.123405E-02
28.31065,1.127173E-02
28.77859,.0113094
29.48051,.0113094
29.48051,.0113094
29.48051,.0113094
29.48051,.0113094
29.71448,.0113094
29.94845,1.134708E-02
29.94845,1.142244E-02

Mir fallen spontan 2 Möglichkeitne ein:

1.: Wie schaffe ich es, dass alle Werte dasselbe Format haben (X.XXE-0X)
Beim Importieren (Komma=Trennzeichen) kommt ein ziemlich Mist heraus. Ich kann kein ordentliches Diagramm zeichnen mit den gemischten Werten. Außerdem ist nicht nur das Format ein Problem, sondern die Werte selbst sind falsch - es kann nicht 8x hintereinander derselbe Wert stehen)

2.: Gibt es eine Formel, die mir jedes 50. Wertepaar in eine eigene Spalte schreibt und ich korrigiere die paar Werte händisch. 50 Wertepaare würden mir schon genügen, um ein Diagramm zu zeichnen.


Im Anhang liegt das File, vielleicht fällt jemand noch eine bessere Möglichkeit ein.
 

Anhänge

  • g3_1_1.txt
    47,5 KB · Aufrufe: 150
Zuletzt bearbeitet:

-MikeK

Cadet 4th Year
Dabei seit
Mai 2007
Beiträge
92
Du brauchst lediglich zuerst alle "," durch ";" ersetzen damit du ein sauberes Trennzeichen hast und anschließend die "." durch "," ersetzen damit die Zahlenschreibweise stimmt.
Fertig :)

Grad getestet, 30 Sekunden Arbeit.
 

kmeleon

Cadet 4th Year
Dabei seit
Nov. 2007
Beiträge
97
Hallo!
Wenn Du 8 mal hintereinander den gleichen Wert hast und diese damit falsch sind, kann Excel auch nicht mehr helfen. Woher soll Excel wissen, was der richtige Wert ist?

Für die Lösung mit jedem 50. Wert in einer Extraspalte, die Du dann händisch korrigierst, geh so vor:
Wenn A und B die Spalten mit den Daten sind, schreibe z.B. in Spalte D die Formel =ZEILE(A1) und zieh sie ganz runter. In Spalte E schreibst Du die Formel =D1/50 und ziehst sie auch ganz runter. In Spalte F folgende Formel =GANZZAHL(D1/50) und runterziehen. In Spalte G die Formel =WENN(E1=F1;A1;"") und runterziehen. Anschließend legst du einen Filter über Spalte G und filters alle leeren zellen heraus. Dann bleibt nur jeder 50. Wert stehen. Diese kannst Du per copy+paste irgendwo anders untereinander bringen.

Für die Werte in Spalte B gehst Du genauso vor.
 

Sherman123

Fleet Admiral
Ersteller dieses Themas
Dabei seit
Nov. 2002
Beiträge
12.337
@MikeK
Im *.txt File? Und dann importieren oder direkt in excel?


@kmeleon
Danke. Für die Formel.

Ja, die doppelten Werte sind Fehlerwerte. Aber da ich sowieso nur ein Diagramm zeichne, fallen diese paar Werte nicht so sehr ins Gewicht. Das wäre ein verkraftbares Übel.
Ergänzung ()

Arh - Endlich hab ichs geschafft:

Im Importier Menü kann man auswählen, dass ein . Komma-Trennzeichen ist. ' wies ich als Tausender-Trennzeichen zu. Jetzt importiert Excel die Daten richtig.


Danke euch beiden!!!
 
Top