Linux Mint triber für WLAN gesucht

cyberpirate

Vice Admiral
Dabei seit
Jan. 2007
Beiträge
6.750
Hallo,

ich habe hier ein altes Asus Notebook wo früher WinXP installiert war. Ich habe mir darauf
jetzt Linux Mint installiert. Ich bin absoluter Neueinsteiger und weiß nicht wie ich den fehlenden
Treiber für das WLAN installieren kann und wo ich den finde. Es handelt sich um folgendes:

Broadcom Corporation BCM: 4306 802.11b/g Wireless LAN Controller

Außerdem wird noch ein Treiber für ein unbekannte Gerät gebraucht. Wie kann ich raus finden
um was für eine Gerät es sich dabei handelt? Es steht dort auch noch folgendes:

Dieses gerät verwendet einen manuell installierten Treiber.
 
Zuletzt bearbeitet:

FrankR31

Cadet 4th Year
Dabei seit
Nov. 2005
Beiträge
71
Hallo, wenn Du Hilfe für Linux Mint brauchst frage doch mal im Mint Forum "http://forums.linuxmint.com/" und bei "http://www.linuxmintusers.de/", da findest Du bestimmt Hilfe. Wenn Dein WLAN nicht funktioniert schließe Dein Notebook erstmal über LAN an und lasse ein komplettes Update durchlaufen, evtl. hilft auch ein Kernel Upgrade, aktuell wäre das 3.13.2. Die notwendigen Dateien dafür findest Du hier "http://kernel.ubuntu.com/~kernel-ppa/mainline/". WIE Du ein Kernel Upgrade machst kannst Du im Linux Mint Forum nachschauen, das ist überhaupt kein Problem und schnell gemacht.
 

xXMartinoXx

Lieutenant
Dabei seit
Okt. 2009
Beiträge
650
Sicher das du da noch nen Treiber brauchst? Bei meinem netbook lief das WLAN sofort unter Mint. Vielleicht hats ja auch ne andere Ursache das es nicht geht.
 

Feuerbiber

Ensign
Dabei seit
Dez. 2012
Beiträge
227
hänge das gerät mal über LAN ans netz und installiere über die grafische treiberinstallation "Jockey", die du ja scheinbar schon gefunden hast die angebotenen treiber.
hier nochmal ne anleitung:
http://wiki.ubuntuusers.de/WLAN/Broadcom_bcm43xx
 

Caedus

Lieutenant
Dabei seit
März 2012
Beiträge
515
Ein Broadcom ...
Installiere aus der Paketverwaltung das Paket b43 und starte den Rechner neu, dann sollte es laufen.
Wenn nicht, dann lies diesen Artikel, vielleicht findest du da noch was passendes.
 

cyberpirate

Vice Admiral
Ersteller dieses Themas
Dabei seit
Jan. 2007
Beiträge
6.750
So nach den Updates erscheint unter Treiber nix mehr. Ob das jetzt installiert
wurde weiß ich nicht. Jedenfalls sieht der Rechner immer noch kein WLAN Netzwerk.
Es steht dort unten rechts in der Leiste immer nur das Kabelnetzwerk.
Dann wird das wohl nichts mit dem Notebook und WLAN. Schade eigentlich.
 

Feuerbiber

Ensign
Dabei seit
Dez. 2012
Beiträge
227
Hast du denn mal die Anleitung die dir zwei Leute gepostet haben befolgt?

Wenns schon daran scheitert ein Paket zu installieren, solltest du vielleicht wirklich die Finger von Linux lassen...


Um es kurz zu machen und dir das Mausgeschubbse zu ersparen:

- öffne ein Terminal
- gib folgenden Befehl ein:
sudo apt-get install b43
anschließend:
sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
- anschließend:
sudo apt-get install b43-fwcutter firmware-b43-installer

-starte ggf. das System neu


Das Ganze hat mich 30 Sekunden Recherche gekostet, ist der PC-Nutzer von heute wirklich so unmündig?
 
Zuletzt bearbeitet:

cyberpirate

Vice Admiral
Ersteller dieses Themas
Dabei seit
Jan. 2007
Beiträge
6.750
Nein der Nutzer ist nicht so unfähig wie Du es jetzt hinstellst. Treiber wurden ja schon
installiert wie weiter oben beschrieben. Zumindest geh ich davon aus da es nicht mehr
unter der Rubrik erscheint. Aber es kommt eben keine WLAN Verbindung zustande.
Werde aber nochmal Deine Anleitung testen.

Das Ergenis der ersten Eingaben:

AMD2800 nuub65 # sudo apt-get install b43
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket b43 kann nicht gefunden werden.
AMD2800 nuub65 # sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-sourc
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket broadcom-sta-sourc kann nicht gefunden werden.
 
Zuletzt bearbeitet:

Feuerbiber

Ensign
Dabei seit
Dez. 2012
Beiträge
227
Du hast das "e" bei " broadcom-sta-sourcE" vergessen, deswegen die Fehlermeldung der zweiten Ausgabe. Wiederhole den Befehl:
sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

Kommen dann immernoch Meldungen, dass Paket nicht gefunden werden kann, dann ist es nicht vorhanden und u kannst das entsprechende paket bei der Eingabe des Befehls weglassen.

Dieser Befehl ist nötig ab Kernelversion 3.0.X, ich vermute mal das ist bei dir der Fall weil du eine aktuelle Distri benutzt. Er entfernt "alte" Treibermodule, die zu fehlern führen können.

Bezüglich der Frage ob der Treiber installiert ist:
Poste bitte einmal die Ausgabe von:
lsmod

Dies zeigt dir alle geladenen Treibermodule an. Wenn der Treiber installiert ist, müsste er dabei sein.

Ist der dritte Befehle " sudo apt-get install b43-fwcutter firmware-b43-installer " durchgelaufen?
Wenn ja ist das gut, es installiert die unfreie Firmware.



Starte System neu und melde dich nochmal hier



Falls es immer noch nicht gehen sollte, sage mir bitte um welchen WLAN-Chip es sich genau handelt. Dies erfährst du mit:
lspci -vnn | grep 14e4

Kopiere die Ausgabe bitte hier her. Dies ist wichtig, da es zig verschiedene Chips gibt die die Hersteller verbauen. Wie du in deinem Fall HIER sehen kannst.
Evtl. brauchst du nämlich den legacy Treiber. (es gibt zwei verschiedene Treiber für die Broadcom Chips)
 
Zuletzt bearbeitet:
Top