Nur 1 Kern im Task-Manager trotz 4

t-6

Admiral
Dabei seit
Juni 2007
Beiträge
7.970
Nur 1 Kern im Task-Manager trotz 4 physisch vorhandener

...nein, das Häkchen bei msconfig ist nicht gesetzt :)

Es geht darum, dass auf einer frischen Server2012R2-Installation nur 1 Kern im Task-Manager ( & CPU-Z) erkannt/genutzt wird, obwohl alle 4 Kerne im Geräte-Manager erkannt werden. Hyperthreading ist ausgeschaltet, aber auch vorher wurde nur ein phyischer Kern (und halt 2 logische Kerne) erkannt.

Bevor ich jetzt wieder eine KVMoverIP buche um ins BIOS zu kommen & einen Reset durchführe oder gar das ganze Betriebssystem neu installiere (ist bei Hetzner & eigenem Windows/ISO etwas umständlich) frage ich an dieser Stelle lieber erst noch mal nach, ob jemand das Problem kennt und ob ich irgendetwas vergessen haben könnte?

Eckdaten:
Server EX40 von Hetzner
Core i7-4770
Mainboard MSI H87-G43, BIOS up-to-date
32GB RAM
2x2 TB
Windows Server 2012 R2 Std, up-to-date
Rolle: Hyper-V

Siehe auch noch ein Bild der Gesamtsituation: kerne.png

Vielen Dank für den Input!

edit: Nach einer Neuinstallation & Dokumentieren aller relevanten Schritte ist herausgekommen, dass die Rolle Hyper-V irgendetwas damit zu tun hat. Entferne ich die Rolle -> 4 physische/8 logische Kerne. Setze ich die Rolle -> 1 physischer/2 logische Kerne.
 
Zuletzt bearbeitet:

Skandaloes

Lt. Junior Grade
Dabei seit
Juni 2009
Beiträge
260
Im Taskmanager rechte Maustaste in das CPU Diagramm>>Diagramm ändern...>>von gesamt Auslastung auf logische Prozessoren umstellen.

Edit: jetzt erst gesehen das CPU-Z auch nur 1 Kern erkennt. :freak:
 
Zuletzt bearbeitet:

wesch2000

Commander
Dabei seit
Aug. 2014
Beiträge
2.247
das problem hatte ich auch schon mal. nachdem ich mit der setup-dvd gestartet war, waren wieder alle kerne da.
 

t-6

Admiral
Ersteller dieses Themas
Dabei seit
Juni 2007
Beiträge
7.970
Im BIOS mal nach der Virtualisierung geschaut oder generell, was da so eingestellt ist?
VT-d ist an. Alles steht auf quasi "max" - es macht echt keinen Sinn von den Einstellungen im BIOS/UEFI her, dass das Betriebssystem nur einen Kern erkennt.

Update: Dieses Problem hat mit Hyper-V zu tun; wird Hyper-V angeschaltet, bleibt im Task-Manager nur noch 1 phyischer Kern übrig. Wird Hyper-V wieder entfernt, bekommt der Host alle Kerne (nach dem obligatorischen Neustart) wieder zurück.
 
Zuletzt bearbeitet:

MusicJunkie666

Commander
Dabei seit
März 2013
Beiträge
2.757
Ich konnte auch schon "interessante" Phänomene in Zusammenhang mit Hyper-V feststellen; allerdings nicht so schlimm wie bei dir.

In meinem Fall zeigte der Task-Manager nach Installation der Hyper-V Rolle die ganze Zeit an, dass die CPU mit vollem Takt laufen würde. CPU-Z hat aber gezeigt, dass es eben nicht so ist...
 

t-6

Admiral
Ersteller dieses Themas
Dabei seit
Juni 2007
Beiträge
7.970
Kurzer Nachtrag: Selbst das Standard-Windows-Image vom Anbieter hat exakt dasselbe Problem hervorgerufen. Der Server geht jetzt "zurück".
 

ekin06

Captain
Dabei seit
Nov. 2007
Beiträge
3.286
Top