OSX und kein richtiger Zugriff auf das Netzwerk

LaserDiscDude

Captain
Registriert
Apr. 2007
Beiträge
3.673
Ich habe meine Apple Time Maschine verkauft und mir ein NAS von QNAP gekauft.

Unter Windows läuft das Ding ohne Probleme, außer wenn ich mit meinem MacBook Pro damit arbeiten möchte.

Zuerst musste ich Feststellen, dass die Verbindungsprotokolle SMB und AFP ziemlich langsam sind und nach etwas längeren recherchieren ich im Netz das Protokoll NFS gefunden habe.

Ich muss dazu sagen, dass ich ein einfach Anwender in der OSX Welt bin und ich am liebsten mit solchen Sachen "protokollen" nicht aueinandersetzen möchte und diese vorher auch nicht gekannt habe.

Jetzt aber spinnt OSX irgendwie komplett.

- Der Inhalt von Ordnern wird ziemlich langsam angezeigt, sprich man öffnet ein Ordner und nach 10 Sekunden ungefähr wird erst der Inhalt angezeigt, unter Windows habe ich dieses Problem nicht.

- Mit Word oder Excel kann ich auf das NAS überhaupt nicht zugreifen. Es wird im Finder mein Root Ordner angezeigt, darin wird nichts angezeigt. Jetzt kopiere ich alle meine Daten zuerst auf den Desktop....

- Manchmal sagt mir OSX, dass die Dateien defekt seien bzw. nicht lesbar, auch meckert er herum, dass ich keine Zugriffsberechtigung darauf habe. Hier habe ich nur die Lösung mit einem anderen Protokoll micht zu verbinden, dann klappt das auch.

Somit ist der NAS unter OSX überhaupt nicht nutzbar für mich. Ist das ein generelles Problem von OSX, dass es sich im Netzwerk nicht gut verhält, oder habe ich etwas übersehen? oder, gibt es ein noch weiteres besseres Protokoll?

Ich hoffe Ihr könnt mir hier weiterhelfen.
 
Ich habe hier 3 QNAP Würfel rumstehen, alle haben Time Machine schon dabei, muss nur aktiviert werden. Schon kann das MacBook damit arbeiten.

Nix mit rumfummeln, das ist doch das was den Mac ausmacht.

lg
fire
 
d3vilsadvocate schrieb:

Jaaaa, und weiter?

firexs schrieb:
Ich habe hier 3 QNAP Würfel rumstehen, alle haben Time Machine schon dabei, muss nur aktiviert werden. Schon kann das MacBook damit arbeiten.

Nix mit rumfummeln, das ist doch das was den Mac ausmacht.

lg
fire

Time Machine ist die einzige Funktion die bei mir ohne Probleme funktioniert...

Bei mir ist das irgendwie anders herum, Mac macht bei mir die meisten zicken und Windows läuft 1A
 
Glaube eher, dass das Problem wo anders zu suchen ist. AFP sollte eigentlich schnell laufen. Wie verbindest du dich auf dem Mac mit dem NAS?
Im Finder cmd+k und dann afp://ipAdresseNAS?
 
signalgrau schrieb:
Glaube eher, dass das Problem wo anders zu suchen ist. AFP sollte eigentlich schnell laufen. Wie verbindest du dich auf dem Mac mit dem NAS?
Im Finder cmd+k und dann afp://ipAdresseNAS?

Genau.

Unter AFP läuft es bei mir so um die 10 MB in der Sekunde, bei NFS 18 MB.
 
Das mit dem "Nix mit rumfummeln" trifft leider mit steigender Versionsnummer von OS X immer weniger zu und die beschriebenen Probleme kenne ich auch zu genüge...
Das Ding ist, dass Apple nach und nach "Apple-fremde" Protokolle von der Liste streicht... SMB ist jetzt schon ein Graus und der Support für NFS wird (ich glaube beginnend mit 10.9) auch immer weiter reduziert...
Zu diesem Zweck haben wir in der Firma einen netatalk-Server aufgesetzt, was in etwa dem entspricht, was QNAP eben auch macht um als AFP-Server zu fungieren. Für die Unterstützung von TimeMachine muss der Server die Option "tm" senden, dadurch akzeptiert die TimeMachine den Server als TimeCapsule... Wenn aber bestimmte Informationen nicht korrekt gesendet werden, dann kann das zu Problemen führen...

Dennoch würde ich schauen, ob du vielleicht irgendwie anders geartete Probleme hast... schlechte WLAN-Verbindung, falsches Routing oder was auch immer...
 
Hat echt keiner eine Lösung für das Problem?

Bei mir im Netzwerk gibt es keine Probleme, es muss definitiv am OS X liegen. Das geilste ist, wenn ich Windows 7 über Boot Camp auf MacBook Pro starte, funktioniert alles, ohne rumgefummel!

Das ist echt nervig wenn ich Dokumente erst auf den Desktop ziehen muss um sie zu bearbeiten.

Langsam überlege ich mir, die OS X Partition noch kleiner zu machen und nur noch Windows auf dem MacBook Pro zu nutzen, da habe ich zumindest keine Probleme und das Arbeiten läuft angenehmer von statten.
 
Prüf mal so Standarddinge wie DNS und Gateway, etc. Vermutlich ist da was nicht korrekt und daher laufen Anfragen ins leere.

lg
fire
 
Schau mal mit dem Netzwerkdienstprogramm nach, wo es hakt. Kannst ja einen Trace an die Adresse schicken, mit der du dich verbinden willst.
 
Ja Leute, habe mir einen Mac gekauft um nicht ständig irgendwelche IT-Fachbegriffe zu erlernen und zu schauen wo sich was befindet, ich will einfach nur auf meine Daten zugreifen :-(

Könnt Ihr mir erklären wie ich was genau mache?
 
Da bin ich leider raus, da ich aus gutem Grund kein Apple Gerät nutze.

lg
fire
 
Ich habe den Fehler gefunden, zumindest was es mit den Word, Excel etc. Datein auf sich hat.

Im gesammten Pfad zur Datei, darf das wort "File" nicht auftauchen! Auch nicht als "Fileserver" oder "Files".

Jetzt habe ich meinen Root Ordner auf "Data" umgestellt und siehe da, keine Probleme.

Um das herauszufinden, musste ich einige Stunden googlen :-(

Was die Geschwindigkeit betrifft, liegt es wohl einfach daran, dass die Protokolle einfach von Apple Stiefmütterlich behandelt werden und es wohl von Version zu Version schlimmer wird.
 
Zurück
Oben