Cups auf Pi Zero - Drucker in Windows wird nicht verbunden

Infect007

Lt. Commander
Registriert
Mai 2008
Beiträge
2.000
Hi,
ich habe seit einer knappen Woche CUPS auf einem Pi Zero installiert.
Das ging soweit relativ einfach.
Danach habe ich den Drucker meiner Freundin (Kyocera FS-920) als Drucker hinzugefügt (Das Häkchen dass der Drucker geshared wird ist gesetzt). Der Druck der Testseite über das CUPS Menü war auch erfolgreich.

Danach wollte ich den Drucker auf meinem PC und dem Laptop meiner Freundin hinzufügen.
Wenn ich auf "Drucker suchen" klicke, wird direkt "printer @ raspberrypi-2" gefunden.
Nach Klick auf "Gerät hinzufügen" steht danach permanent Verbindung wird hergestellt.

Bei meiner Freundin am Laptop habe ich das gleiche Problem.

Im CUPS Hilfebereich habe ich unter der Rubrik "Printer Sharing" noch folgendes gefunden.
cupsctl --share-printers
cupsctl --share-printers --remote-any
lpadmin -p printer -o printer-is-shared=true
lpadmin -p printer -o printer-op-policy=authenticated

Alle 4 Befehle habe ich danach testweise per SSH noch ausgeführt, gebracht hat es nichts.
Zusätzlich habe ich mal noch:
lpadmin -p Kyocera_FS-920 -o printer-is-shared=true
lpadmin -p Kyocera_FS-920 -o printer-op-policy=authenticated
ausgeführt, jedoch war auch das ohne Erfolg.

Habt ihr eine Ahnung was ich falsch mache?
 
Madman1209 schrieb:
Hi,

Datei- und Druckfreigabe ist auf den Windows-Clients aktiv?

VG,
Mad
Ja, Netzwerkerkennung und Datei- und Druckfreigabe ist beides eingeschaltet/aktiviert
 
danke @IceKillFX57
Das hat bei mir leider auch nicht geklappt :/
"Es konnte keine Verbindung mit dem Drucker hergestellt werden. Überprüfen sie den Druckernamen und wiederholen sie den Vorgang..."

Muss ich evtl. noch irgendetwas mit der Benutzersteuerung machen?
Benutzer hinzufügen und irgendwelche Rechte vergeben?
 
IceKillFX57 schrieb:
Hast du das so da angegeben?:
[IMG]https://s12.directupload.net/images/200823/temp/l5m43dha.png[/IMG]

Natürlich dann deinen Drucker. Hast du den unter CUPS eingerichtet?
Ja genau, so habe ich ihn angegeben und auf weiter gedrückt, dann kam aber die oben genannte Fehlermeldung.
Wenn ich meine URL da eingebe und auf durchsuchen klicke, öffnet er die Netzwerkumgebung, da wird aber auch kein Drucker gelistet.

Ja, unter CUPS habe ich ihn hinzugefügt, aber was genau meinst du mit eingerichtet?
Der Druck der Testseite über CUPS hat auch funktioniert.

Nur nochmal zu Bestätigung:
Der Drucker ist nur am Pi Zero angeschlossen per USB, der Pi Zero per WLAN.
Mein PC hat keine USB Verbindung zum Drucker, sie sind nur beide im LAN
 
Du sollst ja nicht Durchsuchen sondern die Adresse da einfügen und dann auf Weiter klicken
 
IceKillFX57 schrieb:
Du sollst ja nicht Durchsuchen sondern die Adresse da einfügen und dann auf Weiter klicken
Habe ich ja wie gesagt gemacht:

Infect007 schrieb:
Ja genau, so habe ich ihn angegeben und auf weiter gedrückt, dann kam aber die oben genannte Fehlermeldung.

Leider kommt dann wie gesagt die Fehlermeldung
 
IceKillFX57 schrieb:
Feste IP hast du dem PI vergeben oder? Nicht das es da dran liegt....
Ja, ich habe dem Pi auf der Fritzbox immer die 192.168.178.44 zugewiesen.
Ich kann auch per SSH darauf zugreifen.
 
@IceKillFX57 braucht man denn zwingenderweise ein Samba Server?
Oder geht das mittlerweile ohne Samba?

edit:
habe jetzt alles nochmal neu aufgesetzt und jetzt funktioniert es.
kA wo der Fehler war, aber Hauptsache es läuft jetzt :)
 
Zuletzt bearbeitet:
Zurück
Oben