Ubuntu neue Partition einbinden

CA3D0

Lt. Commander
Dabei seit
Apr. 2011
Beiträge
1.141
Hallo,

Ich versuche gerade in Ubuntu einen bisher ungenutzten Teil der Festplatte einzubinden
ich habe die Partition /dev/sda2 als ext4 formatiert und möchte sie jetzt einbinden, aber dieser Artikel hat mich ein bischen erschlagen :lol:

soweit bin ich gekommen:
Code:
sudo mount -t ext4  /dev/sda2 /home
wird so das Dateisystem permanent in in den Home Ordner eingebunden?
 

SpamBot

Vice Admiral
Dabei seit
Juni 2010
Beiträge
6.591
nein nur für diese Sitzung, permanent kannst du recht einfach über fstab einbinden... schau dir einfach hier die Beispiele an ;) klick

Edit: kurze Anleitung:
im Terminal

(fstab mit Editor öffnen)
"sudo gedit /etc/fstab"

dann eine neue Zeile mit
Code:
/dev/sda2     /home/Benutzername/deinZielOrdner     ext4     rw     0     0
einfügen

Edit, Fehler ausgebessert... sorry )
 
Zuletzt bearbeitet:

CA3D0

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
1.141
edit: danke

wobei es /home/Benutzername/Zielordner ist
Ergänzung ()

/dev/sda2 /home/test/sonstiges ext4 defaults,rw 0 0
das steht jetzt in fstab drin, danach habe ich
eingegeben, aber anscheinend habe ich keine Schreibrechte für die Partition oder so, sobald ich eine Datei dorthin schreiben will bekomme ich einen Fehler
Ergänzung ()

es ist anscheinend ein Berechtigungsproblem, habe ich irgendeinen Befehl vergessen?
 
Zuletzt bearbeitet:

SpamBot

Vice Admiral
Dabei seit
Juni 2010
Beiträge
6.591
du bist dann wahrscheinlich nicht Besitzter der Ordner und Dateien...
entweder über die Konsole mit chmod rechte holen oder du öffnest den Explorer mit Admin rechten (sudo nautilus) und dann rechtsklick auf die Order und dir dann da irgendwo in den Eigenschaften die Rechte holen

Edit: Nur wenn du die Partition in deinem Ubuntu z.B. mit geparted erstellst erhälst du Automatisch Lese und Schreibe rechte auf die Datein dieser Partition... wenn du die Partition in einem anderen System erstellst und nachträglich in fstab einbindest musst du dir erst die "Besitzrechte" holen ;)
 
Zuletzt bearbeitet:

CA3D0

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
1.141
kann das daran liegen, dass ich nicht der Besitzer der partition bin?
Ich habe die Partition nicht in Ubuntu formatiert
afaik ist das doch nur bei fat und ntfs wichtig?!

edit: plötzlich antworten alle^^
Ich habe die Berechtigungen über sudo Nautilus änder können, jetzt funktioniert es

Vielen Dank an alle
 
Zuletzt bearbeitet:

Daaron

Fleet Admiral
Dabei seit
Dez. 2011
Beiträge
13.487
Die Variable "default" beinhaltet "rw", aber gleichzeitig auch "nouser". So wie ich das sehe muss da die Option "user" mit gesetzt werden (als letztes), also defaults,users
 
Top