VirtualBox 5.1 USB 3.0 Treiber - BlueScreen und Probleme

Oli-nux

Lieutenant
Dabei seit
Nov. 2007
Beiträge
675
Hallo,

wie im Betreff steht nutze ich VirtualBox, aktuell 5.1.18.
Host und Gast sind jeweils Windows 7 64-Bit.
USB 2.0 läuft auch problemlos, aber ich wollte nun USB 3.0 in der VM nutzen.

Nachdem ich auf diese Renesas-Treiber gestoßen bin und diese installiert habe, danach die VM beendet, in den VM-Einstellungen USB 3.0-Controller aktiviert und wieder gestartet habe, mich am Gast angemeldet habe, versuchte er den Treiber zu installieren bzw. zu finden und stürzte mit einem BlueScreen ab.
Die VM startet aber kurz darauf wieder automatisch, also wieder am Gast in Windows angemeldet, er suchte wieder, wieder BlueScreen - Spiel von vorne.

Danach konnte ich mich am Gast anmelden, er sucht nichts mehr und auch kein BlueScreen mehr (bisher).

Andere USB 3.0 Treiber (für die VM) konnte ich nicht nutzen:
https://www.computerbase.de/downloads/treiber/mainboards/usb-3.0-host-controller-treiber/
Ich habe einen Quad Q6600.
Eine extra Karte für USB 3.0 wurde damals von mir eingebaut, weil das Mainboard (MSI P35 Neo2) kein USB 3.0 hat.:o

Problem:
Ich kann zwar einen USB-Stick an USB 3.0 anschließen, aber in der VM nicht nutzen. Schließe ich diesen am USB 2.0 an, so kann ich diesen in der VM nutzen.
Am Host funktioniert der USB2.0-Stick sowoahl am USB 3.0 als auch USB 2.0.
Am Host funktioniert USB 3.0 generell!

Es wird mir auch noch im Geräte-Manager der VM ein Unbekanntes Gerät angezeigt, welches mir beim Installieren von Treibern (automatisches Suchen auf Festplatte) den ersten BlueScreen bescherte.
USB-Controller.jpg
Minidump1.jpg
Minidump2.jpg

Edit:
Das Intel Driver Update Utility fand auch keinen Treiber.
 
Zuletzt bearbeitet:

ekin06

Captain
Dabei seit
Nov. 2007
Beiträge
3.376

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675
Habe ich installiert, ich nutze VirtualBox schon sehr lange ;) (glaube seit v3.x) - geht trotzdem nicht.
 

ekin06

Captain
Dabei seit
Nov. 2007
Beiträge
3.376

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675
Die Beiträge dort bringen mir leider alle nichts!

Karte ist eine Xystec PCIe 2x USB 3.0 (wohl unbekannter).
Sie funktioniert aber lokal sehr gut.
 

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675

gozoc

Cadet 4th Year
Dabei seit
Okt. 2004
Beiträge
116
Tja ... meiner bescheidenen Meinung taugt VirtualBox nicht mehr. Ungefähr seit der Version 4.
Also ich habe NUR Probleme. Bis zu einem USB3 Problem komme ich erst gar nicht.
Nach einem Update gehen also VMs nicht mehr. Neue kann ich erst gar nicht erstellen. Netzwerk-Modul Probleme und letztens wollte ich mal updaten (in der Hoffnung das was besser wird), also auf die aktuelle Version 5.1.18 .... da läuft das Update nicht mal durch.
Auch nach mehrmaligen Versuchen komme ich nie durch das Update. Es hängt einfach (vermutlich beim Netzwerkkarten-Modulupdate).
Ich gebe auf und schmeisse diese Software runter.
Das doofe ist nur, dass es, wie in vielen EDV Bereichen, kaum taugliche Alternativen gibt.
VmWare ist mittlerweile auch verkommen und Schrott. Früher, als es das nur unter Linux gab, war es superklasse und das non plus ultra.
Taugt alles nix mehr ... zumindest ist das meine persönliche Erfahrung.
Und dieses hyper-V Zeug von Microsoft .... *kotz* ist natürlich das Letzte und braucht man gar nicht erwähnen.

Alles nur noch Frickelsoftware, was den User dazu zwingen möchte, stunden und tagelang vor dem PC zu sitzen und die Probleme zu lösen. Was für ein Blödsinn.
(ich habe übrigens eine Windows 7 prof. x64 Systemumgebung.)
 

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675
Lieber gozoc,

zum einen gehört dein Problem nicht hier rein und hilft mir nicht weiter!;)

Zum anderen nutze ich VirtualBox auch schon mind. seit v4 und ich habe keine Probleme!
Bis auf eben aktuell USB 3.0.:rolleyes:
Bei Updates lade ich mir das Setup sowie das Extension-Setup herunter und installiere es (es deinstalliert die vorherige Version automatisch).:)
Ich kann dein Problem also garnicht nachvollziehen.
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.909
Unter VBOx installierst Du gar nichts an Treibern, die zu Deiner USB 3 Karte gehören. Gar nichts. So geht das nicht. VBox virtualisiert die USB 3 Ports und versorgt sie mit der Gast Erweiterung mit einem eigenen xHCI Treiber.

Was gemacht werden muss. Der USB Controller muss ordnungsgemäß unter dem Host laufen und eingerichtet sein.
 

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675
@BlubbsDE
Bist du dir da wirklich ganz sicher und hast du das selbst im Einsatz?
Nachdem was man so liest muss der Treiber in der VBOX installiert werden.
Unter dem Host läuft USB 3.0 problemlos.
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.909
Ich bin mir da ganz sicher, ja. Es ist eine VM. Die Hardware steht nicht direkt zur Verfügung, auch sie wird von VBox virtualisiert. Und man kann mit den Treibern für USB, GPU, Sound usw. nichts anfangen. Die benötigten Treiber werden von der Gasterweiterung installiert. Und es sind andere Treiber, als die man für die jeweilige Hardware auf dem Host nutzen würde.
 

Oli-nux

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
675
Du bist dir sicher, schreibst aber nicht ob du eine VM mit USB 3.0 selbst im Einsatz hast!:rolleyes:
Dann erkläre mir doch bitte mal die ganzen Beiträge die man über Google so findet - unabhängig vom OS - in welchem es genau darum geht, dass man in der VM (Gast-System) eigene USB3.0-Treiber benötigt?!:freak:
Ich glaube du hast selber keine VM mit USB 3.0 am Laufen und gehst einfach nur von einer Vermutung aus!:o

z.B.:
Quelle
Oskar's Frage vom 13.04.17

Die neuste VirtualBox inkl. Gasterweiterung ist installiert.
Meine externe USB 3.1 SSD von Samsung wird im Gast wohl erkannt, aber nicht richtig eingebunden.
Es fehlt offenbar der besagte USB-3.0-Treiber von Intel.
Aber wie füge ich diesen Intel Treiber richtig in mein Gast-System ein?


Antwort an Oskar:
@Oskar:
Das virtuelle Windows hochfahren. Im virtuellen Windows den Treiber herunterladen und installieren.


Antwort von Oskar:
es hat gekappt, genau so wie es mir hier liebenswürdiger Weise beschrieben wurde.
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.909
Ich bin immer noch zu 100% sicher. VBox emuliert eben einen Intel USB 3 Controller. Daher passen die Intel Treiber. Selbst für Deine USB 3 PCI(e) Karte. Die vermutlich aber keinen Intel Chipsatz hat.

Dein Zitat steht nicht im Widerspruch zu dem, was ich gesagt habe. Irgendeine Hardware muss VBox ja emulieren. Bei USB 3 sind es eben Intel USB Ports, die VBox aus der tatsächlichen Hardware auf dem Host macht. Auch wenn auf dem Host gar kein Intel USB Port zur Verfügung steht.

Und ja, ich habe das schon zigfach unter VBox 5.x eingerichtet. Ich selber nutze jetzt aber den VM Ware Player.
 
Top