Youtube Download ohne Musik oder ohne Bild - Firefox

Headb@nger71

Lieutenant
Dabei seit
Nov. 2010
Beiträge
729
Bevor Youtube seine Regeln geändert hatte konnte ich auch schon die meisten Videos angucken oder downloaden.
Wenn es Probleme gab, dann natürlich im Bereich Musikvideos.
Ich verwende Complete YoutubeSaver oder DownThemAll bzw. VideoDownload Helper.
Eigentlich aber CYS.
Dort kann man den FFmpeg Codec einbinden. So weit so gut. Anschauen geht.

Seit ca. 3 Wochen wird angezeigt das eine Datei herunter geladen wird, aber kein Inhalt. 0 Bytes. Dauert auch nur 1 Sek.
Oder ein Video mit Bild ohne Ton bzw. Tonspur ohne Bild.
Auch laden die Plugins nicht mehr den Titel des Stück mit runter. Nur der hinterlegte Name in der Browserzeile wir angegeben.
In anderen Bereichen bei YT klappts.
FF ohne Plugins neu installiert und Addons danach installiert brachte keine Besserung.
K.Lite Paket installiert auch nicht da lt. einigen Meldungen YT die Codecs geändert hat - stimmt das?

Zweiter PC das gleiche.
Was kann noch der Grund sein oder was helfen?

System neu aufsetzen bleibt als letztes, aber vermutlich keine Besserung.
 

Madman1209

Fleet Admiral
Dabei seit
Nov. 2010
Beiträge
23.973
Hi,

anderes Tool nutzen. Hast du mal ein Beispiel Video, das nicht funktioniert?

VG,
Mad
 

DeusoftheWired

Admiral
Dabei seit
Juni 2009
Beiträge
8.928
youtube-dl zeigt sämtliche verfügbaren Formate, lädt sie herunter, kombiniert sie oder reicht sie zur Verarbeitung an FFmpeg & Co. weiter.

 

MyNamesPitt

Banned
Dabei seit
Jan. 2017
Beiträge
653
Kenne das Problem, irgendwo wurde mir der Grund angezeigt, weiß nur nicht mehr genau wo: Manche Videos sind auf irgend einer Art geschützt, andere nicht. Bei den "geschützten" verweigern einige Addons schlicht die Arbeit. Andere Tools hingegen ignorieren den Kopierschutz und laden einfach herunter. (Rechtlich gesehen ist das auch völlig in Ordnung, da Streaming selbst sowieso eine Form des Kopierens ist.)

Also ich schließe mich an: Anderes Tool nutzen.
 

Headb@nger71

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2010
Beiträge
729
probier ich aus...
 

DeusoftheWired

Admiral
Dabei seit
Juni 2009
Beiträge
8.928
Ein Link zum Video, bei dem es mit den anderen Methoden nicht geklappt hat, wäre auch noch ganz hübsch.
 

Headb@nger71

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2010
Beiträge
729
Zuletzt bearbeitet:

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
39.780
Dann lass das s beim https doch einfach mal weg.

Oder einfach mal das Tool wechseln. Der JDownloader 2 macht da zB einen guten Job und wird ständig aktuell gehalten.
 
Zuletzt bearbeitet:

Headb@nger71

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2010
Beiträge
729
Danke, das klappt.
 

DeusoftheWired

Admiral
Dabei seit
Juni 2009
Beiträge
8.928
Der Screenshot ist nicht von mir, der stammt aus einem drei Jahre alten Blogeintrag. Ist aber der erste Treffer einer Google-Bildersuche nach youtube-dl. :D

Der Fehler bei dir ist, daß du keine reine Videoadresse angegeben hast, sondern die URL noch den Zusatz &list=TLGG1PI3pU5LY1owMTAyMjAxNw enthält. Das hätte einem spätestens bei der Fehlermeldung

Code:
der Befehl "list" ist entweder falsch geschrieben oder konnte nicht gefunden werden.
auffallen müssen. YouTube-Links sehen normalerweise so aus: https://www.youtube.com/watch?v=XetTBjCw6TU. Dabei ist der Teil https://www.youtube.com/watch?v= statisch und die elf Zeichen danach, hier also XetTBjCw6TU, geben die Video-ID an.

Füttert man youtube-dl mit einer solchen reinen Videoadresse, klappt das bei deinen zwei Beispielvideos wunderbar:


Den Hinweis „Downloading js player en_US“ habe ich vorher allerdings noch bei keinem anderen Video gesehen. Mag eine Erklärung dafür sein, daß es mit den anderen Downloader vorher nicht geklappt hat.

youtube-dl kann auch ganze Playlisten herunterladen, wenn man die URL der Playlist übergibt und sie nicht an einer normalen Video-ID hängt. Eine als Beispiel aus dem Channel des Videos, das du benutzt hast:

https://www.youtube.com/playlist?list=PLAXgM0mQib5RoL3i0eDhRTu1gXKUN4bc2

Also ruhig mal die Adreßleiste des Browsers im Auge behalten. Die hat schon ihren Sinn. :)
 
Zuletzt bearbeitet:

Headb@nger71

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2010
Beiträge
729
Probier ich auch noch mal...
Ergänzung ()

D
Der Fehler bei dir ist, daß du keine reine Videoadresse angegeben hast, sondern die URL noch den Zusatz &list=TLGG1PI3pU5LY1owMTAyMjAxNw enthält. Das hätte einem spätestens bei der Fehlermeldung

Also ruhig mal die Adreßleiste des Browsers im Auge behalten. Die hat schon ihren Sinn. :)
Den hab ich aber nicht angehängt, der stand so in der Adresse, könnte sein das der aus dem Abo kommt oder aus dem Lesezeichen das ich angelegt hatte.
Die normalen Links sind auch kürzer...
 
Top