2 Monitor Setup Displayport & HDMI - Fenster verschoben nach WakeUp

Whizzler13

Cadet 1st Year
Dabei seit
März 2019
Beiträge
8
Hi,

ich bin leider ein wenig am Verzweifeln... Gigabyte (mein Grafikkartenhersteller) schiebt das Problem auf LG und LG schiebt das Problem auf Windows 10... Ganz toll.

Ich habe zwei MOnitore daheim. Einen 27" Samsung (Display 2) via HDMI angeschlossen und einen LG 32GK850F-B via Displayport (Display 1 - Hauptbildschirm), Damit ich die vollen 144hz ausschöpfen kann.


Zum Problem:

Beim Wakeup, nachdem der Energiesparmodus von Windows die Monitore ausgeschaltet hat, verschieben sich alle Fenster auf den LG (Display1). Zusätzlich bekomme ich den Windows Sound für PnP Geräte abgespielt (neue Hardware erkannt.)

Das gleiche lässt sich auch anders Simulieren. Ich deaktiviere den LG Monitor manuell. Alle Fenster/Anwendungen bleiben wie gehabt auf Monitor 2 (Samsung). Wenn ich nun den LG (Display 1) wieder anschalte, bekomme ich den PnP Sound für "Hardware entfernt" und kurz darauf den Sound für "Hardware erkannt". Beide Monitore sind dann wieder an, aber es wurden alle Anwendungen auf den LG (Display 1) verschoben.

Im Geräte-Manager werden beide Monitore richtig erkannt und angezeigt.

Nvidia-Treiber sind die letzten / aktuellsten.
Win 10 Version 1809 Build 17763.437

Im OSD kann man leider kein DCC/CI finden.
Lediglich Smart Energy & Automatic Standby. Beides habe ich deaktiviert.

Hat jemand eine Idee / Ratschläge oder sonstige Hinweise? Im Internet konnte ich keine Lösung dazu finden :(
 
Zuletzt bearbeitet: (Thema wurde gelöst! Kann aber leider den Titel nicht ändern)

Humptidumpti

Moderator
Teammitglied
Dabei seit
Aug. 2004
Beiträge
22.906
Das hat auch nix mit den Grafikkarten oder dem Treiber zu tun. Wenn ein Displayport Monitor aus geht oder in Stand By geht meldet er sich bei Windows ab und ist für das System weg. Das ist bei HDMI nicht der Fall.

Wenn für Windows jetzt einen "neuen" Monitor erkennt wirft das automatisch die ganze Desktopbelegung über den Haufen.
 

Whizzler13

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2019
Beiträge
8
Danke erst mal für die Antworten.

Das heißt entweder unterbindet der Monitor-Hersteller den Standby / Stromsparmodus oder Microsoft patched das Problem mal?
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
39.084
Da gibts nichts zu patchen. Monitor weg, Icons werden neu arrangiert. Du kannst Dir da mit einem Tool helfen. Desktop OK eignet sich da zB gut für.

Das Problem mit geöffneten Fenstern wirst Du nicht weg bekommen. Und das wird auch nicht gepatcht werden.
 

Whizzler13

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2019
Beiträge
8
Naja so ganz glauben kann ich das nicht.

Auf der Arbeit sind an der Dockingstation vom Lenovo Thinkpad ebenfalls 2 Displayport Monitore angeschlossen. Hier habe ich gar kein Problem.
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
39.084
Dann sagt die Dock Windows nicht, dass der Monitor nicht mehr zur Verfügung steht.

Dann müsstest Du auch eine Dock zwischen GPU und Monitore setzen. Aber direkt an die GPU angeschlossen wird der sich abgemeldete Monitor auch von Windows entfernt und alles geöffnete landet auf Bildschirm 1.
 
Zuletzt bearbeitet:

Whizzler13

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
März 2019
Beiträge
8
So ich habe nun doch eine nicht perfekte, aber passable Lösung gefunden :-D.

Zur Lösung:
Der LG Support hatte mich auf einen Post gebracht. Ich sollte "DMMEnableDDCPolling" in der Registry deaktivieren.

Folgender reg Eintrag.
Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000]
"DMMEnableDDCPolling"=dword:00000000

Post: #800
https://www.hardwareluxx.de/community/f111/der-multimonitoring-thread-einstiegshilfe-1-a-772061-32.html#post19613592

Das wieder herum hat bei mir nicht den gewünschten Effekt gebracht.

Ich bin dann noch auf das Tool "RestoreWindows" gestoßen.

https://github.com/gurrhack/RestoreWindows

Dieses herunterladen, starten und voilá bei mir funktioniert es nun. 90% aller Anwendungen bleiben nun auf dem zweiten Monitor stehen.

Noch ein Tipp für RestoreWindows - Autostart nach jedem Windows reboot:

Wenn man sich RestoreWindows von github heruntergeladen und entpackt hat, einfach die EXE als Verknüpfung in den Autostart Folder hinterlegen.

Dazu folgendes machen.
  • Win + R (für Ausführen) drücken.
  • "shell:startup" eingeben.
  • Nun eine Verknüpfung von 'RestoreWindows.exe' einfügen.
RestoreWindows startet nun mit jedem Windows start/neustart.

Hoffe ich kann dem ein oder anderem dadurch auch helfen.
 
Zuletzt bearbeitet:
Top