Fantec DB-ALU31 Festplattengehäuse - USB-C Polarität?

banjogit

Cadet 3rd Year
Dabei seit
Mai 2014
Beiträge
61
Hallo zusammen,

ich habe mir folgendes externes Festplattengehäuse zugelegt:

Fantec DB-ALU31 (USB 3.1)

Darin betreibe ich eine 4TB Western Digital Blue.

Das Fantec hat ja einen USB-C Anschluss. Ich schließe es über ein "USB-A auf USB-C" Adapterkabel am USB 3.0 Anschluss meines PCs an.

Jetzt das Seltsame: Je nachdem in welcher Richtung ich den USB-C Stecker ins Fantec stecke wird die Festplatte erkannt oder eben nicht. In beiden Fällen leuchtet zwar das grüne On-Lämpchen, aber es kann sein dass die Platte vom PC nicht erkannt wird. Dann muss ich den USB-C Stecker um 180° drehen, und erst dann wird mir die Platte angezeigt.
Ich dachte bei USB-C ist es egal wie rum man den Stecker reinsteckt?

Dies ist auch am USB-Anschluss meiner Fritzbox und an anderen USB Ports so. Das USB-Adapter-Kabel hab ich natürlich ebenfalls testweise getauscht und als Ursache ausgeschlossen.

Ich hoffe ich habe mich verständlich ausgedrückt und würde mich über Hilfe sehr freuen. Event. ist das Gehäuse ja kaputt?

Vielen Dank im voraus
-banjogit-
 
Ich hatte den gleichen Effekt mit einem Icy-Box Gehäuse und einem AmazonBasics USB-A to USB-C 3.x Kabel.

USB-C selbst sollte in beiden Richtungen gehen. Aber für 3.x Geschwindigkeiten existieren 2 Paar Übetragungsleitungen, von denen nur 1 im A-Stecker angeschlossen sein kann (A hat deutlich weniger Pins).

Laut Standard, sollte das Gehäuse diesen Fall erkennen und intern den USB-C Stecker umgedreht beschalten. Anscheinend halten sich da unsere Gehäuse / die Controller drin nicht an den Standard....

Das kann eigentlich nicht am Kabel liegen, denn das gleiche Kabel funktioniert mit meinem Pixel 4 in beiden Richtungen.

Das trifft hauptsächlich eigentlich nur USB-C auf A Geschichten mit USB 3.x gen 1/2 Geschwindigkeiten. Da bei USB-C Hosts der Host die "Umdrehung" übernehmen kann. Für 2.0 gibt es nur ein Leitungspaar, deshalb muss dort nichts intern gedreht werden.
 
Zuletzt bearbeitet:
Tja, nun stellt sich für mich die Frage, ob ich das Fantec deswegen zurückgeben soll? Die Übertragungsgeschwindigkeit ist davon ja nicht berührt, oder?
 
Nein. Die Geschwindigkeit ist davon unbeeinflusst.

Wenn du es nicht ständig umstecken musst mit A-auf-C Kabeln würde ich es behalten. Da mein Gehäuse das auch hat, würde ich vermuten, das mindestens eine ganze Familie von USB - SATA Controllern das so handhabt und Teile der Konkurenz vermutlich das gleiche Problem hätten (und es nicht gut dokumentiert ist, man müsste also wirklich Gehäuse durchprobieren).
 
Zitat von Ray519:
Nein. Die Geschwindigkeit ist davon unbeeinflusst.

Die Übertragungsgeschwindigkeit betrug beim DB-ALU31 10G immer so um die 35 MB/s. Das erschien mir doch sehr wenig. Ich hab mir dasselbe Gehäuse jetzt in der 6G Variante geholt (DB-ALU3 6G), und bei dem erreiche ich regelmäßig Datenraten um die 140 MB/s. Keine Ahnung, ob das von diesem USB-C-Steckerproblem herrührt. Jedenfalls gebe ich das DB-ALU31 jetzt zurück, Ich brauche nämlich ein Gehäuse das vernünftig an meinen USB-A 3.0 Port funktioniert.
 
35 MB/s klingt sehr stark nach USB 2.0 Geschwindigkeit. Das passiert normalerweise wenn Leute halt nur ein 2.0 A-auf-C Kabel kaufen.

Aber dazu passt nicht ganz dein bisheriges Problem, das der Stecker nur in einer Orientierung überhaupt ne Verbindung bekommt, da müsste also noch mehr/was anderes im Argen liegen, als meine bisherige Vermutung. Den Fall hatte ich auch nicht getestet...
 
Zuletzt bearbeitet:
So, ich habe jetzt mal mit meinen externen Gehäusen ein wenig ausprobiert und kann dein Problem so ziemlich nachstellen.

Mit 2.0 (C-auf-C) geht es nur in einer Orientierung. Mit 3.x gen 1 (5G) A-auf-C geht es in einer Orientierung, die andere geht nicht (Notebook sieht die Festplatte, aber nix funktioniert. Desktop findet die Festplatte gar nicht). Mit einem 3.x gen 2 (10G) C-auf-C Kabel geht es in allen Konstellationen (das ist das Kabel was vom Hersteller der Festplattengehäuse auch beiliegen sollte).

Ich habe ein weiteres externes Gehäuse wo grundsätzlich alles geht, auch die A-auf-C 3.x gen 1 (5G) Variante absolut ohne Probleme.

Ich konnte für dein Fantec-Gehäuse leider nicht herausfinden, ob es den selben/ähnlichen Chip verwendet, wie mein Gehäuse (Asmedia ASM1352R Chip) und damit ob man das Problem vllt auf einen bestimmten Chip eingrenzen kann...

(Faszinierenderweise kommt mit dem problematischen Gehäuse laut USB TreeView gar keine 10G Verbindung zustande, obwohl das selbe Kabel und Notebook es mit dem anderen Festplattengehäuse schaffen. Nicht dass es bei 1 HDD einen Unterschied machen würde, aber trotzdem...)
 
Zurück
Top