IAStorDataMgrSvc.exe verursacht konstant 50% CPU-Auslastung

Dabei seit
Feb. 2010
Beiträge
6
#1
Hi!

Ich habe eine Intel x25-M Postville G2 80GB in meinem Notebook und hatte den Intel RST-Treiber v9.5.6.1001 WHQL-Treiber installiert.

Mein System ist Win7 x64 Pro, die Southbridge ICH9M und die Platte läuft im AHCI-Modus.

Sinn dieses Treibers ist es angeblich, den SSD-Controller dazu zu bringen die Festplatte im Hintergrung zu TRIMmen.

Vor ein paar Tagen ist mir aufgefallen, dass die IAStorDataMgrSvc.exe, die automatisch mit dem System gestartet wird (Teil vom RST, nicht von der ToolBox) konstant ~50% CPU-Auslastung verursacht.

Erst dachte ich, dass sie vielleicht gerade am Trimmen ist, oder die Platte indiziert.
Nach 1-2 Tagen war das aber unwahrscheinlich.

Dann dachte ich an einen Virus.
Alle Scanner meines Vertrauens können das aber nicht bestätigen.

Etliche Neustarts und manuelles Trimmen mit der Toolbox brachten auch keine Veränderung.
Weiterhin 50% Last, und das mit hoher Priorität (also unanbhängig von anderen CPU-Anfragen) in einem unkillbaren Prozess.

Letzte Möglichkeit die mir einfällt ist, dass die Anwendung ins Internet will, aber nicht darf, weil die Windows-Firewall per default neue Anwendungen blockiert... dann könnte sie aber einfach lieb fragen und muss nicht gleich ausrasten.


Google spuckt zu dem Thema nichts aus.
Ich habe den Treiber jetzt erstmal deinstalliert, damit endlich wieder Ruhe im Karton ist.

Wie sind eure Erfahrungen?
Habt ihr auch Probleme mit dem RST-Treiber, speziell mit diesem Service?
Oder hat vielleicht jemand eine Erklärung für oben beschriebenes?


VG Zapp
 

nicoc

Fleet Admiral
Dabei seit
Jan. 2008
Beiträge
10.723
#2
Dabei seit
Mai 2007
Beiträge
2.141
#3
Du kannst auch ganz einfach den Dienst deaktivieren.
 

Anhänge

zappbrannigan

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
6
#4
Sicher könnte ich den Dienst deaktivieren, aber das Verhalten ist mir ein bißchen zu krankhaft um dem ohnehin (noch?) unoffiziellen Treiber zu vertauen.

Also macht der Dienst bei euch keine Probleme?

... Irrtum. Deinstalliere den Storage Manager. Wird nicht gebraucht für Trim. Was du meinst, ist Intel's Toolbox.
Irrtum. Die Toolbox ist zum manuellen TRIMmen da, weil der alte RST-Treiber das nicht automatisch kann.
Und um den Automatismus geht die ganze Aufregung doch... aber du hast wahrscheinlich in sofern recht, da nirgends offiziell bestätigt wird, dass der 9.5.6.1001 wirklich TRIMmen kann.
 

nicoc

Fleet Admiral
Dabei seit
Jan. 2008
Beiträge
10.723
#5
... der RST trimmt nicht (wo steht, dass der Trimmen kann?). Lediglich Win7 trimmt automatisch wenn die Firmware es unterstützt. Und die Toolbox kann man anweisen wann sie automatisiert trimmen soll. Die Frage ist, ob der RST den Trim bei Benützung der Toolbox durch lässt.
 
Zuletzt bearbeitet:

zappbrannigan

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
6
#6
Windows 7 gibt also Bescheid, dass Dateien gelöscht wurden, und die Firmware der Festplatte ist bereit die entsprechenden Zellen zu leeren.

Der Treiber dazwischen reicht den Befehl aber nicht weiter... also ist es grundsätzlich falsch zu behaupten, dass der Treiber nicht trimmen kann?

Na wenn du meinst.

DASS er (jener Treiber, der die bei mir anscheinend defekte IAStorDataMgrSvc.exe mitbringt) den Befehl DURCHLÄSST, wenn du es unbedingt so nennen willst, wird in dem von mir oben verlinkten Thread behauptet und teilweise direkt wieder revidiert.

...Und die Toolbox trimmt soweit ich das verstanden habe unabhängig vom verwendeten Treiber, muss aber separat gestartet werden und hat mit dem Befehl von Windows 7 scheinbar nur noch wenig zu tun.
 

nicoc

Fleet Admiral
Dabei seit
Jan. 2008
Beiträge
10.723
#7
... ist dir aufgefallen, dass ich in dem Link oben auch einige Beiträge gepostet hatte? Der RST (bis zur momentanen Version) lässt den Trim Befehl nicht durch. Win7 trimmt automatisch gibt aber kein Feedback d. h. es lässt sich nur durch Leistungstest, in Abständen von einigen Tagen, feststellen, ob getrimmt wurde (Allerdings muss die Firmware das automatische Trimmen zu lassen. Hierzu musst du die Changelog der FW durch lesen). Die Toolbox kann aber so eingestellt werden, dass sie z. B. einmal pro Tag, Woche etc. trimmt und gibt dir anscheinend eine Rückmeldung. Funktionieren tut das ganze aber (anscheinend) nur mit dem MSAHCI Treiber.
 

René81

Lt. Commander
Dabei seit
Okt. 2008
Beiträge
1.405
#8
Hallo,

ich habe selbiges Problem - 50% CPU Auslastung der IAStorDataMgrSvc.exe.

Hab diesen eigentlich nur für den AHCI Modus installiert. Jetzt stellt sich mir die Frage, brauche ich diesen überhaupt unter W7 ?

mfg
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
44.800
#10
... nein, nicht unbedingt. Im Allgemeinen reicht der Intel-Chipsatztreiber, auch für AHCI.
Im Allgemeinen reicht auch der Microsoft AHCI Treiber.
Hier habe ich was darüber gefunden. Gibt wohl eine Fake Version die ein Virus ist und selbst der echte versuchst wohl via port 80 an 199.7.48.190 (verisign.net) zwecks Certificat Überprüfung zum Update zuzugreifen.
Da Du ja kein RAID hast, kannst Du ihn wohl einfach abschalten und ggf. noch mal bei Virustotal prüfen.
 
Zuletzt bearbeitet:

René81

Lt. Commander
Dabei seit
Okt. 2008
Beiträge
1.405
#12
Danke Jungs.
Habe den Treiber deaktiviert. Die hohe CPU-Auslastung ist weg.

Der Rest funktioniert (gefühlt) wie vorher.

Ein Fake hab ich eher nicht installiert, da der Treiber von der Intelseite war...

mfg

...bei deaktivietem Dienst, funzt dies auch tadellos
 
Zuletzt bearbeitet:
Top