Motorola Moto G - Custom Rom kann nicht geflashed werden

Dan Kirpan

Banned
Dabei seit
Dez. 2008
Beiträge
1.333
Hey,

ich wollte gerade ein Moto G 4G mit einer Custom Rom flashen, aber ich bekomme immer den Fehler:

E:Error executing updater binary in zip '/external_sd/Motorola Moto G/cm-12.1-20151103-NIGHTLY-peregrine.zip'

Ich habe TWRP und CyanogenMod von Peregrine genutzt. Ich hatte das auch schon mal vor 3-4 Monaten gemacht. Ich weiß echt nicht warum es jetzt nicht geht.

CyanogenMod: http://forum.xda-developers.com/moto-g/4g-development/rom-unofficial-cyanogenmod-12-4-4-4-t2951070

Wisst ihr woran das liegen könnte?
 

Dan Kirpan

Banned
Ersteller dieses Themas
Dabei seit
Dez. 2008
Beiträge
1.333
2.8.7.0

Ich glaube ich muss noch mal eine neue drauf flashen, vielleicht war das die falsche. Ist jetzt schon Monate her und ich weiß nicht mehr welche es genau war.

Ich versuch es mal hiermit:

1. http://www.android-hilfe.de/thema/rom-5-x-x-official-cyanogemod-12-x-fuer-moto-g-4g.649995/#post-8514495

2. http://forum.xda-developers.com/moto-g/4g-development/collection-somcom3xs-experimental-corner-t2996266

Wie kann ich noch mal TWRP flashen? Das ist schon ewig her und ich finde im Internet keine Anleitung.
 

Dan Kirpan

Banned
Ersteller dieses Themas
Dabei seit
Dez. 2008
Beiträge
1.333
Das geht über cmd oder? Kannst du mir kurz sagen wie? Ich will da nichts falsch machen :)

Ich habe schon versehentlich das Modem vom Handy gelöscht und kann nicht mehr telefonieren :freaky:

Ergänzung:

Ich habe mir jetzt ADB und Fastboot heruntergeladen, außerdem die Motorola Device USB Treiber installiert. Das Gerät wird aber in Fastboot nicht erkannt, ich sehe aber die Ordner Struktur. Muss ich das Smartphone in einen speziellen Boot Modus bringen um es mit dem image flashen zu können?
 
Zuletzt bearbeitet:

Dan Kirpan

Banned
Ersteller dieses Themas
Dabei seit
Dez. 2008
Beiträge
1.333
Ok das habe ich gemacht. Das Handy wird jetzt auch erkannt.

Ich bekomme aber immer den Fehler "error: cannot load C\Users etc."

Woran liegt das? Der Pfad stimmt auf jedenfall habe das einige male ausprobiert. Auf dem Gerät kommt der Fehler cmd: getvar.partition-type:recovery
 

Hancock

Captain
Dabei seit
Nov. 2007
Beiträge
3.364
Woher weißt du, dass der Pfad stimmt? (Trick, drücke TAB bei einem unvollständigen Namen, dann wird der vervollständigt, falls das nicht passiert, denkt Windows anders als du). Sonst: Falsche Rechte, nach C:\ kopieren und "Jeder" Komplettzugriff geben.
Der cmd: ... Fehler ist laut Internet nicht tragisch/kein Fehler, nur ne Info/Warnung.
 

Dan Kirpan

Banned
Ersteller dieses Themas
Dabei seit
Dez. 2008
Beiträge
1.333
Wow nice hat funktioniert!

DANKEEEEEEE

Oh man endlich :-D Ich hoffe jetzt klappt das auch mit dem Custom Rom

P.S: Mit TWRP kann ich irgendwie nicht flashen. Ich bekomme immer den Fehler E:Error executing updater binary in zip '/external_sd/Motorola Moto G/cm-12.1-20151103-NIGHTLY-peregrine.zip'

Ich habe es jetzt mal per Fastboot probiert. Sah so aus als würde das gehen aber das Handy bootet nicht. Bleibt einfach hängen. Weiß einer was ich falsch mache?
 
Zuletzt bearbeitet:

meav33

Lieutenant
Dabei seit
März 2014
Beiträge
890
Hast du eventuell den cache nicht gelöscht?
Ansonsten probiers doch erst mal mit dem offiziellen cyanogenmod von der cm download seite
 

Hancock

Captain
Dabei seit
Nov. 2007
Beiträge
3.364
Mit fastboot kannst du keine zips flashen, fastboot kann nur Images flashen (Unterschied wie ne RAR ggü. ner iso-Datei).
Wenn da immer nen Fehler kommt, sind die Gründe meist:

Alte/Falsche Recovery: Fürs Moto G gibt's eine mit Encryption-Support (auch wenn du das nicht brauchst), damit hat bei mir das Flashen meist funktioniert: Ich find grad nur den direkten Link https://www.androidfilehost.com/?fid=24052804347771162

Korrupte ZIP: Dateigröße vergleichen, oder noch besser Prüfsumme. Und dann nochmal runterladen.
 

Dan Kirpan

Banned
Ersteller dieses Themas
Dabei seit
Dez. 2008
Beiträge
1.333
Hey,

hat jetzt geklappt. Ich musste den Bootloader selbst akutalisieren. Das war das Problem.
 
Top