Probleme mit Testdisk beim Wiederherstellen, gelöschter Partition

Packy

Lt. Junior Grade
Dabei seit
Nov. 2007
Beiträge
401
Hallo

dummes Missgeschick:

externe 1TB Festplatte NTFS 1 Partition via USB an Win7 angeschlossen und Partition mit EaseUS Partition Master 9.2 verkleinert und direkt eine neue Partition mit 300GB und FAT32 erstellt. Währenddessen ging das USB Kabel raus und nun fragt Windows mich, ob ich die Partition formatieren möchte (angezeigt als 1tb RAW) :o

Danach bin ich direkt mit Testdisk dran und habe die HDD abgesucht, sie wurde gefunden, die Dateien können aber nicht angezeigt werden, weil das Dateisystem nicht gelesen werden kann. Und es sagt mir, dass die Größe nicht passt. Das einfache Schreiben der Partitions Tabelle bringt nichts.
Kann mir jemand helfen, die richtige Größe einzugeben, oder habe ich keine Chance mehr? Das ist meine Backup Festplatte! :freak: Tatsächlich sind 333GB Daten drauf.



test3.JPGtest.JPGtest2.JPG
 
Zuletzt bearbeitet:

puri

Commodore
Dabei seit
Apr. 2011
Beiträge
4.214
Muss irgendwas damit zu tun haben, dass die Platte 4K-Sektoren hat, Testdisk aber von 512B-Sektoren ausgeht, wenn ich das richtig interpretiere. Ist aber wohl schon eine neue Testdisk-Version - müsste die eigentlich selbst sehen.
Probiere mal ein anderes Rettungstool, vielleicht klappts dann.
 

Packy

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
401
Ok ich habe die Daten nach der Tiefensuche gefunden. Testdisk ist in der Tat verwirrt wegen 512/4096 Blocksize.
Ich habe die Part.table geschrieben, bin aber unsicher ob das alles war oder ob ich noch mehr machen muss, weil wenn ich nochmal auf die Platte gehe und mir das anschaue, sieht es so aus:

test erf 2.JPG

Ich habe den ganzen Nachmittag die Anleitungen für Testdisk durchgelesen, und weiß auch wie man die Größen und Werte für die Part. alle ändert, bin mir aber unsicher, was nach dem Schreiben der Parttable nltig ist und was nicht.
Ansonsten werde ich wohl über Nacht alles kopieren und dann formatieren. Aber es ginge sicher komfortabler?

Edit: STRG+C gedrückt und Fenster beim Kopieren aus versehen geschlossen -.- Alles nochmal machen ....... Habe danach auch neugestartet. Nur die Part Table zu schreiben hat also nich gereicht.

Edit2: hat geklappt, bin als nächstes mit CHKDSK /F dran und nun ist alles wieder da :)
 
Zuletzt bearbeitet:
Top