Zahlreichen Distributionen laufen nicht

Verata

Lieutenant
Dabei seit
Apr. 2009
Beiträge
747
Ich versuche seit mehreren Tagen eine stabile Ubuntu 19.04 Installation auf meinen neuen Büro PC zum Laufen zu bekommen, bin mittlerweile sehr ratlos und würde mich sehr über eure Hilfe freuen.
Wenn ich Ubuntu als live System boote oder frisch installiert habe geht, einigermaßen problemlos. Eine Netzwerkverbindung über den Intel Onboard Chip war nicht zu haben, daher habe ich eine Realtake Karte eingebaut und den Onboard Chip deaktiviert.
Nach einigen Neustartvorgängen bleibt immer wieder Gnome hängen. Ich kann dann auch nicht mehr aus Gnome ins Terminal wechseln und muss per Knopf neustarten. Testhalber habe ich KDE installiert. Hier tritt das Problem auch auf. Kubuntu scheitert bereits beim Willkommensbildschirm des Bootsticks, Manjaro bootet gar nicht. Windows 10, das ich für eigene Anwendungen als zweit OS habe läuft absolut stabil.
Ich vermute, dass das Problem im Zusammenhang mit der Grafikkarte steht und habe daher auch die Treiber von Nvidia getestet. Das bringt keine Verbesserung sondern zusätzliche Probleme. Ich bin für jeden Rat sehr dankbar.

€: Problem gelöst, für suchende Lösung unten

Hardware:
CPU: Threadripper 2970WX
MB: MSI X399 SLI Plus
RAM: 64 Gb DDR4
GPU: Nvidia Quadro P400
Montiore: 2x 1920x1080
 
Zuletzt bearbeitet:

Cokocool

Admiral
Dabei seit
Feb. 2009
Beiträge
8.789
Hast du mal Fedora versucht ?
 

RYZ3N

Community-Redakteur
Teammitglied
Dabei seit
Mai 2018
Beiträge
8.688
Da du von einem Büro-/Office-PC sprichst, benötigst du doch sicherlich nicht die neusten Pakete, kannst kannst im Gegensatz dazu aber sicher von einem längerem Support profitieren.

Probier doch mal mit einer LTS-Variante wie z.B. Ubuntu 18.04 LTS. Auf Produktivsystemen habe ich damit ganz gute Erfahrungen gemacht.
 

Verata

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
747
Vielen Dank für eure Hilfe,
Mit dem testen diverser Vorschläge in Sachen Distributionen bin ich noch beschäftigt. Allerdings wäre mein Wunsch Ubuntu zu haben. @ Tuxfriend: Die Idee klang für mich zunächst sehr gut. Leider ist auch hier schon beim booten Schluss. @BFF: Vielen Dank für den link. Das sehe ich mir morgen genauer an. Klingt zumindest nach einem sehr ähnlichen Problem.
 

emeraldmine

Fleet Admiral
Dabei seit
März 2009
Beiträge
24.461

Tornhoof

Cadet 3rd Year
Dabei seit
Juni 2016
Beiträge
44
Du hattest Probleme mit dem Intel NIC auf Linux?
Stell sicher dass das modul igb geladen ist, ansonsten ist das schon komisch. Der I211 ist seit Jahren unterstützt.
 

Ratz_Fatz

Lieutenant
Dabei seit
Mai 2011
Beiträge
805
Vielen Dank für eure Hilfe,
Mit dem testen diverser Vorschläge in Sachen Distributionen bin ich noch beschäftigt. Allerdings wäre mein Wunsch Ubuntu zu haben. @ Tuxfriend: Die Idee klang für mich zunächst sehr gut. Leider ist auch hier schon beim booten Schluss. @BFF: Vielen Dank für den link. Das sehe ich mir morgen genauer an. Klingt zumindest nach einem sehr ähnlichen Problem.
Dann lade dir die Ubuntu 19.10 Beta(Link) runter und teste ob es per Live USB besser läuft. Aktuellere Treiber usw. sind sicher von Vorteil, machen bei meinem AMD 3200G zum Teil einen deutlichen Unterschied aus, wie stabil das System läuft.
Ich verwende hier Fedora 30, erst Ubuntu 19.04 später Ubuntu 19.10 und konnte das bei meinem System gut nachvollziehen.
 

lokon

Lt. Junior Grade
Dabei seit
Aug. 2013
Beiträge
317
Nach einigen Neustartvorgängen bleibt immer wieder Gnome hängen. Ich kann dann auch nicht mehr aus Gnome ins Terminal wechseln und muss per Knopf neustarten.
Ich vermute, dass das Problem im Zusammenhang mit der Grafikkarte steht und habe daher auch die Treiber von Nvidia getestet. Das bringt keine Verbesserung sondern zusätzliche Probleme. Ich bin für jeden Rat sehr dankbar.
Quadro P400 = GP107 = NV137 = "Pascal" Generation

Also mit Ubuntu 18.10 *ohne Nvidia Grafikkarte" wurde bei Phoronix ein Threadripper gebenchmarkt .
Bei Nvidiakarten hat der Nouveau-Treiber zu wenig Entwickler und Tester - eine Quadro Karte ist vlt. seltener ("Workstation Hardware") - siehe HardwareSuche - außerdem hat die Pascal Generation kein "Reclocking" - fehlender Unterstützung durch Nvidia; es gibt keine richtige Hardwareinitialisierung und deshalb ist die Performance von der "Pascal" Generation sehr schlecht (hier, Benchmarks)

Bleibt also der Nvidia Treiber, den du dann nutzen musst - für den Support ist aber Nvidia zuständig - da musst du den Bug melden und dann warten und hoffen, dass er gefixt wird.

Als Tip vielleicht zuerst den graphischen Login/Desktop deaktivieren - mit Ubuntu zB damit , SSH aktivieren und dann prüfen woher die Fehler kommen mit den nvidia Treibern. Mit den Testprogrammen / Logdateien von Xorg solltest du sehen, ob der Nvidia Treiber korrekt geladen wird.

Wenn das zuviel Arbeit / Zeit ist, kannst du natürlich auch darüber nachdenken eine andere Grafikkarte zu organisieren, die von Linux besser unterstützt wird .
 

Verata

Lieutenant
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
747
Ich habe ein Bios Update gemacht und C-State im Bios deaktiviert. Beides ohne Erfolg. Die Vermutung von lokon scheint mir sehr plausibel, sodass ich mir das erst einmal näher ansehen werde. Da ich GPU Performance eigentlich nur unter Windows brauche könnte ich mir auch eine besser laufende Zweitkarte reinsetzen, die ich dann für Linux nehme. Ich melde mich, wenn ich weiß, was bei dem Test raus gekommen ist.

€: Ich habe eine eher verrückte aber stabile Lösung:
Ich habe zusätzlich zur P400 eine FirePro 5800 eingebaut und betrieb unter Ubuntu 19.04 einen Bildschirm an jeder Karte und unter Windows beide an der P400. Unter Ubuntu habe ich zudem Nvidia Treiber auf die Blacklist gesetzt. So geht jetzt alles.

Vielen Dank für eure Hilfe
 
Zuletzt bearbeitet:

lokon

Lt. Junior Grade
Dabei seit
Aug. 2013
Beiträge
317
Wenn in der "Office" 3 Monitore stehen mit Displayport und als weitere Anforderungen kleine Bauform (low profile oder 1 Slot) oder ohne externen Stromanschluss auf der Liste steht - also kein "Leistungsmonster" zum Spielen /3D Grafik gesucht wird, dann ist diese Quadro P400 aktuell sogar das günstigste Modell, dass Geizhals Preisvergleich listet.
 
Top