CD-ROM und DMA Modus

U

Unregistered

Gast
Ich hab ein Problem.
Mein CD-ROM Laufwerk läuft unter WinXP nur im PIO Modus.
Festplatte läuft normal im U-DMA 100 Modus.


Unter Win98 hatte ich damit keine Probleme.
Was muss ich installieren damit der DMA Modus aktiviert wird?
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
61.502
Original erstellt von Unregistered
Mein CD-ROM Laufwerk läuft unter WinXP nur im PIO Modus.
Festplatte läuft normal im U-DMA 100 Modus.
DMA und UDMA sind 2 verschiedene Sachen. XP stellt die Laufwerke automatisch in den Modus, den das Laufwerk unterstützt. Du kannst aber mal sehen unter Eigenschaften im Gerätemanager von Deinem IDE/Atapi-Controller, bei den erweiterten Einstellungen, kann man einstellen, UDMA wenn verfügbar oder Auto. Wenn dein CDRom aber kein UDMA unterstützt, kannst Du den auch nicht einstellen. Die meisten können bloß bis PIO 4, neuere Brenner und CD können UDMA Mode 1 / 2 ( z.B. 24x Brenner, 16x Brenner), oder Multi-Dma Mode (z.B. 12x) Ausserdem muß das Laufwerk dann auch mit einem 80 pol. UDMA Kabel am UDMA Port angeschlossen sein. Bei einem VIA Chip, mußt Du ausserdem noch die Treiber installiert haben, bei den anderen wohl auch.
 
U

Unregistered

Gast
Das Problem ist ja das das CD-ROM nicht mal im DMA läuft.
Unter Win98 lief es ja im DMA Modus.
U-DMA unterstützt es ja gar nicht.
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
61.502
Du verwechselst da 2 Dinge, bei win98 konntest Du wenn ein Laufwerk Direct Memory Acces unterstützt, diesen auch aktivieren, wenn beide am Port angeschlossenen Laufwerke dies können. Auch Laufwerke, die den PIO Mode haben, konnten zur besseren Datenübertragung den DMA-Mode. Unter XP ist dieser Modus aktiviert, mach mal mit einem Programm den Test, wie schnell das Laufwerk unter 98, mit und ohne DMA, ist und unter xp. cu werkam
 

p71

Ensign
Dabei seit
Mai 2001
Beiträge
175
welches board hast du ?
teilweise werden bei älteren boards mit via-chipsatz die cd-roms und brenner nur auf pio4 betrieben.
das hängt vom jeweiligem bios ab, weil die boardher. damit den via-bug umgehen wollen.
allerdings ist es kein prob. die laufwerke auf pio4 laufen zulassen
 
Top