FreeNAS 8.30 - geringe Datenübertragung?

Flo0

Ensign
Dabei seit
Feb. 2011
Beiträge
253
Hallo zusammen,

hab für meinen Vater mit FreeNAS ein NAS zusammengebaut mit Teilen die er noch rumliegen hatte.

Aktuell sind auf dem System 2 Platten als Raid 1 und ZFS eingebunden (aber noch nicht freigegeben)
1 Platte ist als NTFS eingebunden und eine 1 Platte habe ich mal Testwiese als iSCSI eingebunden.

Alle Platten sind WD Green 2TB (5 Stück insgesamt) und das NAS hat 16 GB Ram und ne AMD FM1 CPU (genaue Bezeichnung weiß ich gerade nicht dürfte aber schon nen Quadcore sein)

Unser Komplettes Netzwerk ist auf 1GBit/s ausgelegt.

Als wir nun mal die Transferraten überprüft haben, kamen wir bei ISCSI (bei einem 25GB iso Festplattenabbild) auf Rund 50 MB/s und bei der NTFS Platte auf rund 40MB/s.

Sind die Zahlen ok? Sie kommen mir etwas gering vor. Gibt es Möglichkeiten die Datenübertragung noch zu steigern? Theoretisch sind ja 128 MB/s möglich. Habe in den FreeNAS Foren schon einige Beiträge dazu gelesen das Leute die selben Probleme haben (mit noch niedrigeren Transferraten) aber habe bis jetzt noch keine Lösung dazu gefunden.

mfg
Flo
 

DeusoftheWired

Admiral
Dabei seit
Juni 2009
Beiträge
9.787
Wenn der Test per SMB-Freigabe war: Mit FTP-Freigabe wiederholen und staunen.
Ansonsten Netz mal mit iperf testen.
 

leboh

Ensign
Dabei seit
Mai 2010
Beiträge
167
Wie schon geschrieben: Netzwerk testen, schlechte Gbit Karten liegen oft so bei 50-60MB/s.
Gute bei 120-125.
 

Nilson

Fleet Admiral
Dabei seit
Dez. 2008
Beiträge
18.057
guck mal was dir
Code:
ifconfig -a
ausgibt.

sollte am besten 1000baseT(X) full-duplex ausgeben (das X ist optional, die meisten Karten haben nur T)

40 MB/s hört sich stark nach half-duplex an.
 

Flo0

Ensign
Ersteller dieses Themas
Dabei seit
Feb. 2011
Beiträge
253
Vielen Dank schonmal soweit. Dann tippe ich auf eine Schlechte Netzwerkkarte.

iSCSI wird nicht über SMB freigegeben. (Restlichen jedoch schon werd ich mal auf FTP umstellen)

NAS zeigt auch

media: Ethernet autoselect (1000baseT <full-duplex>) an.
Wie gesagt das gesamte Netz hat 1 GBit/s (der Switch zeigt ja auch nichts anderes an).

Und danke für den Tipp mit iperf ;)
 

Humptidumpti

Moderator
Teammitglied
Dabei seit
Aug. 2004
Beiträge
23.406
Schlechte Netzwerkkarten gibt es quasi seit 10 jahren nicht mehr. Jede popel OnBoard Karte pumpt locker 110MB/s+ durch die Leitung wenn die Treiber stimmen und das System die Datenmenge bereitstellen kann. Dazu benötigt man auch keine spezielle Hardware. Alles möglich mit Budgetkomponenten.

Ich denke eher das FreeNas hier entweder nicht mehr schafft oder es falsch konfiguriert ist. Evtl. limitieren auch die Festplatten. Obwohl das bei 50MB/s eigentlich nicht der Fall sein sollte.

Btw. 125MB/s sind das theoretische Maximum für GBit Netzwerk. Da muss man aber noch den Overhead abziehen. Maximal sind realistisch 113-115MB/s wenn absolut alles passt.

Tante Edith:

SMB über Windows.

Aufnahme1.png
 
Zuletzt bearbeitet:

Flo0

Ensign
Ersteller dieses Themas
Dabei seit
Feb. 2011
Beiträge
253
Ich hab vorhin nochmals mit meiner WD Black getestet. Das iSCSI System hatte 90-125MB/s (Win8 hat kurzzeitig sogar 126MB/s angezeigt, is jedoch unmöglich da wir keine Link Aggregation konfiguriert haben) und auf der SMB Freigabe warns 70-90MB/s könnte wirklich an der Festplatte gelegen haben. Vllt sollte die Festplatte im anderen Rechner mal Raushaun.....

Wir hatten anfangs extreme Probleme (teilweise nur 5MB/s) allerdings scheint es nun besser zu funktionieren.

Danke euch.
 
Top