WOL funktioniert nur teilweise

Domiking

Cadet 1st Year
Dabei seit
Jan. 2019
Beiträge
12
Guten Tag zusammen
Ich habe heute auf meinem Computer das starten mit WOL eingerichtet, dabei habe ich alle Einstellungen im BIOS und in Windows 10 richtig gemacht. WOL funktioniert auch, mit Portweiterleitung auch von extern aus, jedoch mit einem Hacken: es funktioniert nur für 10min nach dem Herunterfahren. Ich habe Fast Startup deaktiviert und wüsste auch keine andere Einstellung, die falsch ist.
Arp-Binding von MAC-Addresse und IP-Addresse ist auf Router gemacht.

LAN-Kabel an AsRock B450 Pro4 Mainboard V3.50
WLAN-Repeater AirTies4930
Router Archer C6 V2


Hat jemand ähnliche Erfahrungen oder eine Lösung oder einen Vorschlag?

Edit: Netzwerkkarte ist auch auf der neusten Version (Realtek)
 
Zuletzt bearbeitet:
Dein Router bekommt vom Provider eine permanente IP Adresse?
Nutzt Du Magic Packet am PC (was an der MAC hängt) oder "any" als Weckgrund?
 
  • Gefällt mir
Reaktionen: Domiking
Zitat von Domiking:
Arp-Binding von MAC-Addresse und IP-Addresse ist auf Router gemacht.
Was meinst du damit? WOL hat nichts mit IP-Adressen zu tun. Man weckt MAC-Adressen auf. Der Router wird nach 10 Minuten Inaktivität in seinem ARP-Cache die Zuordnung MAC-Adresse / IP-Adresse verwerfen.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Domiking und snaxilian
Zitat von Atkatla:
Was meinst du damit? WOL hat nichts mit IP-Adressen zu tun. Man weckt MAC-Adressen auf. Der Router wird nach 10 Minuten Inaktivität in seinem ARP-Cache die Zuordnung MAC-Adresse / IP-Adresse verwerfen.
Ich habe bei meinem Router die MAC-Addresse mit der IP-Addresse verbunden per Arp-Binding (IP ist statisch) damit der Router nicht dem PC einen Arp-request senden muss, dachte das funktioniert so.
Ergänzung ()

Zitat von MyPVR:
Dein Router bekommt vom Provider eine permanente IP Adresse?
Nutzt Du Magic Packet am PC (was an der MAC hängt) oder "any" als Weckgrund?
Ich habe einen dynamischen DNS eingerichtet, nach den 10min in der der PC heruntergefahren ist macht es keinen Unterschied ob ich es mit dem dyndns, der Broadcast Addresse, oder der statischen IP-Addresse des Routers probiere, es klappt nicht mehr.

Folgend Bilder die meine Settings hoffentlich genügend erklärt:
Einstellungen nicht auf den Bildern:
Advanced EEE: Disabled
ARP Offload: Enabled
Auto Disable Gigabit: Disabled
Energy-Efficient Ethernet: Disabled
Green Etherneth: Disabled


Ich verwende also das Magic Packet und nicht "any".
Könnte "any" eine Lösung sein?
Ich kann mir auch gut vorstellen das wie man auf Bild 1 sieht "Allow this computer to turn off this device to save power" der Grund sein könnte, jedoch werden dann die unteren 2 WOL-Einstellungen ausgegraut, was WOL vielleicht ganz ausschaltet.

Edit: Ich habe zum testen die oben gennante Optionen ausgeschaltet, und WOL funktioniert immernoch. Ich werde jetzt testen ob es auch nach einer längeren immernoch funktioniert, womit mein Problem gelöst wäre.
Edit 2: Nach einiger Zeit warten habe ichs nochmal probiert, wieder ohne Erfolg, Problem ist immernoch das gleiche.

Ergänzung ()

Zitat von hans_meiser:
Vielen Dank für deine Hilfe, das Problem wie im oberen Link habe ich jedoch schon mit dem Arp-Binding gelöst, wenn WOL über extern nicht geht gehts auch nicht über intern.
Ich denke das ich den Router als Fehlerquelle ausschliessen kann.
 

Anhänge

  • IMG_20200723_134526.jpg
    IMG_20200723_134526.jpg
    4,4 MB · Aufrufe: 164
  • IMG_20200723_134546__01.jpg
    IMG_20200723_134546__01.jpg
    7,6 MB · Aufrufe: 162
Zuletzt bearbeitet:
WOL Magic Packets werden üblicherweise an den Broadcast verschickt.

Evtl. das Portforwarding auf die 192.168.0.255 legen oder was auch immer die Broadcastadresse ist, falls dein Router das zulässt.
Dann kanns dem Router egal sein ob sein ARP Cache noch da ist oder nicht.

Geht denn WOL von intern noch? Könnte auch ein Power-Save Feature des PCs sein. WOL geht nur aus S1-S5. Nicht aus S6 (komplett aus)
 
  • Gefällt mir
Reaktionen: Domiking
Zitat von h00bi:
WOL Magic Packets werden üblicherweise an den Broadcast verschickt.

Evtl. das Portforwarding auf die 192.168.0.255 legen oder was auch immer die Broadcastadresse ist, falls dein Router das zulässt.
Dann kanns dem Router egal sein ob sein ARP Cache noch da ist oder nicht.

Geht denn WOL von intern noch? Könnte auch ein Power-Save Feature des PCs sein. WOL geht nur aus S1-S5. Nicht aus S6 (komplett aus)
Ich kann bei meinem Router leider kein Port-Forwarding auf eine Broadcast Addresse mache...
Nach den 10min nachdem der PC heruntergefahren ist, geht jedoch auch von intern nichts, egal ob mit Broadcast oder der IP-Addresse, hab alles probiert.
Es könnte sehr gut sein das es etwas mit dem Power-Managament zu tun hat, jedoch wüsste ich nicht was, Stromspareinstellungen sind auf "Maximaler Performance" und er Deep Sleep im BIOS ist Disabled (Ist glaube ich der S6 State)
 
Zitat von Domiking:
Wie schickst du das WOL Signal intern?
Ich kann https://www.heise.de/download/product/magicpacket-87175 zum testen wärmstens empfehlen

Zitat von Domiking:

Dein PC hängt per LAN Kabel am Repeater und der macht eine WLAN Bridge zum Router?
Falls ja, mal mit einem langen Lankabel quer durch den Flur/Treppenhaus direkt am Router gegentesten.
 
  • Gefällt mir
Reaktionen: Domiking
Zitat von h00bi:
Wie schickst du das WOL Signal intern?
Ich kann https://www.heise.de/download/product/magicpacket-87175 zum testen wärmstens empfehlen



Dein PC hängt per LAN Kabel am Repeater und der macht eine WLAN Bridge zum Router?
Falls ja, mal mit einem langen Lankabel quer durch den Flur/Treppenhaus direkt am Router gegentesten.
Ich verwendete bis jetzt immer die Website https://www.depicus.com/wake-on-lan/woli die sich auch mit Parametern in der URL erweitern lässt, ganz praktisch.


Kann ich mal probieren, habe zufällig noch irgendwo ein 20m Kabel rumliegen, Danke.

Edit: Habe das 20m Kabel irgendwo verlegt, und da der Router 2 Stockwerke tiefer als der PC ist wäre die Lösung sowieso nur temporär gewesen, ich werde den Hersteller des Repeaters mal anschreiben ob seine Repeater eine Funktion hat die mein WOL möglicherweise abzwackt.
 
Zuletzt bearbeitet:
Zurück
Top