VMware Workstation und VLAN möglich?

Bob.Dig

Captain
Registriert
Dez. 2006
Beiträge
3.952
Ich möchte in einer VM mit VMware Workstation VLAN nutzen, in der Gestalt, dass der Host selbst kein VLAN nutzt sondern nur der Guest, über das selbe Kabel. Meine bisherigen Versuche scheiterten, dies nach älteren Anleitungen über einen anderen Netzwerktreiber in der VM zu realisieren. Auf dem Host wird eine Realtek-NIC genutzt. Auch auf dem Host mittels Realtek Utility ein VLAN einzurichten und dann nur dieses für die VM zu nutzen scheiterte (DHCP ging, aber kein Internet-Traffic). Das gleiche nur für den Host funktionierte aber ohne Probleme.

Wer hat es aktuell am Laufen und kann aus erster Hand helfen?
 
Zuletzt bearbeitet:
Was für einen virtuellen Netzwerkadaptertyp (NAT, Bridged, Host-only) verwendest Du in der VM? Erfahrungsgemäß ist Bridged am besten, weil es den Netzwerkverkehr des NIC 1:1 vom Host zur VM durchleitet.
 
Mal mit dem vmxnet3 Adapter, statt dem Standard e1000 Adapter, versucht?
Dort kann man im Treiber der VM ja die VLAN ID einstellen:

2020-08-17 11 46 11.jpg
 
Liegt denn wirklich vom Switchport her das getaggte VLAN welches du verwenden möchtest an?

Wer routet zwischen dem VLAN und dem Internetanschluss?
 
Wo steht denn das Ziel was der Server erreichen soll?
Wenn die VM die VLAN ID hat muss ja auch die andere Seite es haben.
 
Dann solltest du zu dem Zustand zurück bei dem DHCP ging und nur noch das Internet lauffähig machen, das ist bestimmt nur eine fehlende Firewallregel in der pfSense gewesen.
 
Wird nicht funktionieren, denn dein Host kennt keine VLAN Tags und leitet die Pakete statdessen einfach ohne solche auf dein Netzwerk raus...

Eine Variante wäre, virtuelle Adapter mit VLAN tagging auf Windows 10 zu erstellen um diese dann innerhalb von VMware Workstation 1:1 an die VM weiterzureichen. Damit hättest du für jedes VLAN eine virtuelle NIC auf dem Host. Dies funktioniert aber nur mit Windows 10 Pro/Ent.
http://www.wensley.org.uk/vlan

Je nach Host Betriebssystem kann auch ein virtueller NIC mit VLAN tunneling eingerichtet werden, das heisst alle VLAN tags werden zum Gast Betriebssystem weitergeleitet. Dort kannst du dann wie von leipziger1979 beschrieben, eine VLAN ID innerhalb des Gastbetriebssystems setzen.
 
  • Gefällt mir
Reaktionen: JBG und Bob.Dig
d2boxSteve schrieb:
Dann solltest du zu dem Zustand zurück bei dem DHCP ging und nur noch das Internet lauffähig machen, das ist bestimmt nur eine fehlende Firewallregel in der pfSense gewesen.
Leider nein, da ja die selbe Einstellung auf dem Host problemlos lief.

@Eagle_B5 Das sieht mehr wie Hyper-V aus...
 
Zuletzt bearbeitet:
Wenn du den Host in das gewisse VLAN taggst?
Aktuell scheint der Host ja ungetagged im native VLAN zu sein.
 
d2boxSteve schrieb:
Wenn du den Host in das gewisse VLAN taggst?
Genau, mittels des Realtek vlan-Utility.
Ein natives vlan gibt es nicht, würde ich mal behaupten. Zumindest gibt es keine id. Bin aber kein vlan Experte. Das Ganze wird über meinen Asus-Router im AP mode als Switch und der pfSense realisiert. Da scheint es aber nicht zu haken sondern an VMware WS und ggf. Realtek.
 
Alles ohne Tag nennt man native VLAN und das ist üblicherweise bei jedem Gerät die ID1, die muss man aber nicht angeben weil das Netzwerkpaket eben ohne Tag kommt.

Ich würde trotzdem den Zustand mit DHCP wieder herstellen und von da aus weitermachen.

Den Host ungetaggt, bei VMWare in der VM bridge auf die physikalische Netzwerkkarte des Hosts und im Guest eben das VLAN einstellen. So sollte es richtig sein.
 
d2boxSteve schrieb:
Den Host ungetaggt, bei VMWare in der VM bridge auf die physikalische Netzwerkkarte des Hosts und im Guest eben das VLAN einstellen. So sollte es richtig sein.
Genau das geht ja nicht, daher, wer hat es selbst aktuell am Laufen und kann was dazu sagen.
 
Wenn du schon keine Hilfe akzeptierst, dann arbeite dich wenigstens mal ins Thema VLAN ein: zB. damit https://www.admin-magazin.de/Das-Heft/2012/03/VLAN-Grundlagen-virtueller-LANs

Die DHCP IP bekommts du vermutlich von VMware Workstation, je nach Adapter Einstellung dort, scheiterst du dann aber mit deiner restlichen Konfiguration (VLAN/Firewall/etc). Am besten malst du mal ein Bild fürs Verständnis.
 
  • Gefällt mir
Reaktionen: Bob.Dig
Dann lies dir bitte den ersten Satz meines ersten Posts durch...

PS: ich arbeite bei VMware und habe bereits seit 2003 Erfahrungen mit diesen Produkten.
 
  • Gefällt mir
Reaktionen: Roesi und Bob.Dig
Ja sage ich, weil dein Host nichts mit VLAN tags anfangen kann... Du must ihm das beibringen mit Variante 1 oder 2 wie in meinem ersten Post beschrieben. (Wenn dein Gast in ein bestimmtes VLAN rein soll)
 
  • Gefällt mir
Reaktionen: Bob.Dig
Zurück
Oben