Windows XP/2003 - Schreibfehler auf Datenträger

niz

ᴬ7ᵪ
Dabei seit
Nov. 2001
Beiträge
24.292
Ich hatte in letzter Zeit öfter mal das Problem mit Windows XP und jetzt mit Windows 2003 @WS, dass beim Boot der Datenträger aufgrund defekter Indexe repariert werden muss und zwischendurch im Windows folgender Baloontip erscheint:



HDD F: ist jetzt als normale HDD (nicht im Raid) am HPT370 als Sec. Master angeschlossen. Vorher (mit Win XP) hatte ich die Probleme mit Der Prim. Master HDD. Kann es evtl. an einer der Stromversorgungen liegen, die ich mittels Y-Adapter von 1 auf 4 bringen musste? Die Prim. Master Platte am Controller macht jetzt keine Mucken mehr, dafür die Sec. Master. Netzteil müsste mit 351W auch stark genug sein.

Oder woher kommt das, und wie kann ich das evtl. beheben?
 

niz

ᴬ7ᵪ
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
24.292
Jetzt ist es ja eine komplett andere Platte, die die Probleme macht und nicht mehr die, die vorher die Schreibfehler hatte. Vorher war es eine 40GB Maxtor und jetzt nach einem kleinen Umbau ist es ne 80GB IBM. Keine der Platten ist fehlerhaft.
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
63.255
Es ist aber eine komplett andere Platte. Kann es sein, das Du geklont hast und in der MFT falsche Infos stehen, nämlich die der alten Platte? Die MFT ist eine Datei, die von NTFS als Erstes verarbeitet wird.

Lies Dir mal hierzu den Artikel durch:
http://www.id.ethz.ch/Homepage/heim/harddisk/harddisk.htm

Die $MFTMIRR Datei ist eine Sicherheitsmassnahme. Sie enthält eine Kopie der ersten 16 Records der MFT, sie wird von NTFS in der Mitte der Disk gespeichert. Die MFT dagegen liegt in der Nähe des Laufwerkanfangs.

Der Zugriff auf die MFT spielt eine entscheidende Rolle in der Zugriffszeit bei einem NTFS Laufwerk. Da die MFT selber eine Datei ist, kann sie wie alle anderen Dateien auch, fragmentiert werden. Um dies zu Verhindern, wird bei einem neuen NTFS Laufwerk eine gewisse Anzahl Clusters (Standard: 12,5 %) um die MFT herum freigehalten. Dies funktioniert aber nur solange die Disk nicht bis an die Grenzen voll ist, dann werden diese Clusters vom System quasi wieder eingezogen. Auch wenn extrem viele Dateien gespeichert werden und diese Zone nicht mehr für alle MFT-Einträge reicht, entsteht Fragmentierung, da diese Einträge in anderen Bereichen des Laufwerks gespeichert werden müssen.

Unglücklicherweise lässt NTFS keine Defragmentierungs-Software an die Meta Files heran. Die einzige Möglichkeit diese zu defragmentieren scheint aus heutiger Sicht das Imaging des ganzen Laufwerks mit einer Software wie Norton Ghost oder Winimage zu sein, die ihre Images auf Dateibasis erstellen. Die nachstehenden Bilder zeigen links eine Disk die mehrmals mit Diskeeper Version 3 defragmentiert wurde! Rechts das Resultat nach einem Image und dem zurück spielen mit Ghost Version 5.1c SP1. Ghost scheint die weitaus effektivere Defragmentierung zu sein, hat aber offensichtlich auch einen wichtigen Nachteil: Der freigehaltene Platz für die MFT ist verschwunden. Daraus folgt, dass wenn geklont wird, dieses regelmässig wiederholt werden sollte. Dieses Verhalten von Ghost wird noch näher untersucht.

Versuch es mal mit einem Tool wie Diskkeeper zu defragmentieren, andere kenne ich nicht die das können. Du kannst aber auch erst mal die ganze Platte defragmentieren, evtl hilft das schon.
Wenn es sich bei der Platte um einen Dynamischen Datenträger handelt, kannst Du noch ganz andere Probleme mit Datenverlust der gesamten Platte erwarten. Kenne ich.
 

niz

ᴬ7ᵪ
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
24.292
Hmm nein ich habe da nichts geklont. Die Platten sind in der Anschlussreihenfolge geblieben, wie sie mit XP auch waren. Das einzige, was ich vor der Windows 2003 installation verändert habe war, dass ich die Platten aus dem 3 1/2" Käfig mit Winkeln in den 5 1/4" Käfig geschraubt habe. Dabei kann ich nur die Stromanschlüssen vertauscht haben, IDE Kabel sind Haar-genauso, wie vorher angeschlossen.

Fragmentiert ... Da könnte was dran sein. Alle Platten sind im Durchschnitt zu 90% voll und ne Defragmentierung von 240GB ... Ich hab da bisher noch nicht so die ausreichende Lust gehabt... :rolleyes:
 
D

DjDIN0

Gast
Speicherprobleme auch möglich

Daten verluste können auch wegen total zu scharfen Speichersettings im BIOS oder eben Speicherproblemen sein, siehe dazu den Link :

https://www.computerbase.de/forum/t...ersettings-bei-i865pe-875p-datenfehler.40791/

Hate so ähnliche Probleme deswegen, mein Zitat dort : "Das dürfte dann auch die manchmal auftauchenden seltsamen Dateifehler erklären die ich auf der Festplatte manchmal hatte welche ansonsten nie waren, über DMA durch den Speicher geschickt wurden da so manch Daten b.z.w. im Endeffekt Datein korrupt/fehlerhaft geschrieben/gelessen..."

Mal mit MEMTEST : https://www.computerbase.de/downloads/systemtools/memtest86-plus/ wie auch ich dort verwendet habe prüfen.Kommen da auch Errors solltest du was machen, muss jetzt nicht am Speicher liegen aber kann.
 

xxxx

Banned
Dabei seit
Nov. 2002
Beiträge
3.626
@werkam das Ntfs keine Defragmentierungssoftware ran läßt stimmt nicht ganz mit O&O Defrag kannste beim booten den Mft defragmentieren lassen aber nur wenn genug Speicherplatz frei ist.
 

freak01

Commander
Dabei seit
März 2002
Beiträge
2.677
@dunkelangst:

oder lass erst mal chkdsk an die Sache ran:

Eingabeaufforderung
-->
chkdsk X: /f/x

x: steht für das laufwerk, mit /f werden die fehlerbehoben, mit /x wird ein exklusiver Schreibzugriff herbeigeführt --> z.B. laufwerk C: wo windows installiert ist, dieses wird dann beim nächsten start überprüft
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
63.255
Original erstellt von xxxx
@werkam das Ntfs keine Defragmentierungssoftware ran läßt stimmt nicht ganz mit O&O Defrag kannste beim booten den Mft defragmentieren lassen aber nur wenn genug Speicherplatz frei ist.
Du hättest den ganzen Thread lesen sollen, dort steht das Diskkeeper es kann und ich bisher noch kein anderes kenne, welches die MFT defragt. Der Diskkeeper ist auch nicht ganz so teuer wie O&O.

@DunkelAngst
wenn Du 240 GB an Daten auf den Platten hast und bis 90 % voll ist, mußt Du Dich nicht wundern, wenn Fehler in der MFT auftauchen. Erhöhe mal den Wert von 12,5 % des freien Platzes auf 25 %:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Control\FileSystem>>>
Neu > “DWORD-Wert” >>> “NtfsMftZoneReservation”
“1” = 12.5 % des freien Festplattenplatzes (Standard - Bereits eingestellt)
“2” = 25 % des freien Festplattenplatzes dadurch wird zwar mehr Platz belegt aber die MFT wird um einiges schneller bearbeitet und kann mehr Einträge aufnehmen. Du solltest aber mal etwas Platz auf den Platten schaffen, 10% ist schon ganz schön am Limit.
 

niz

ᴬ7ᵪ
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
24.292
OK. Also zu scharfe Speichertimings können es schonmal nicht sein, da ich in diesem System auf Stabilität gesetzt habe und die Timings alle auf Default stehen. Speicher ist auch getestet und hat keine Fehler.

Mit dem Defragmentieren muss ich wohl noch ein wenig warten. Um zu defragmentieren habe ich nämlich zu wenig Speicherplatz :rolleyes: und bis ich das alles wegbrennen kann, wird auch noch gut Zeit vergehen. Auslagern im Netzwerk fällt auch komplett platt, weil selbst im Netzwerk verteilt nur noch wenige GB frei sind. Ja ich bin halt ein Schludriger, wenns ums brennen geht :D Muss ich halt noch etwas mit den Lese-/Schreibfehlern leben. Zumindest ist keine Platte defekt, was ich vorher angenommen habe, denn jetzt gibt ja die Maxtor Ruhe und eine andere Platte macht den Ärger.

Aber Danke für die Tips! Ich werd zum gegebenen Zeitpunkt drauf zurückkommen. :daumen:
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
63.255
An Deiner Stelle würde ich nicht zu lange schludern, Du könntest es evtl bereuen. Räume doch mal ein wenig auf, kann auch schon etwas an Platz bringen. Papierkorb verkleinern, Temp Ordner leeren, Auslagerung kleiner machen, hilft auf jeden Fall erstmal den Fehler zu beheben.
 

HotShot

Lt. Commander
Dabei seit
Juli 2003
Beiträge
1.025
Ic habe auch Datenverlust beim Schreiben auf der Platte. Die Platte ist nagelneu (80GB Maxtor S-ATA). Die primäre Partition ist 10GB groß - also genug Platz für XP.

Unmittelbar nach der Installation war alles iO. und auch beim Installieren von Software usw. war alles ok. Aber beim Booten am nächsten Morgen gings dann los. Dauernd die Fehlermeldung. Scandisk hat keine physischen Fehler gefunden und auch keine im Dateisystem. Ich bin im Moment ziemlich ratlos.

Das Kabel der Festplatte habe ich auch schon ausgetauscht. Auch am 2. S-ATA Port habe ichs probiert. Nichts davon hat geholfen.
 

niz

ᴬ7ᵪ
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
24.292
Wie vermutet liegt es bei mir an der Y-Kabel-Verteilung. Mit anderen Y-Adaptern oder jetzt einem anderen Netzteil funktioniert alles Problemlos. Wie ich darauf gekommen bin? Case offen gehabt, und als wieder mal ein Schreibfehler auftrat - kombiniert :p Zum selben Zeitpunkt gingen nämlich 4 Festplatten einfach aus und wieder an. Kann ja dann nur der Strom sein. Jetzt hab ich Ruhe :)
 

098529812

Lt. Commander
Dabei seit
Juli 2003
Beiträge
1.331
hast du eine ATI Grafikkarte im System ???
gehe unter Systemeigenschaften/Leistungsoptionen/Erweitert
ändere den Eintrag Speichernutzung auf Programme
dann müßten die Probleme verschwinden
 
Zuletzt bearbeitet:

niz

ᴬ7ᵪ
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
24.292
also ich nicht. da ist momentan eine GF FX verbaut. aber wie gesagt lag es bei mir an der stromzufuhr.
 
Top