Shutdown - Vorgang dauert ewig. Ursachen?

Yaakov

Ensign
Dabei seit
März 2004
Beiträge
142
Hi Leute,
hab windows xp professional mit sp3. seit dem ich alles eingerichtet hatte, ist der shutdown-vorgang langsamer geworden. jetzt dauert es fast eine minute bis der rechner sich ausschaltet. es laufen aber nicht viele programme im hintergrund, da ich sie immer aus dem systray entnehme! hat jemand irgendwelche vorschläge?

mfg Yaakov
 

Loopo

Admiral
Dabei seit
Juli 2002
Beiträge
7.610
seit wann gibt's den SP 3 denn offiziell !? :D

hast du Logitech-Treiber installiert !?
 

Zer0

Cadet 3rd Year
Dabei seit
Feb. 2004
Beiträge
60
SP3???

xp antispy>" Auslagerungsdatei beim Herrunterfahren löschen" aktiviert?
 

phil.

Just for a visit
Teammitglied
Dabei seit
Feb. 2004
Beiträge
27.991
Willkommen Yaako,

das ist schon fast normal, daß es je mehr man installiert der Start aber auch das beenden von Windows länger wird.
Eine Minute ist doch noch schon ganz gut ;)
Ich gehe einmal davon aus, daß du nicht an der Registrierung gedreht hast um die Auslagerungsdatei zu überschreiben. Danach dauert der Shutdownvorgang wirklich lange.
 

Twisterking

Lt. Commander
Dabei seit
Jan. 2004
Beiträge
1.715
Dass mit den vielen Programmen installiert stimmt nicht immer!
Ich hab' so in etwa 8-10 Programme im Hintergrund und in der System-Tray laufen und mein PC is nach 5- max. 8 sek nach dem drücken der "Shutdown-Buttons" komplett aus!
Schreib' dochmal, WAS für Programme du inst. hast / die im Hintergrund (möglicherweise) mitlaufen! Denn wie gesagt: 1 Min. is schon arg lange!
Und wie schon gesagt wurde: Falls du XP Antispy hast, die Opt. "Schnelles Herunterfahren" aktivieren!
Und vielleicht mal ChDsk, defrag., und mit Registry Tools mal ein wenig aufräumen (wie zB PageDeFrag)!

Gruß
Twist
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.081
Das herunterfahren so lange dauert, liegt daran, dass Windows eine Wartepause einlegt bis Programm geschlossen werden, wenn sie nicht mehr reagieren, das kann man einstellen in der Registry.

HKEY_CURRENT_USER\ Control Panel\ Desktop\

Stelle hier den "AutoEndTasks" als Datentyp REG_SZ auf "1"

Bedenke aber, dass nun alle Anwendungen einfach beendet werden, wenn Du z. B. den Rechner herunterfährst. Das kann natürlich mit geöffneten Dateien zu Datenverlusten führen.

Wenn eine Anwendung sich aufhängt und nicht mehr reagiert, erscheint nach einer gewissen Zeit auch eine Meldung von XP. Diese Wartezeit von Windows kannst Du auch unter folgenden Schlüsseln einstellen:

Durch den Wert "HungAppTimeout" als Datentyp REG_SZ wird die Zeit in Millisekunden angegeben, bis eine Dialogbox mit der Fehlermeldung erscheint. Der Standardwert hierfür ist 5000 Millisekunden, den kannst Du ja mal niedriger einstellen z.B. auf 3000.

Durch einen weiteren Wert "WaitToKillAppTimeout" als Datentyp REG_SZ kannst Du festlegen, nach welcher Zeit eine Applikation beim Herunterfahren automatisch beendet werden soll. Der Standardwert hierfür ist 20000 Millisekunden. Nach Ablauf dieser Zeit wird die Applikation je nach Parameter "AutoEndTasks" entweder mit oder ohne Rückfrage beendet.
Den Wert kannst Du ja mal mit 10000 oder noch niedriger testen.

Zusätzlich dauert es auch lange um die Systemwiederherstellung und das Speicherabbild auf die Platte zu legen wenn der Rechner runterfahren soll, dieses kannst Du auch einstellen.
Geh mal in die Eigenschaften vom Arbeitsplatz>Erweitert >Starten und wiederherstellen und stell es so ein, wie es auf dem Bild eingestellt ist.
 

Yaakov

Ensign
Ersteller dieses Themas
Dabei seit
März 2004
Beiträge
142
jab,.. von xp-antispy hatte ich schon alles aktiviert!!
hab diverse reg-cleaner laufen lassen, sowie bootvis und defragmentierung.



hab nun das ganze wochenende an meinem system rumgespielt, alles probiert was hier geschrieben wurde und selbst noch n bissel probiert. das resultat war, das ich mein system gecrasht habe. nun hab ich xp einfach mal neu installiert und gemerkt, das nachdem ich meine tv-karte installiert habe, auf einmal der shutdown-forgang so lange gedauert hat. kann das evt. an den treibern liegen?außerdem ist die tv-karte (ist ein notebook mein pc) ist nicht immer im karten-schub!
 
Zuletzt bearbeitet:

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.081
Dann solltest Du mal abstellen, dass beim Runterfahren ein gesamtes Speicherabbild gemacht wird. Geht in den Einstellungen, wie schon oben beschrieben.
 
Top